Unable to deploy custom image to WVD

Copper Contributor

So we've been testing WVD in our organization for a about a month, we've had some of the common issues others were having deploying host pools, getting connection errors, etc. We've worked all of that out and can now do personal and pooled deployments, create app groups and deploy applications all without issue.  The problem I'm running into now happens when I do a deployment with a custom image. The deployment finishes successfully but does not attach itself to the WVD service. The machine gets built, I can RDP into it but it doesn't show up in the Remote Desktop Web Client, in powershell the host pool doesn't show in the tenant, nor the management UI. I've also created the image in several different ways. I've used sysprep on one of the machines already deployed in WVD, captured the image from the Azure portal and did a WVD deployment, I've followed the steps in this arcticle, I've also created a machine from the marketplace using the multi user Windows 10 + O365 image, sysprep, and deploying using the VHD URI of the disk. Each one results in the same, the deployment goes through without error, the machine joins the domain and shows up my computers OU, you can RDP to it and use it normally, but it does not show up in RDP and you cant find any trace of the host pools or sessionhosts in powershell using any of the Get-RDS commands. Appreciate any help on this.



8 Replies
Are you happen to deploy your custom image? If so please ensure you follow these steps and install our agent and bootloader:

@Eva Seydl 


Thank you for the reply, I actually managed to get it up and deployed.



@Yipsilon  Nice. What is the issue & resolution? may be of help

@Yipsilon Yes, what was your solution exactly?

best response confirmed by Eva Seydl (Microsoft)

@Yipsilon - I was experiencing the exact same issues.  Get-RdsSessionHost -TenantName $myTenantName -HostPoolName $myHostPool would never return a value.  I tried both UPN and SPN, but neither worked.  What ultimately did it was deploying the custom image and uninstalling all the Remote Desktop Agents including the Geneva Agent. I then installed an older agent using the New-RdsRegistrationInfo token and re-installed the boot loader (although it probably didn't need to be done).  It registers successfully and then automatically re-installs agent 1.0.1288.2700 and the Geneva Agent 42.5.4.

For me it was a piece of software in my image which piece I'm not sure. We deploy our user images fully loaded and something must have been interfering so one by one I took out each package. Eventually we got around the issue by deploying a plain image and scripting the installation of the other software.

@m_grewnow - can you let me what the links were that used to download all the agents? I can't seem to find them online.



I found the agent in the deployed image in this path "C:\DeployAgent\RDInfraAgentInstall".