Unable to add 2016 or 2019 to WVD pool

New Contributor

I have tried to add both 2016 (including SxS manual install) and 2019, they appear in the pool but fail with the same error (see below) after "updating". The original pool and Win10 multi-user machine that was provisioned from the portal is fine. tia.


AllowNewSession : True
Sessions : 0
LastHeartBeat :
AgentVersion : 1.0.407.1
AssignedUser :
OsVersion :
SxSStackVersion :
Status : UpgradeFailed
UpdateState : Failed
LastUpdateTime : 5/3/2019 10:27:32 PM
UpdateErrorMessage : UpdateAgentSxSStackAsync - InstallMSIException Microsoft.RDInfra.RDAgent.Service.InstallMSIException: Fatal error during installation.
at Microsoft.RDInfra.RDAgent.Service.MsiInstallerHelper.LaunchMSIExec(String msiArgs, TimeSpan timeSpan, ILogger logger, Boolean reportFailures) in
C:\agent\_work\1\s\src\RDAgent\src\Service\AgentUpdateClasses\AgentUpdateCommon.cs:line 81
at Microsoft.RDInfra.RDAgent.Service.SxSStackInstaller.InstallMSI(String msiFilePath) in
C:\agent\_work\1\s\src\RDAgent\src\Service\AgentUpdateClasses\SxSStackInstaller.cs:line 62
at Microsoft.RDInfra.RDAgent.Service.RDAgentUpdateHandler.<UpdateAgentSxSStackAsync>d__55.MoveNext() in
C:\agent\_work\1\s\src\RDAgent\src\Service\AgentUpdateClasses\RDAgentUpdateHandler.cs:line 426

2 Replies
I cloned the original W10 vm and was able to add that to the pool. I would still like to know how to add a marketplace 2016 or 2019.

@rich_wsCheck the Event Log on the new server. You probably need to install the Remote Desktop Session Host role.



Add-WindowsFeature RDS-RD-Server