Unable to access host pool

Brass Contributor

I have run the steps in the tutorial 


and provisioned a host pool via marketplace and it appears to have deployed successfully e.g. I have the RDS VM created. 

The users I assigned in the Basics blade get the following using the web client 'looks like your Admin hasn't set up any resources for you yet' with similar message for thick client.

PowerShell sign in with Add-RdsAccount using either service principle or the account used to create tenant and I can run Get-RdsTenant ok with tenant name returned, when I run Get-RdsHostPool with that tenant name it return nothing - possibly a permissions issue of some sort?

Get-RdsDiagnosticActivities only brings back one management activity.


I can then create a new host pool using New-RdsHostPool and Get-RdsHostPool returns it so potentially I can go though the host pool provisioning with PowerShell but ideally would like get marketplace provisioning working.






2 Replies

@Chris Johnston : Hmmm....after you ran the Azure Marketplace offering, were there any errors? If no host pools ended up getting created, then most likely there was some permissions issue, but at least it should have thrown an error.


Definitely log in 1 more time with your service principal on your local system and make sure it has access to that host pool you created. Once you can confirm that, please try and run the Azure Marketplace offering one more time and let me know if it works.

@Christian_Montoya the deployment has failed on domain join. AD UPN was an onmicrosoft.com account so I needed to expand out the domain section on the template and enter it. (domain is derived from UPN if you don't enter a domain so in my case the derived domain was incorrect)

Once I did that it all worked fine.