The client cannot connect to the destination specified in the request

Occasional Contributor

I'm getting the following error when deploying.  The VM's join the domain just fine.


"error": { "code": "VMExtensionProvisioningError", "message": "VM has reported a failure when processing extension 'dscextension'. Error message: \"DSC Configuration 'FirstSessionHost' completed with error(s). Following are the first few: The client cannot connect to the destination specified in the request. Verify that the service on the destination is running and is accepting requests. Consult the logs and documentation for the WS-Management service running on the destination, most commonly IIS or WinRM.



Can someone let me know what I'm supposed to be troubleshooting?  It's not clear what destination machine is.

7 Replies

@chad Snelson : Did you end up troubleshooting or redeploying and getting a working host pool?


In the Azure portal, it should specify which virtual machine was attempting to run this configuration, so you could troubleshoot that VM, as long as you have a connection to that machine. Typically, these errors occur from permissions issues. Since the beginning of May, we listened to feedback and re-ordered the "Tutorial" docs to mitigate these issues. You can check out our tutorials again at and should be able to complete this task now.

@Christian_Montoya I tried redeploying several times and it always failed.  I haven't tried since my first post.  I'll go back through the tutorial and let you know if I have success.  Thanks for the reply!

I just redeployed and got the same error. What would you recommend at this point?

@chad Snelson : The first step I'd take is to do a manual deployment to get a single VM running, and see if that works. From there, you should be able to verify the (1) domain join, (2) logging into the Windows Virtual Desktop PowerShell to create a host pool and registration token and (3) installing the Agents with the registration token.

Hello @chad Snelson 


Were you ever able to resolve this? If so can you please help me! I am having the same issue!


Thank you

@Marco41 I've got the same issue when my Session host where deploy in an OU with configuration GPO.

I deploy a new one in an OU without GPO Applies and it's OK.


Hope it's helping you.


Thanks for the tip.  This suggestion worked for me too!