Template validation error when creating host pool

Occasional Contributor

This has just started happening today. I'm using the WVD - Provision A host Pool in the Azure Portal.

 

NOTE:

- Same WVD tenant has been working even up until this morning.

- I'm using a service principal to authenticate. This is also working.

- Using the Windows 10 w/ Office template

 

PROBLEM: I created a host pool earlier, however missed the domain config when setting up the deployment so it failed when trying to join the machine to the domain. I removed the resource group and all related resources in said group leaving my networks etc intact, and configured the deployment again. On validation, I am now getting the following error:

 

 
InvalidTemplate
Deployment template validation failed: 'The template parameter 'baseUrl' is not found.
 
It does not matter which of the supplied templates I use I have the same problem.
 
Any suggestions or further info required?
37 Replies

I've just wiped my WVD tenant and set it up from scratch following along again with the guide here: https://docs.microsoft.com/en-au/azure/virtual-desktop/
Even created a new Service Principal and can log into the WVD tenant with those credentials.
Still having the same issue. I'm guessing MS is working on the VM templates and messed something up? Or am I missing something else.

I have the same issue here :( Logged a ticket irrepective

@WookieGTB 

 

Hi,

 

yesterday everything was working fine, today i have same issue. Hope they are going to fix it soon, need a test deplyoment asap.

 

bR

Hi

I have the same problem. Hoping for a quick resolution.

@Scott_unikdenamrk 

I'm getting this as well. Glad to see it's not just me. I'm guessing the other option is to provision without using the Gallery Image. Has anyone tried that yet?

I have the same problem. Support is declining any help as this is a preview program they say.

@WookieGTB : Thank you for reporting the issue. We are working have identified the issue and working on testing and publishing the fix. 

 

 

Great, thanks. I am hoping to run a client demo with this today so hopefully it is working soon.
@Devan10 If you have any deployment that you have already done successfully, go to the deployments in the deployed RG and redeploy the template from there. It will work for sure.

@Devan10 Looks like it will take us more time to provide the fix for the template. We will keep you updated. 

@Eva Seydl 

 

Just to let you know. I reported this issue through the CSP partner support channel and the Azure support Twitter account and both did reply that this is a preview and therefore no support will be done. I know that the SLA is that way, but if the community reports issues and the official support channels are not willing to help, this will not help anyone. 

 

For my case, we are in the middle of a proof of concept for a customer and after the reactions from the support we can't recommend anymore this offering to them. Yesterday everything went fine and today everything failed while the deployment. 

 

Best, Marco

 

 

@WookieGTBI just want to join in and mention that it has never worked for me, but as of right now, I'm getting those same template errors.  #metoo

@WookieGTB 

 

This is also happening to me. I have tried using different users, images (win10, win10 + office and win server) and different instances with the same result...

@WookieGTB 

Having exactly the same issue, was working not to long ago and suddenly getting this error when trying to create another host pool.

I deployed yesterday a other way. You can create a pool with Az PowerShell. Afterwards you deploy W10 VMs from the Marcetplace and add them with 2 downloadable installers to the pool. You can find the manual on the same place as the other manual.

https://docs.microsoft.com/en-us/azure/virtual-desktop/create-host-pools-powershell
Today I am facing the same issue while creating Host pool from Market place.

@praveenanil regarding the previous deployment template.   It did seem to succeed with the deployment using an existing deployment template but the hosts did not register with the host pool.  This is likely due to user error on my side but at least it got me further along so thanks for the help.   

 

Hopefully this is resolved soon.

@Eva Seydl 

 

Created my own image to use and get the same result, so don't think its an issue with the templates.

 

Was supposed to be building a POC for a customer this week who is interested in deploying this to replace an existing RDS implementation that is under performing, so will be a hard sell if it doesn't get resolved soon.