Start OneDrive when using a RemoteApp in WVD

New Contributor

Hi Guys,


I am testing with WVD in a Lab environment, and everything is working fine. I only have one thing that doesn't seem to work. OneDrive is starting when i'm using the "Full Desktop" mode in WVD, but when i start a RemoteApp, the OneDrive client isn't starting. 


Is this a WVD / FSLogix related issue? And how can i solve this?





73 Replies

@racook . Thanks Again for this. it's working like a champ - the only change i'd like to see is that now it does pop File Explorer when you open an app. Is there any way around that? Will it honor the /background parameter?

@mirthrock Happy to say that RailRunOnce does work. However, It pop open File Explorer when you open an app. It's not the end of the world, but would be nice to find a way around that. I was going to play w/ the background parameter to see if it will work if i reference it in the reg key.



Yes. You'll want to duplicate the entry that is in the normal HKCU\Software\Microsoft\Windows\CurrentVersion\Run key.


REG_SZ: "OneDrive" <path to onedrive.exe> /background

Adding the registry key worked great for me as well, thanks!

@racook /background worked like a champ. thanks again.

Thanks for all the help and input everyone. Just to be clear, Do I have to create the RailRunOnce key under HKLM\SYSTEM\CurrentControlSet\Control\Terminal Servert? It doesn't seem to be an existing key on my Remote Desktop server.

@mirthrock yes,  you have to create both Annotation 2019-10-02 170610.pngthe key and the expandable reg value. see pic. 

@racook Would this also work in a Citrix Published Application environment? We're having the exact issue described, but for HDX sessions, we don't use RemoteApp.


OneDrive works fine in a full Published Desktop, but not in Published Applications.


EDIT: It doesn't appear to work. Seems this is a RemoteApp specific key.

@Cambo380 This only works (as far as I know) with rdpshell.exe which is used for RemoteApps.

FYI about this thread, @Randy Wong. And kudos to @racook for problem solving and providing insight.

Hi Guys,


I'm new here, but also experiencing similar issues with the OneDrive client in our RDS 2019 environment.


Users in our company login to a RDS session which seems to work fine, next they will start a RemoteApp (OneDrive will also start in the background of this RAS session).


As they modify and save files through the RAS session (Excel files, saved on there RAS desktop -> which is the Desktop in OneDrive), these files aren't visible in there RDS session after closing the RemoteApp.


Checking the OneDrive content on a laptop or online ( does show the saved file from the RAS session.


So it seems that the OneDrive client in the RAS environment is synced, but the OneDrive client in the RDS environment isn't. Opening the OneDrive application in the RDS session does trigger a sync and will make the saved files from the RAS session visible in their RDS session.


Note: We are using FSLogix technology with concurrent Profile & O365 containers, also I implemented the reg key as mentioned by @racook 

Who can help me solving this sync issue between our RAS and RDS environment?


@RubenGr Thanks for the post!

It sounds like the OneDrive sync backup feature is not configured on the users RDS, and is configured on the local computer. (or vise-versa)


Review this document and confirm if the OneDrive sync backup feature is configured in both environments.


Hope this helps!

Hi @Jeremy Esposito,


I checked the settings of both OneDrive clients (in RDS & RAS) and they both have the backup feature enabled.

Saving a file on the RAS Desktop works fine, checking the content of my desktop online shows the newly saved file. But after closing the RemoteApp the desktop on the RDS isn't updated, this only happens after logging off the RDS session.


Logging back on the RDS session the desktop is synced and the saved file is availible. I looks like the OneDrive client on RDS won't sync since the client on the RAS did sync earlier.


To test this senario I changed the internet connection on our RAS Server so that it communicates over another ipaddress. And what do you think.... the files are synced directly to the RDS desktop.


Using OneDrive as a remote app isn't necessary or useful because it's not an app that users will interact with (like MS word, excel, etc) and/or access their files from.
Nor does the OneDrive remote app sync to the desktop or remote session.
This is why we have removed OneDrive remote app from the remote desktop list in the latest version.
OD sync is essentially just a utility to keep the files synced to/from the cloud and monitor sync status.
The OneDrive sync client should be running within the WVD session so it will sync files within the session.
Monitoring sync status should also be done within the WVD session or local computer.
When a user is on a local computer and launches an Office remote app (say MS-Word) then goes to File> Open>OneDrive-Tenant OR Sites-Tenant>(some folder), MS-Word uses the O365 connected service to connect to that users OneDrive or SPO site and works with/saves that file in the cloud directly. OneDrive sync client running on the local computer and remote session will then sync the file from the cloud.
In these use-cases, the OneDrive sync client remote app is really not needed.

Hi @Jeremy Esposito,


Sorry for the misunderstanding.,,

I try to explain our scenario again, since WVD isn't available in Europe yet we use the 2019 Remote Desktop Services to let users connect to a Windows 2019 Remote Desktop Server (RDS).


So at the beginning our their workday our users startup their ThinClient and connect to a RDS... on that server I deployed Office 365 ProPlus, Teams machine-wide Installer and the OneDrive client (using the /ALLUSER parameter).


I need this system to be as uniform as it can be, because users from multiple (federated) companies log in to this server.

All other applications (specifically for the different companies) will be published trough multiple Remote App Servers (RAS)

- Company A uses custom application A

- Company B uses custom application B


On these RAS users need to import for example some Excel files which they saved in there Documents of Desktop folders (on the RDS). So therefor I've also deployed OneDrive on the RAS environment.

So for example:

A user is logged in to the RDS and starts RemoteApp A, after it is started this user needs to import a Excel file which he saved on the RDS Desktop (in my opinion only accessible through the OneDrive client, which works fine0). So importing the Excel file from the RDS Desktop, it generates some output (for example a .txt file). The users needs to save this file and wants to use this after closing the RemoteApp. If it is saved on the RAS Desktop without the OneDrive client available it will be saved on the RAS servers desktop where the users can't get to.

The thing is, as the file is saved on the RAS (OneDrive) Desktop, the RemoteApp is closed. Coming back  on the RDS Desktop the .txt file isn't visible. I can trigger a sync by for example create a new folder on the RDS Desktop. Seconds after that the .txt file will become visible. But this isn't a workable way for these normal users.

@RubenGr Thanks for the update and clarification. The scenario you described would need to be further investigated by O365 support. Please file a support case for this issue.



Hi Randy,


Have adding the key: 


Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RailRunonce\


OneDrive \ REG_SZ \ "C:\Program Files (x86)\Microsoft OneDrive\OneDrive.exe" /background


This works for all existing issues - where a profile has been created previously.


However, for any new user during logon the user session will 'hang' on the process "Run Once Wrapper"


The remote desktop client will continue with the message: "Configuring remote session..."


If you kill the Run Once Wrapper the user will login and there doesn't seem to be an issue after that.


Have you or anyone else seen this issue?

@Baljit Aujla  @racook 


I have exactly the same problem. WVD environment with Windows 10 multi-user session custom image (without O365 applications) with latest updates (including 1909 version). No FSLogix in place (we don't use O365 apps within th WVD environment).


Customer has an application (non Microsoft) and wants to access files to open from OneDrive. Installed the OneDrive per machine (latest version) and applied te following reg keys for silent account config;




And the following for remote apps;


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RailRunonce]
"OneDrive"="\"C:\\Program Files (x86)\\Microsoft OneDrive\\OneDrive.exe\" /background"


On question, does the last registry key be a "REG_ZG" or a "REG_EXPAND_SZ" type?


Anyway, in both cases it is not working. If I go within the app to File > Open I see OneDrive, but it is not configured / user is not signed in. I also see the OneDrive system icon from the WVD environment in my local system tray (not logged in). If I publish OneDrive.exe as a RemoteApp and start this app, OneDrive is configired correctly and OneDrive files became also available in the first RemoteApp.


When publising the full desktop everyting is working fine!


One other problem that a have and wat Baljit montioned is the hang on "Preparing Windows". This will take up to 5 minutes! This problem is only with a RemoteApp and not with a Published Desktop. This problem started when installing the OneDrive per Machine installation. If I remove OneDrive from the Hostpool, the problem is gone. No strange errors in the EventLog.


Annotation 2019-11-14 150520.png





Setting EnableADAL=2 fixed the problem regarding RemoteApp for us in a Parallels on-prem environment with Server 2019. Not related(?) but the correct configuration here:
Cannot find any info on what the value “2” means, maybe MS can comment?

@Robin Hobo we have same problem. But this isn't a onedrive problem. For example we use printix in a environment with the same Railrunonce. Also in this case the first logon attempt is stuck. After that it's ok. 

Anyone idea's?