Spring Update 2020 is in Public Preview!


Today we have announced public preview of our next update which comes with several improvements. See here where Brad Anderson and Julia White summarize our most exciting capabilities:https://www.microsoft.com/en-us/microsoft-365/blog/2020/04/30/enable-remote-work-faster-new-windows-...

Get started by navigating to the Azure Portal and search for Windows Virtual Desktop. Our PS module is also available in PSGallery as part of Az module. The ARM API reference is available here - https://github.com/Azure/azure-rest-api-specs/tree/master/specification/desktopvirtualization/resour.... Our documentation is available here - https://docs.microsoft.com/en-us/azure/virtual-desktop/

Note: Existing object created using GA tools will not show up on the portal. You will need to migrate them to ARM object. Migration tool (under implementation) will be provided by the WVD team.

Known issues:

This is the list of open issues we have that will be fixed soon:

  • Assign a user directly to a session host using the portal (mitigation: uses PS cmdlet)
  • Enabling and disabling of validation environment property doesn’t work
  • Export template from creation wizards not working (mitigation: for hostpool template, navigate to hostpool->properties->download template)
  • New-AzWvdWorkspace – at present you need to provide all properties for the PS cmdlet, else it fails - Name, ResourceGroup, Location, Description and Friendlyname
  • Not all doc links on the portal redirects you to the right document location.
64 Replies

Hey @Pavithra Thiruvengadam, have you had a chance to share the documentation if possible? :)

there are couple of issues with the assignment of appgroup to a WorkSpace. 

a) I have 2 appgroups and initially they each belonged to separate WorkSpaces (WS0, and WS1). I disassociated appgroup 0 from ws0 and wanted to add it to ws1. but the portal does not see that I have an un-assigned appgroup.   


b) when I list the Appgroups in the Appgroups blade. the workspace column is blank.


can you advise how to overcome these issues please. 


is the migration process documentation ready?

Can we work on the new portal without affecting the previous one?

We are excited to want to use the new portal without affecting users on the machines of the previous portal.



@Antonio Valdez Cantu 

The new WVD environment is built on azure resource manager (ARM), and does not seem to overlap with the previous WVD environment (hence why the old WVD pools dont show up in the new WVD interface). Our Finance, IT, and Sales WVD pools built on the old WVD environment appears to still be functioning as it was and we've already deployed 2 new pools to the new ARM version of WVD.  So, at least from our experience, you should be safe trying it out.

Existing users will not be affected by using the portal. Your existing environment will not be affected, either.

@Pavithra Thiruvengadam 

We noticed this morning the previous autoscaling instructions for WVD https://docs.microsoft.com/en-us/azure/virtual-desktop/virtual-desktop-fall-2019/set-up-scaling-scri... is only intended for the 2019 fall release of WVD and not the new ARM based WVD. How is this scaling handled in the new WVD environment?

Hi @JeremyWallace ,


good point which I´ve also addressed. For this reason I created an article showing how to perform scaling!



The second article going much more in detail will be released this week. 

Hope this helps you, please leave me a comment if you want to know more.




@patrickkoehler Good morning, I have a quick question about RDP audio redirection in the new release.  I modified the RDP settings in Azure portal for Audio input to On and Audio output to play sound on remote computer, but Microsoft Teams couldn't detect the microphone on local device.  Did I miss anything or should I still redirect audio with powershell.?  thanks!

Hi @Cookiekaikai!


thanks for coming back to me. 

The only reliable way I experienced is to configure the audio capturing and camera redirect via PowerShell even in the new Spring Release.


This is how you can achieve best results:


1. Connect to your Azure Account with Admin rights:


2.  Afterwards check your current RDPProperties of your HostPool. e.g.

Get-AzWvdHostPool -ResourceGroupName %YourRG% -Name %YourHostPool% | fl Name,CustomRDPProperty

3. Now define your RDP Properties into a variable, check the settings that are validated by me:

$rdpproperties = "audiocapturemode:i:1;capture:i:1;audiomode:i:0;camerastoredirect:s:*;redirectclipboard:i:1"

For more RDP settings check out the Microsoft Doc here: https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/clients/rdp-files?con...

4. Apply the settings to your HostPool

Update-AzWvdHostPool -ResourceGroupName %YourRG% -Name %YourHostPool% -CustomRDPProperty $rdpproperties

5. In your Remote Desktop app, click on the three points beside your HostPool and check for update.

6. Connect to your Desktop and see it works!


If I can help you furthermore, please come back to me!



@patrickkoehler   I appreciate the response Patrick!  I was able to get the mic to work by enabling audio redirection on the host using gpedit.  I never had to do this before so it was strange.



We had the same issue so we ran the PS Script instead and did a reboot of the WVD and it worked.

Can someone from the Microsoft team provide an update on this? If there is downtime, which page describes the issue/details/post-mortem info?



@Pavithra Thiruvengadam 


Works great excepting any attempt at administration; I am the Global Administrator for the domain in Azure Active Directory.


When accessed through https://rdweb.wvd.microsoft.com/arm/webclient/index.html; UAC does not accept username@domain.com + Password.


When accessed through RDP; "The connection was denied because the user account is not authorized for remote login".


If unable to elevate privilege via WVD and also unable to set for remote login over RDP; how does one administer the WVD VMs?


Thank you in advance for your time and attention.





I don´t think that this is a WVD issue. 

Did you check your Desktop application group to see if your user / security group is added successfully? 

On the other hand, are there any kind of hardening GPOs enabled which prevent the access via RDP? 






So appreciate the response.


Agreed. WVD is working perfectly and I can go to my desktop at will using my Global Administrator username in the form of jd@domain.com plus the password.


The issue arises AFTER I am ON the WVD desktop where, for instance, I can run [Windows PowerShell].


However, when I run [Windows PowerShell (Admin)], UAC comes up and I can not find any combination of username and password that works.


So I guess the proper question is; "what form of my username and password should I use in WVD for UAC?"


Hopefully that makes sense.


As for direct RDP; when I am on the WVD desktop I can see that the "Enable Remote Desktop" is set to On. I can not change that of course because it also says in red letters, "Sign in as administrator to change this setting". Point being you may be right about a GPO. Apologies as I do not know how to check.


So either resolution would be helpful; either get through UAC in WVD or externally access via RDP.


Thank you in advance for your time and attention.





WVD is GPO and domain level access. So if you have an Enterprise or Domain Admin account. You can open your powershell as administrator with that account.



Thank you for responding, this sounds promising. Unfortunately I am not versed in how to implement the changes you speak of.


What I do know is that I started the PaaS Azure Active Directory Domain Services (AADDS) and it seems to be working perfectly with WVD; and that I am the Global Administrator for mydomain.com.


Hopefully this means that I have the "Domain Account" you referenced; May I trouble you for what to do next? Do I go somewhere in the Azure portal to set something in GPO?


Would I then be able to open PowerShell on the WVD desktop when logged in as administrator?


Anxious to learn ;)





Woo Hoo :)


You put me on the right track. I found the [Groups] in AADDS and put myself into the "AAD DC Administrators" group. Shazam! I was able to load and run PowerShell as Administrator.


Thank you so much for your suggestion.



So will this REST API be updated with the ARM endpoints? https://docs.microsoft.com/en-us/rest/api/virtual-desktop/

At the moment it will only return objects from the original deployment method.

@Pavithra Thiruvengadam Is it possible to add an endpoint manager with MVD