(Solved) Unable to Create New Host Pool VMs [Spring Release]


Wanted to see if anyone is having issues adding new VMs to an already existing host pool in WVD Spring release.


I try to add additional VMs but I receive an error staying that not all required parameters are completed. I review and it appears everything is, there are not many fields to complete when deploying a new VM to an existing host pool.


I am not receiving the red circle on the section missing the parameter like I do when I actually leave something out (e.g. leave out the # of VMs to create, red circle over Virtual Machines, error near the # of VMs required field).


I have replicated this issue when deploying VMs to either region of East US or West India.


Thanks for any input!

13 Replies

I also had a colleague of mine go through the deployment process under their account and had them check my work, they too experience this error.

I have Faced the same error , I had to add a new VM through manually the PowerShell.
The error --> Required parameters are missing , please complete all required from fields .

Thank you

@SherifAzima Are you still experiencing the issue? There was an outage on Monday which stopped VMs from being added to host pools. 

Hi Neil ,
yes , I have just tried to add additional VM using Azure portal it still gives me the same error.

Thank you

@SherifAzima  @Neil McLoughlin 

I am receiving the required resource error still as of this AM as well.


@SherifAzima are you on the fall or spring release? For spring this is the only method I see to expand an existing host pool. Is there a doc for a different process?


In the spring release I do not see the PS command to add create a session host:


I do have a ticket in with Microsoft Premier support, but I know this is still in preview so it will take some time for them to assess and get back to me.


My lab is a spring setup. with regards to the expand the host pool , you could manually expand it.
please find the following URL that demonstrates how to register/add a new VMs to an existing host pool

- create / prepare a VM
- Register the VM into the host pool through the power shell.

Still I can't able to add additional VM through the portal

Thank you in advance.

@SherifAzima I am getting lots of DSC errors when trying to create a new pool. Can anyone advise please?


The DSC Extension received an incorrect input: An error occurred while executing script or module 'Configuration.ps1': The term 'C:\Packages\Plugins\Microsoft.Powershell.DSC\\bin\..\DSCWork\Configuration.0\Configuration.ps1' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.. Please correct the input and retry executing the extension.

@richardredgrave  @SherifAzima @Neil McLoughlin 


Heads up I just got off a call with a Microsoft Support Engineer. There is a known issue that when using the ARM to deploy an additional session host to an existing host pool, that some are receiving an error. Microsoft has been able to reproduce in a test environment, a hot fix is supposed to be pushed out tomorrow 6/19/2020 sometime.


The error the engineer had is slightly different than mine, but similar and he confirmed I was missing no parameters.


MS Engineer error:



My Error:




Microsoft did confirm that creating a VM using the Shared Image Gal, domain joining, then installing the required apps to enroll into the host pool is the current way to add to an existing host pool when this error is encountered. I will post an update tomorrow if the hot fix resolves this for me.

Please check that the host pools aren't be prevented from access the internet . I have check a successfully created Host Pool, I found the following lines
1- Creating Working directory: C:\\Packages\\Plugins\\Microsoft.Powershell.DSC\\\\bin\\..\\DSCWork\\Configuration.0\r\n
2- Downloading
3- Extracting
Executing C:\\Packages\\Plugins\\Microsoft.Powershell.DSC\\\\bin\\..\\DSCWork\\Configuration.0\\Configuration.ps1

at last to confirm this is the problem , please login to the failed VM and check that configuration.ps1 is existed .

Thank you
best response confirmed by CMurphyUSA (Contributor)

@SherifAzima  @richardredgrave  @Neil McLoughlin 


I did a test this morning using the ARM template and all seems to be working after Microsoft applied the hot fix!







Yes , it has been worked with me ,Thank you :)



I have another problem. When adding session host to a pool, I receive the following error: DSC extension part

"status": "Failed",
"error": {
"code": "ResourceDeploymentFailure",
"message": "The resource operation completed with terminal provisioning state 'Failed'.",
"details": [
"code": "VMExtensionProvisioningError",
"message": "VM has reported a failure when processing extension 'dscextension'.
Error message: \"The DSC Extension received an incorrect input:
An error occurred while executing script or module 'Configuration.ps1':
Die Benennung \"C:\\Packages\\Plugins\\Microsoft.Powershell.DSC\\\\bin\\..\\DSCWork\\Configuration.0\\Configuration.ps1\" wurde nicht als Name eines Cmdlet, einer Funktion,
einer Skriptdatei oder eines ausführbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist (sofern enthalten), und wiederholen Sie den Vorgang..\r\n
Please correct the input and retry executing the extension.\"\r\n\r\nMore information on troubleshooting is available at "



From the Below URL , You will find most of Azure WVD creation errors .


As well , You will find the most of DSCextension  errors due to it was not able to get admin access on the VM .


Hence the solution will be provide a username and password have administrative access on the virtual machine .


Also check the scripts was downloaded to this path "C:\\Packages\\Plugins\\Microsoft.Powershell.DSC\\\\bin\\..\\DSCWork\\Configuration.0\\"


Thank you !