Session host VM's Not Found from Host Pool

New Contributor

Hi, I've been playing with the 2020 preview of WVD and I've hit an issue I cannot seem to solve, even by redeploying the host pool. 


Having created the host pool using the template provided and deployed a master image to 4 pooled desktops I am able to see my deployment and assign users to the workspace. In turn I can connect to the pooled desktops using Microsoft Remote Desktop as expected.


The issue is that even though the host pool is listing the 4 session hosts when I select the VM I get an error 'Not Found' blade.


These VM's exist, I can navigate to them through resource group.


This is the location of the 404 error



This is the location of the VM using the VM properties 



I'm not sure if this information is useful, but it's the only thing I could see from the portal.


The problem propogates itself when I come to create a RemoteApp group. It says the host pool does not contain any desktops so I cannot choose any applications. 


I've redeployed on 2 occasions but I keep getting stuck here. Is there any advanced logging I could try to further troubleshoot this issues or has anyone else had a similar experience?


Thanks in advance. 

7 Replies

@Lee Reevell Are your VMs created in a different subscription or resource group than the hostpool? I ask cos the easy fix is to move the VMs to the same subscription or resource group as the hostpool. We should support the different RG or subscription setup but I m trying to uncover if it is indeed a problem to fix (I have tried out different RG and it worked for me).

@Pavithra Thiruvengadam Thanks for your reply.


I can confirm that the VMs are all in the same Resource group as the host-pool and all objects sit within the same subscription. I've removed the deployment again since I last posted and I am having the same issue with the new deployment. 


As the WVD is in the preview the host pool, application group and Workspace are located in East US whereas the rest of my deployment is in UK West (all still in the same RG). Would this have any impact here?


I've also logged this issue with our support contractor. 

@Lee Reevell Thanks for the clarifications. I will provide this for our investigation.

Hey there. I'd like also add MY plug for this issue too. I have this very problem too.


My WVDs are in Canada Central and metadata in USWest 2


@Garthlogic I have opened a high priority bug for this.

@Pavithra Thiruvengadam 

Good Morning Pavithra.  Have you heard anything on this front?


Thank you again.  Hope you have a good weekend.