Remote Desktop Client on Windows 7

New Contributor

We are rolling out WVD for a client where most of their workstations are Windows 7. With the WVD web client printing being so clunky we really want to use the latest installed client for Windows 7 64-bit (version 1.2.945.0).


I have it installed on their workstations however, everyone is getting a message when they click the Subscribe button that says "Something went wrong. We couldn't authenticate you. Please contact technical support for help."


Has anyone seen this and resolved it? If so, what was your resolution?

6 Replies
Hi Todd, this error, unfortunately, does not tell much except most likely you ran into an issue authenticating with AAD. Before recommending next steps we would like to take a look at the client Logs.

Can you zip and upload the client logs from this folder ?

Make sure to close the connection centre/subscription client before collecting the Logs.

@abuZ Todd_Parnell - did this ever get resolved?


I am getting the same error message with a user, all other users in the organisation can access correctly.


The user can authenticate through ADD via other methods, and can access through the web client.


The error happens when they click subscribe (either subscribe button). The logon popup does not show, they then get this error.


Any ideas?


The log file is attached.

@James Bliss @abuZ 


Our end resolution was to ensure the Windows 7 computers were fully and completely patched and up to date. There is apparently one or more patches that resolved the issue, however, we don't know exactly which ones. We simply patched them with every available patch and then they all worked.


- Todd Parnell

@James Bliss  I will take a look at the Logs and get back soon. In the meantime, if this is win7 , do as  @Todd_Parnell  suggests

thanks both for the replies.


this is Windows Server 2016, and all updates have been installed. 

@James Bliss  The Logs are incomplete (no connection related Logs, and Feed subscription Logs without anything useful). It seems like this user still has the clients open when they collected logs which can cause this. Can we repeat the collection with 2 things :

1. Close the connection centre (the visible client that was used to subscribe)

2. From System Tray, goto the Remote Desktop Icon , Right Click and Disconnect All Sessions (see screenshot attached)


Also what is the UPN of the impacted user ? The Logs would have it (if they were complete)