Remote Desktop Client for Spring 2020 WVD doesnt connect but WebClient no issues - NLA issue

%3CLINGO-SUB%20id%3D%22lingo-sub-1398132%22%20slang%3D%22en-US%22%3ERemote%20Desktop%20Client%20for%20Spring%202020%20WVD%20doesnt%20connect%20but%20WebClient%20no%20issues%20-%20NLA%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1398132%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20team%2C%3C%2FP%3E%3CP%3EI%20am%20testing%20WVD%20using%20the%20Spring%202020%20release.%20No%20issues%20in%20deploying%20ADDS%2C%20WVD%20host%20pool%2C%20VMs%2C%20Workspaces%2C%20Apps%20(and%20Desktop).%20No%20issues%20in%20connecting%20to%20these%20resources%20via%20the%20webclient%20using%20the%20feed%20%22%3CA%20href%3D%22https%3A%2F%2Frdweb.wvd.microsoft.com%2Farm%2Fwebclient%2Findex.html%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Frdweb.wvd.microsoft.com%2Farm%2Fwebclient%2Findex.html%3C%2FA%3E%22.%20It%20automatically%20finds%20the%20workplaces%20and%20anything%20%22published%22.%3C%2FP%3E%3CP%3EI%20installed%20the%2064bit%20remote%20desktop%20client%20on%20windows%2010%2C%20it%20also%20automatically%20finds%20all%20the%20workplaces.%20However%2C%20when%20i%20click%20to%20connect%20ony%20app%2C%20i%20get%20the%20error%20with%20NLA.%20%22The%20remote%20computer%20that%20you%20are%20trying%20to%20connect%20to%20requires%20Network%20Level%20Authentication%20(NLA)%2C%20but%20your%20Windows%20domain%20controller%20cannot%20be%20contacted%20to%20perform%20NLA.%20You%20can%20try%20connecting%20to%20the%20remote%20computer%20using%20your%20username%20and%20password%20instead.%22%20(PIC%20attached)%3C%2FP%3E%3CP%3EThe%20VM%20has%20successfully%20joined%20the%20domain%20during%20creation%20and%20i%20have%20no%20issues%20in%20connecting%20via%20the%20webclient.%20I%20have%20changed%20passwords%2C%20recreated%20pools%20etc%20but%20i%20consistently%20get%20the%20same%20error%20with%20the%20desktop%20client.%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20simply%20followed%20the%20wizards%20with%20creation%2C%20and%20not%20used%20any%20personal%20images%2C%20just%20the%20gallery.%3C%2FP%3E%3CP%3Eplease%20help%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E***%20I%20have%20found%20the%20issue%2Fresolution%20****%3C%2FP%3E%3CP%3EThe%20issue%20occurs%20if%20i%20am%20logging%20onto%20my%20PC%20with%20a%20PIN.%20The%20remote%20desktop%20client%20remembers%2Fuses%20the%20last%20login%20process%2Fdetails.%20IE%20If%20i%20have%20logged%20onto%20my%20PC%20with%20a%20PIN%2C%20remote%20desktop%20uses%20that%20authentication%20process.%20When%20i%20click%20on%20the%20app%2Fresource%20in%20remote%20desktop%2C%20i%20am%20asked%20to%20put%20in%20the%20PC%20PIN.%20It%20then%20fails%20with%20the%20NLA.%3C%2FP%3E%3CP%3EResolution%20is%20to%20select%20%22more%20choices%22%20when%20the%20PIN%20window%20comes%20up%2C%20then%20select%20password....%20For%20some%20reason%20its%20wasnt%20obvious%20to%20me..%20for%20hours%2Fdays....%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1405906%22%20slang%3D%22en-US%22%3ERe%3A%20Remote%20Desktop%20Client%20for%20Spring%202020%20WVD%20doesnt%20connect%20but%20WebClient%20no%20issues%20-%20NLA%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1405906%22%20slang%3D%22en-US%22%3EYou%20are%20correct.%20While%20we%20do%20support%20PIN%20login%2C%20it%20only%20works%20if%20the%20local%20PC%20has%20network%20line%20of%20sight%20to%20the%20Domain%20Controller%2C%20otherwise%20you%20have%20to%20use%20username%20and%20password.%3C%2FLINGO-BODY%3E
Regular Visitor

Hi team,

I am testing WVD using the Spring 2020 release. No issues in deploying ADDS, WVD host pool, VMs, Workspaces, Apps (and Desktop). No issues in connecting to these resources via the webclient using the feed "https://rdweb.wvd.microsoft.com/arm/webclient/index.html". It automatically finds the workplaces and anything "published".

I installed the 64bit remote desktop client on windows 10, it also automatically finds all the workplaces. However, when i click to connect ony app, i get the error with NLA. "The remote computer that you are trying to connect to requires Network Level Authentication (NLA), but your Windows domain controller cannot be contacted to perform NLA. You can try connecting to the remote computer using your username and password instead." (PIC attached)

The VM has successfully joined the domain during creation and i have no issues in connecting via the webclient. I have changed passwords, recreated pools etc but i consistently get the same error with the desktop client. 

I have simply followed the wizards with creation, and not used any personal images, just the gallery.

please help :)

 

*** I have found the issue/resolution ****

The issue occurs if i am logging onto my PC with a PIN. The remote desktop client remembers/uses the last login process/details. IE If i have logged onto my PC with a PIN, remote desktop uses that authentication process. When i click on the app/resource in remote desktop, i am asked to put in the PC PIN. It then fails with the NLA.

Resolution is to select "more choices" when the PIN window comes up, then select password.... For some reason its wasnt obvious to me.. for hours/days....

 

1 Reply
You are correct. While we do support PIN login, it only works if the local PC has network line of sight to the Domain Controller, otherwise you have to use username and password.