RDBroker ConnectionFailedUserSIDInformationMismatch

Copper Contributor

Users are currently unable to log on rdweb portal in order to access Windows Virtual Machine. It works friday last week.


Logs show the following error:

ErrorSource: RDBroker

ErrorOperation: OrchestrateSessionHost

ErrorCode: -2146233088

ErrorCodeSymbolic: ConnectionFailedUserSIDInformationMismatch

ErrorMessage: OrchestrateAsync: SID value in the database is different than the value returned in the orchestration reply from the agent for user ≤≥ with Id bd1aea49-675f-4a8c-38aa-08d6cb3d9270. This scenario is not supported - we will not be able to redirect the user session.

ErrorInternal: False

ReportedBy: RDGateway

Time: 02/07/2019 17:06:04


We performed these actions to solve the issue:

  • Stop to synchronized the user
  • Wait for user removal from Azure AD Domain Services
  • Remove with powershell command from Windows Virtual Desktop service
  • Wait 30 min
  • Add user synchronization
  • Wait user in Azure AD domain services
  • Add user in Virtual Desktop service by using powershell command

It still failing with the same error. User not synchronized with azure ad connect works.

8 Replies
best response confirmed by Eva Seydl (Microsoft)

@davidad : Please set-up a validation pool as we have a fix deployed to the validation pools. Learn here how to set those up:


We recommend to make use of Azure Service Health Alerts where you will be notified when the fix is available for production: 

@Eva Seydl thank you for your reply and support

@Eva Seydl Hello Eva, we enabled the ValidationEnv for the pool at true. How many time we need to wait after the agent update on the host pool? And how to force it if possible?


Thank you and best regards.

@davidad: There is no force upgrade feature available today. Upgrades are pushed automatically. We are still working on a proper notification process.

@Eva Seydl OK, so the customer can no longer use the platform, he has to wait for the agent to update himself without knowing when. We don't have another solution?

Hi, would you mind telling me the steps to get that log? We are experiencing issues getting into WVD with our hybrid users also. Thanks!@davidad 

@Eva Seydl 

I didn't have to create new POOL i just ran this command to set my Pool to validation POOL


Set-RdsHostPool -TenantName $myTenantName -Name "contosoHostPool" -ValidationEnv $true

and it is been validation pool since 3 days  but the issue still not resolved 

in Microsoft Docs it said the updates are pushed monthly do we have to wiat for a month

for the updates to be pushed to the POOL or do i need to create new pool


PS C:\Users\Ashraf Ismail> get-RdsHostPool -TenantName MVPPOC

TenantName : MVPPOC
TenantGroupName : Default Tenant Group
HostPoolName : POChost1
FriendlyName : POChost1
Description : Created through ARM template
Persistent : False
CustomRdpProperty :
MaxSessionLimit : 999999
LoadBalancerType : BreadthFirst
ValidationEnv : True
Ring :



from Microsoft docs 

n preview, service updates occur on approximately a monthly cadence. If there are major issues, critical updates will be provided on a more frequent cadence.



@ashro2 : We've been investigating these kinds of issues and just posted this announcement here: .


From your description earlier, it sounds like you match this scenario. If so but you would still like to test, you can create new users sourced from Azure Active Directory, and you should be able to continue testing.