"Please wait for the Windows search" when logging off

Brass Contributor

I noticed when I log off a session host in Remote desktop/WVD, this message displays for about 10 seconds:


And then it finally logs off.

Is this a service I should disable? 


The image was Windows 10 multi session host, 2004

12 Replies



Make sure you are not out of disk space.

Run this query for that WVD

// enter a GB value to check
let setgbvalue = 100;
// Query
where TimeGenerated > ago(1h)
where ObjectName == "LogicalDisk" and CounterName == "Free Megabytes"
where InstanceName !contains "D:"
where InstanceName !contains "HarddiskVolume1"
where InstanceName  !contains "_Total" 
extend FreeSpaceGB = CounterValue/1024
summarize FreeSpace = min(FreeSpaceGB) by Computer, InstanceName
where FreeSpace < setgbvalue

Hi @Jgq85 - I will always recommend disabling Windows Search in your image unless its specifically needed. Using FSLogix helps, but there is definitely a performance impact and you will come across issues like this. 

Disk space looks good no issues there


Hi Neil - I'm seeing conflicting messages about this which has confused me, there are quite a few articles relating to search in multi-user contexts - this one is very handy - https://jkindon.com/2020/03/15/windows-search-in-server-2019-and-multi-session-windows-10/


The thing is, since Win10 2004, and even with search disabled, I'm seeing loads of FSLogix errors in event viewer like the below.


Search catalog mount failed (The security ID structure is invalid.)


Do you know if these errors should be ignored, or if there is a configuration step to prevent FSLogix attempting to include them? I've looked at the RoamSearch reg entry, but believe this should be disabled by default.


Thanks for any help, one for the WVDUG perhaps!


Sorry for thread hijack!

I don't think I have a need for it honestly. I'd rather use "Everything" for searching.
We do have FSLogix. Is Windows Search required for that or something?



Was this ever resolved? I have had a ticket opened for two weeks with Microsoft with no progress. 


Was the solution to just disable both FSLogix RoamSearch and also disable Windows Search? What functionality is lost by doing that?

Has this ever been resolved? I have a client who has this exact same problem and we don't seem to be able to solve this issue, no matter what we try...

@Gotenks  YES!!


Here is what worked for me:


  • login as local admin to the session host
  • open indexing options
  • Advanced
  • File Types
  • under pdf, make sure the radio button for  "index properties only" is checked

Our issue started after installing Adobe and it tried to index inside the documents as well. It kept hanging and changing these indexing filter options resolved it.



@crshovrd Omg that would be awesome! Thank you for sharing!

I'm gonna change that setting and ask the client to turn on Search for testing. I'll keep you updated! *fingers crossed*

@Gotenks Curious if it worked for you? LMK

Hi @crshovrd, I'm sorry for the late reply! I've been sick for a while now...

Today I got in contact with the client and apparantly the issue still remains, even after changing the File Types of PDF... So, back to troubleshooting... :sad:

@Gotenks Bummer. I wish you luck on finding the root cause.