Port redirection

Copper Contributor

Hi everybody

I'm migrating some customer services from on-premise RDP session host to WVD.

Some of the customers are using COM-port redirection to manage local hardware devices from an application running on the rdp session host.

If I run the same application on the WVD host pool, when trying to open the COM port I get:

"unable to open com port error 2". I think it's an application error but I don't see any redirected com device in device manager.

Before starting to check in domain gpo's and other settings, is remote com-port redirection supported using wvd?

I cannot find anything in the docs mentioning it so I'd like to know if it should work or if I have to avoid this solution for customers who need port redirection (unfortunately most of them).


To be more precise. I'm testing a windows 10 enterprise multi-session session host with windows client (not html5).


Thank you in advance

10 Replies

I've found that the problem is only with remoteapp.

With desktop connection the client is correctly forwarding the com ports and the application works correctly without any difference from the "normal" rdp client.

Now I have to find out how to make it work also with remoteapp (if possible) with windows 10 enterprise multi-session..

@setadini2475   Any luck in getting COM ports redirected I have the same issue

@setadini2475 have you managed to get it working with remote apps? facing similar issue (Win10 Ent Multi-session) and have no clue in documentation whether this is supported or not.


I could see that there used to be a setting called redirectcomports:i:1 with standard RDP setup, however based on this documentation enlisting supported custom rdp properties here do not find this property so not sure how COM ports redirection can be enabled in WVD based setup and specifically when using remote apps scenario?


Any inputs on this will be highly appreciated as it could be a deciding factor to go ahead with wvd or not for the customer in our case. @Pavithra Thiruvengadam @Christiaan_Brinkhoff

@bhushangawale com port redirection was missed in the documentation earlier and hence our validation on the portal also excluded it. We are in the process of rolling out the fix. It should be available by end of week. So portal and PS should support it.

@Pavithra Thiruvengadam thanks for confirming. does this mean that currently COM ports are not being redirected and will only work after the fix roll-out over this weekend and should work for remote apps too? will be staying tuned for the fix to get released.

@bhushangawale The settings looked like they were not available through the portal. Now it has been fixed. The fix is available on the portal. Try it out and let me know.

@Pavithra Thiruvengadam It is now accepting the entry of redirectcomports:i:1 on portal, however after saving it, it doesn't show up.

Is it just a portal UI glitch or the setting is not getting applied at all?

@bhushangawale I am not able to repro this. I tried adding redirectcomports:i:1 and saved the properties. When I reloaded the properties page, it was still intact. If you can refresh the browser and try this, I feel it will work.

best response confirmed by Pavithra Thiruvengadam (Microsoft)

@bhushangawale for some reason, I am not seeing your latest response. I did try with the settings you sent. I noticed that redirectcomports was duplicated. so the duplicate was removed.

@Pavithra Thiruvengadam yes that was my bad, sorry for that and appreciate your quick response on this. Yes, the setting seem to be getting saved now. Thanks much!