Outlook showing "need password" authentication dialog isn't shown on Win10 Enterprise multi-session

Copper Contributor



We are having an issue on multiple tenants where Outlook will prompt for a password but the box to put the password in will be hidden and cannot show up.

Interestingly this ONLY has happened where users have multiple mailboxes. This occurs whether the mailboxes are on the same 365 tenant as AVD or not.

If the user has just one mailbox (their own, so the same as their AVD login) it's fine.

The machines are Azure AD hybrid joined using AAD Connect.

Currently a work around we've found that works most of the time is to close outlook, open word and go to account and sign out, from all accounts. Then open up Outlook and the password prompt will show. Occasionally, we will have to create a new email profile for them.

This isn't something that has happened once or twice it has happened many times across many users and on different tenants.


I've tried setting the ADAL reg keys but this just completely breaks it and doesn't even allow us to add the email account.

I've tried the app package thing, but again that hasn't done anything.


I'm desperate for a full fix on this as it's causing me to lose time on other, more important projects and is also causing a hassle for our customers and support staff who constantly have to get this resolved.

We have a customer who is moving 50+ users to AVD very soon and I cannot have 50 people calling every day because of an Outlook issue that shouldn't be an issue.


0 Replies