Outlook Search Not Working - WVD/FSLogix

Occasional Contributor

Hi Everyone,

We use a multi-session win10 environment, for a number of users we have an issue where they cannot search outlook.

It states that the windows search is unavailable despite the service running.

 

My profile however has no issue with searching, would it make any difference that my mailbox is migrated to Exchange online whilst the others are on-prem? We use Outlook for Office 365 desktop client.

 

Clearing the user's FSLogix profiles does not seem to resolve the office, I have not tried to clear a user's 365 container yet. Other users can search despite the message but returns searches in a non-sequential order.

If anyone can assist that would be amazing.

24 Replies

@AT1991 

 

I have the same issue. I have read a few things in regards to this. One is you have to have ROAMSEARCH=2 option set for FSlogix. It does not work. I have also read that With windows 10 MS and Windows 2019 the search service is built in and the option should not be applied. I have tried both. Interesting thing is that I manage these settings with a GPO on all WVD Session host and I can sometimes log into a SH and it works fine, then log off and back onto the same SH and it does not work. Did a complete uninstall and reinstall of most recent FSLogix version. Attempted to manually add settings in registry and use GPO. 

 

I have reached out to MS support and I get two different answers form them as well. 

 

@RYCUL80 

 

Hey mate,

 

Are you noticing events in the event viewer logged by outlook in application logs, event IDs 34 and 35.

See message bodies below:

Event ID 34: Failed to get the Crawl Scope Manager with error=0x80070005.

Event ID 35: Failed to determine if the store is in the crawl scope (error=0x80070005).

 

I have two customers with new WVD implementations and both are plagued with Outlook searching issues in Outlook on the WVD session hosts.

 

I've tried everything I can think of, and I'm tearing my hair out here.

 

Thanks,

Nick

we having the exact same issue with WVD & FSLogix (2.9.7205.27375)

I have the exactly the same issue on 2.9.7349.30108 anyone got any good ideas?

following... have the same issue here

@AT1991  by any chance has anyone found the solution to this? 

I have the same issue.  

I have found you can resolve the issue by making the following change;

File -> Options -> Search -> Uncheck "Improve Search speed by limiting the number of results shown"
 
Does anyone know a way to make this unchecked by default through group policy or registry?

@cjpf_1  thanks ill give that a shot.

@MikeFletcher Did it work in your environment?

Anyone have any success with this? I am also running into this issue.
Windows 10 multisession hosts using FSLogix
Yes, I came across that article. My understanding is Windows 10 multisession already has Multi-user search enabled so no changes are required in FSLogix GPO settings.

Hi all,

 

Microsoft has to confirmed to us that the multi-user search indexing currently has a bug / is a known issue. ETA on a fix is not yet given by MS.

 

However, we received a private fix from them which fixes the problem for testing purposes. In the meantime, we are using this workaround:

- Disable Windows 2019/10 user-based search indexing (HKLM:SOFTWARE\Microsoft\Windows Search "EnablePerUserCatalog" DWORD 0.

- Enable FSlogix search indexing (searchroam = 2 = multi-user search enabled).

 

Although FSlogix search roaming is not supported for Windows 10 / 2019, it works like a charm and fixes Outlook search indexing issues.

 

When MS release a public fix for the bug, we can revert back to the Windows feature. Only inconvenience will be that every user will need to rebuild his search index, but I don't really care.

Same issue but with WVD without FSLogix, any fix for that ? @Marco Brouwer 

@Marco Brouwer 

This workaround fixed PST indexing on 2 AVD hosts I manage. One with FSLogix profiles and one without on Win 10 multi-user OS. 

 

I appreciate the info.

@Smurgen how did you fix it on the host without FSlogix if I may ask?

Is it an environment with just one session host in the farm maybe?

Hi Tikun, i'm sorry, no. Because we use FSlogix to replace the broken Windows functions. If it's an environment with just one host you can revert back to machine-based indexing, but I guess you farm is bigger than one host?

If I get some news from MS about the fix being released, I will post it here. But for now MS won't give me an ETA on this.

@Marco Brouwer Yes, there is only 1 session host. I did enable the FSLogix roaming search setting but can't test it.

I tested logging in and out with a FSLogix profile that has a pst file stored in it. Outlook has to reindex it at every login. If the pst isn't very big this shouldn't be a big deal. The test pst I'm using is 100MB and took about 2 minutes to fully index.