[ NEW ] Windows IT Pro: Getting started: Windows Virtual Desktop ARM-based Azure portal


Getting started: Windows Virtual Desktop ARM-based Azure portal


Windows Virtual Desktop can be a good fit for organizations seeking to enable remote work scenarios. As a result, the new Windows Virtual Desktop Azure Resource Manager (ARM)-based model is now available as a public preview and available to all customers.


In this article, I'd like to cover the deeper technical points that explain how to enroll Windows 10 Enterprise multi-session, including Office 365 ProPlus, via the new Windows Virtual Desktop ARM-based Azure portal—and outline some important things you should know before getting started.


New Azure portal dashboard

The new landing page for Windows Virtual Desktop in the Azure portal (shown below) is clean and simple, and streamlines deployment and management steps. For example, you can now immediately start with the creation of your host pools. Previous steps such as consent and PowerShell creation of the tenant are gone! (I'll talk about this in more detail later in this article.)




Read the complete article here:






11 Replies

Thank you for the great article. I was wondering if you had any help on 2 items:


I followed your previous article before the ARM based version was available. How do I go back and remove the old non-ARM tenant that I assume is still hanging around since I have now created a ARM base tenant. (I have already removed all of the VMs and other objects associated with the old one, just not the old tenant itself and the principle service account that went with it)


On the new ARM based article, I didn't notice any steps to give users the ability to use the full desktop (not RemoteApps). I ask because I have gone through the steps of adding users to the default application group that is setup when you create a pool, but none of those users have access to the desktop. So I assume I am missing something. Image 1 shows that users are assigned in the desktop pool. Image 2 shows one of those same users getting a no resources available message.

A great walk through, thanks much! I am able to Sign in in the Webclient, The Remote Desktop client however fails. The error mentions https://mrs-prod.ame.gbl/mrs-RDInfra-prod that the Organization has not subscribed to or enabled. In previous blogs on this I see this URL in the App Registration in Azure AD. With this deployment the URL is empty and I am not able to fill out the URL Field (in the GUI). Any suggestions?2020-05-06_7-04-11.png

@Jasper Kraak , @Christiaan_Brinkhoff - I am seeing exactly the same, in a new deployment I just attempted this morning.  Works at https://rdweb.wvd.microsoft.com/arm/webclient, fails in the desktop client.  Using RemoteDesktop_1.2.945.0_x64.msi .  I also just opened support ticket # 120050624001359 for.  It feels like there is a missing Enterprise Application here or such?

@DustinHannon @Christiaan_Brinkhoff  I am having the same issue. I can only publish apps, no full desktops

@Mark Ziesemer @Jasper Kraak Same issue here. Let us know the outcome of the support case!

@janpaulplaisier @Jasper Kraak I think I have this working.  Step #1 from the "old" https://docs.microsoft.com/en-us/azure/virtual-desktop/virtual-desktop-fall-2019/tenant-setup-azure-... apparently needs to be carried-over into the new documentation.  I.E., click through to https://login.microsoftonline.com/common/adminconsent?client_id=5a0aa725-4958-4b0c-80a9-34562e23f3b7... .  (Or replace /common/ with a delegated tenant ID, as appropriate.)

@Mark Ziesemer That worked! Thanks man! I forgot from a previous deployment what that step was and assumed it was "automated" in this 2020 Spring update.

@Mark Ziesemer  Thanks! This worked for me too. I also assumed this step wasn't necessary anymore.

Hi -

Thanks for the feedback. I’ve reported all of this and will come back to you shortly.


@Jasper Kraak @janpaulplaisier please register a ticket via the normal procedure. We want to collect the logs and see where this registration process goes wrong. 


We are aware of it and try to solve the issue as soon as possible.