Microsoft WVD Error Message Agent cannot connect to broker with error NOT_FOUND. URL: wss://rdbroke

New Contributor


Hello everyone,

i am currently testing WVD on Azure, and deployed a host pool with 2 vms windows 10 multi session , i installed fslogix and put the registires and tested it and its working fine, however in power shell when i used the following command and got the below results:

 

Get-RdsSessionHost -TenantName $WVDTenantName -HostPoolName $WVDHostPoolName

 

SessionHostName : **-WVD-0.ad.testcrayons.com
TenantName : **-Tenant
TenantGroupName : Default Tenant Group
HostPoolName : **-HostPool
AllowNewSession : False
Sessions : 2
LastHeartBeat : 4/5/2020 2:41:41 PM
AgentVersion : 1.0.1800.1300
AssignedUser :
OsVersion : 10.0.18363
SxSStackVersion : rdp-sxs200326004
Status : Available
UpdateState : Succeeded
LastUpdateTime : 4/5/2020 2:36:39 PM
UpdateErrorMessage : Agent cannot connect to broker with error NOT_FOUND. URL: wss://rdbroker.wvd.microsoft.com//api/rdAgent/v1

SessionHostName : **-1.ad.**.com
TenantName : **-Tenant
TenantGroupName : Default Tenant Group
HostPoolName : **-HostPool
AllowNewSession : True
Sessions : 1
LastHeartBeat : 4/5/2020 2:36:42 PM
AgentVersion : 1.0.1800.1300
AssignedUser :
OsVersion : 10.0.18363
SxSStackVersion : rdp-sxs200326004
Status : Available
UpdateState : Succeeded
LastUpdateTime : 3/31/2020 9:38:24 PM
UpdateErrorMessage :

 

i got the following error message for one of the session hosts only:

 

UpdateErrorMessage : Agent cannot connect to broker with error NOT_FOUND. URL: wss://rdbroker.wvd.microsoft.com//api/rdAgent/v1

 

not sure what is it causing and how it came out of nowhere can someone please advise on this , thanks.

 

8 Replies
Thanks for reporting. This is a output issue. it is already been fixed recently. It should not affect any connection issue.

@Soo Kuan Teo Any additional information on this other than an "output issue"?  I am seeing this as well on a single host and trying to figure out why.  It does not seem to be affecting anything though.

it is powershell output incorrectly. a fix on the powershell output is already on the way.

i also have the same isseue and can only connect to machine throw remote desktop by ip address for machine 

and i can't remote from web portal or throw remote desktop agent 

 

I am facing the similar issue 

Error : Connection not found: RD Agent does not have an active connection to the broker.

 

Get-Rdssessionhost output is given below

 

PS C:\WINDOWS\system32> Get-RdsSessionHost ***tenant ***HP


SessionHostName : ZDVM-0.***.co.nz
TenantName : ***tenant
TenantGroupName : Default Tenant Group
HostPoolName : ***HP
AllowNewSession : False
Sessions : 1
LastHeartBeat : 4/21/2020 10:12:10 AM
AgentVersion : 1.0.1932.3500
AssignedUser : S******.B******@*****.co.nz
OsVersion : 10.0.18363
SxSStackVersion : rdp-sxs200326004
Status : Unavailable
UpdateState : Succeeded
LastUpdateTime : 4/19/2020 7:57:53 PM
UpdateErrorMessage :

Hi Snehanshu, you case is different. your VM status is unavailable.
Can you please start a new thread for you issue? This way other readers don't get confused about your issue with this one.
I tried to check your machine status, I don't get a lot of information about your affected VM. other than it is unhealthy. can you please follow the requirements below?
https://docs.microsoft.com/en-us/azure/virtual-desktop/overview#requirements
Not that I'm aware of. Please start a new thread, and share the output of Get-Rdssessionhost, replace some characters with '*' in your Sessionhostpool name, tenant name, assigned users, to protect your privacy.