Microsoft Teams video/audio calls

Brass Contributor



one of my customer is trying to use Microsoft Teams in WVD to make video/audio calls, and not able to access the mic nor the web cam. The error message saying there is no camera or microphone which is detectable. Is there any way to make this work?

4 Replies



Mic Redirection is not yet supported on WVD. We had to go with another DaaS vendor because of this (250 users). I haven't seen it mentioned as being added any time soon.



Depending on your setup you should be able to make this work. We had a similar issue where we were getting audio, but no mic. Check out this reply in another post:


In our case, the fix was: running a single powershell command, waiting for the change to get propagated to our users, and then a simple disconnect/reconnect on their part. This worked even for our users with USB headsets. The command in our case (after you've already run Add-RdsAccount) was: Set-RdsHostPool -TenantName [wvdtenantname] -HostPoolName [hostpoolname] -CustomRdpProperty "audiocapturemode:i:1"


In the post I linked to, there is a link to Microsoft documentation for all of the RDS properties you can modify in this way. I haven't looked into redirecting cameras, but these properties may be of interest:

  • camerastoredirect:s:value
  • devicestoredirect:s:value
  • encode redirected video capture:i:value
  • redirected video capture encoding quality:i:value


Hi @dbriles Thanks for the reply, I have executed the following commands in power shell.
Get-RdsHostPool -TenantName xyz-HostPoolName abc
Set-RdsHostPool -TenantName xyz-HostPoolName abc-CustomRdpProperty $properties
Do you think this will work? I have actually executed this command yesterday morning but didn't check with the client. 
So after doing this you guys are able to do video calls in Teams?



That looks like it could work, but like I said we only have experience with audio calls through WVD right now - no webcams. If you ran it yesterday and the client has since disconnected and reconnected, definitely get an update from them and see if it worked!