License needed all of a sudden

Occasional Contributor

We have VDI up and running with Windows 10 Enterprise for Virtual Desktop, edition 1903 (upgraded from earlier version I think). When users have been signing into the machine they have been getting a message that no remote licensing server is configured and that the machine will stop functioning after a number of days. Now we are at day 0 and when I sign into the machine it says that it will disconnect me after 60 minutes. 

 

I was under the impression that since it is a Windows 10 machine I wouldn’t need to provide a licensing server?

6 Replies

@Fosselius You are correct, since you are running Windows 10 (Client) there's no need for an RDS license server. We are working on a fix, meanwhile you can follow these instructions for a workaround: 

 

https://docs.microsoft.com/en-us/azure/virtual-desktop/troubleshoot-vm-configuration#remote-licensin...

 

Please let us know whether this helped. 

@Pieter Wigleven (WINDOWS) I’m afraid this broke it completely. Now I’m not able to sign in at all, i get this message when trying now. 

 

8686DACC-8308-4896-83E0-F09F116BC23D.png

@Fosselius Looks like the grace period has expired. Could you remote to the Windows 10 Enterprise multi-session with RDP using the MSTSC /ADMIN parameter. This should probably be done from a VM in the same subnet, e.g. your domain controller. Alternatively assign a temporary public IP to the VM.

 

Next, please make sure all Windows Updates are installed, the latest update should have a mitigation for this. Since the grace period has expired it could be that the update doesn't affect you, please let me know if this is the case. 

@Pieter Wigleven (WINDOWS) I have accessed the server and downloaded the latest updates. Performed a reboot but it had no effect. Version of the operating system is 1903 (Installed on 2019-06-06, OsBuild 18362.418) but the image itself was a earlier version and I can see the feature update in the update history. 

 

Last installed update was KB4517389

@Pieter Wigleven (WINDOWS)  We're also seeing this error. Running 19.03 & updated to the patches released yesterday (Tuesday 10/8/2019, including KB4517389).

 

We followed the instructions at https://docs.microsoft.com/en-us/azure/virtual-desktop/troubleshoot-vm-configuration#remote-licensin...

 

This simply changed the error from "Remote Desktop licensing mode is not configured" to "No remote licensing server is configured".

@Nicholas Semenkovich @Fosselius - we've updated the instructions that can be found under: https://docs.microsoft.com/en-us/azure/virtual-desktop/troubleshoot-vm-configuration#remote-desktop-...

 

Could you please see if this works? Please make sure you disable the Remote Desktop licensing mode. per the instructions.