SOLVED

'joindomain' error with Windows Virtual Desktop

%3CLINGO-SUB%20id%3D%22lingo-sub-1126728%22%20slang%3D%22en-US%22%3E'joindomain'%20error%20with%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1126728%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20single%20vnet%20with%20a%20subnet%20that%20has%20gateway%20and%20a%20subnet%20that%20has%20a%20Domain%20Controller%20successfully%20joined%20to%20our%20on-prem%20domain%20via%20VPN%20tunnel.%26nbsp%3B%3C%2FP%3E%3CP%3EI%20went%20through%20all%20the%20steps%20I've%20found%20online%20to%20getting%20Windows%20Virtual%20Desktop%20going.%3C%2FP%3E%3CP%3EEsssentially%20I've%20gotten%20to%20the%20deploy%20of%20the%20VM%20part%20however%20it%20fails%20with%20joindomain%20error%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CEM%3EVM%20has%20reported%20a%20failure%20when%20processing%20extension%20'joindomain'.%20Error%20message%3A%20%5C%22Exception(s)%20occured%20while%20joining%20Domain....%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20could%20be%20causing%20this%3F%20A%20credential%3F%20I%20know%20it%20has%20permissions.%26nbsp%3B%20Do%20I%20need%20to%20change%20the%20subnet%20that%20this%20WVD%20Host%20Pool%20is%20on%20to%20the%20DNS%20server%20of%20the%20Domain%20Controller%20in%20the%20same%20VNet%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1126768%22%20slang%3D%22en-US%22%3ERe%3A%20'joindomain'%20error%20with%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1126768%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F84477%22%20target%3D%22_blank%22%3E%40John%20Quile%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%20John%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20the%20VM%20in%20the%20same%20vnet%20as%20the%20DC%3F%3C%2FP%3E%3CP%3EWhat%20is%20the%20DNS%20server%20in%20the%20subnet%20where%20the%20WVD%20VM%20is%20created%3F%20The%20domain%20needs%20to%20be%20resolvable.%3C%2FP%3E%3CP%3EAnother%20option%20is%20that%20the%20account%20used%20for%20joining%20the%20WVD%20VM%20to%20the%20domain%20is%20incorrect.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ELooking%20forward%20to%20your%20feedback!%3C%2FP%3E%3CP%3EBR%2C%3C%2FP%3E%3CP%3EDirk%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1127415%22%20slang%3D%22en-US%22%3ERe%3A%20'joindomain'%20error%20with%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1127415%22%20slang%3D%22en-US%22%3EHi%20%2C%3CBR%20%2F%3E%3CBR%20%2F%3EYes%20the%20WVD%20VM%20subnet%20is%20in%20the%20same%20VNET%20as%20the%20DC.%3CBR%20%2F%3EFrom%20on%20prem%20I%20can%20connect%20to%20other%20servers%20(like%20a%20print%20server)%20that%20are%20in%20other%20subnets%20(within%20the%20same%20vNET)%20that%20do%20not%20have%20any%20special%20DNS%20settings%20(they%E2%80%99re%20just%20set%20to%20default).%3CBR%20%2F%3EThe%20only%20place%20I%20have%20a%20DNS%20setting%20pointing%20to%20an%20on-prem%20Domain%20Controller%20is%20on%20the%20NIC%20properties%20of%20the%20DC%20virtual%20machine%20in%20Azure%20(and%20that%E2%80%99s%20not%20in%20Windows%20it%E2%80%99s%20in%20the%20Azure%20DNS%20settings%20for%20the%20VM).%3CBR%20%2F%3EI%E2%80%99m%20not%20reading%20anywhere%20beyond%20that%20to%20need%20DNS%20settings%20for%20WVD%20or%20the%20WVD%20subnet.%20But%20do%20I%20need%20to%3F%20Because%20the%20subnet%20for%20it%20I%20created%20during%20the%20create%20WVD%20pool%20pool%20wizard.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1127437%22%20slang%3D%22en-US%22%3ERe%3A%20'joindomain'%20error%20with%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1127437%22%20slang%3D%22en-US%22%3EAnd%20actually%20I%20just%20realized%20now%20I%20wonder%20if%20it%E2%80%99s%20because%20my%20on-prem%20firewall%20doesn%E2%80%99t%20have%20a%20static%20route%20to%20this%20WVD%20subnet.%20Also%20I%20wonder%20if%20I%20need%20to%20add%20it%20to%20the%20Azure%20DC%20site%20in%20AD.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1127517%22%20slang%3D%22en-US%22%3ERe%3A%20'joindomain'%20error%20with%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1127517%22%20slang%3D%22en-US%22%3E%3CP%3EYou%20mention%20that%20you%20do%20not%20have%20special%20DNS%20settings%20on%20the%20Vnet%20(which%20is%20pointing%20to%20azure%20dns%20instead%20then).%3CBR%20%2F%3E%3CBR%20%2F%3EMake%20sure%20that%20your%20DC%20is%20acting%20as%20the%20DNS%20server%20in%20the%20WVD%20vnet%20so%20your%20domain%20is%20resolvable%20inside%20the%20vnet%20itself.%20I%20would%20retry%20deploying%20the%20VM%20if%20you%20have%20made%20that%20change.%3CBR%20%2F%3EThe%20vnet%20does%20not%20know%20that%20you%20have%20a%20DC%20installed%20in%20it%20which%20is%20acting%20as%20a%20DNS%20server.%3C%2FP%3E%3CP%3EThe%20reason%20why%20these%20things%20aren't%20mentioned%20in%20the%20WVD%20tutorials%20is%20because%20this%20is%20not%20related%20to%20WVD%20(same%20behavior%20on%20every%20azure%20vm)%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1127712%22%20slang%3D%22en-US%22%3ERe%3A%20'joindomain'%20error%20with%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1127712%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F468579%22%20target%3D%22_blank%22%3E%40knowlite%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWell%20I%20set%20the%20DNS%20of%20the%20VM%20DC%20to%20a%20DC%20on-prem.%3C%2FP%3E%3CP%3EBut%20I%20don't%20know%20if%20I%20want%20to%20set%20the%20entire%20VNET%20to%20the%20same%20DNS%2C%20that%20seems%20a%20bit%20much.%3C%2FP%3E%3CP%3EAnd%20I%20can't%20set%20the%20DNS%20on%20a%20NIC%20for%20WVD%20because%20they%20can't%20provision%20for%20me%20to%20get%20to%20their%20NIC%20properties%3F%26nbsp%3B%3C%2FP%3E%3CP%3ESince%20this%20deployment%20fails%2C%20what%20do%20I%20do%3F%20The%20resource%20group%20is%20incomplete%20do%20I%20just%20delete%20it%20and%20start%20over%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1127839%22%20slang%3D%22en-US%22%3ERe%3A%20'joindomain'%20error%20with%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1127839%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F468579%22%20target%3D%22_blank%22%3E%40knowlite%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOk%20so%20I%20manually%20created%20a%20VM%20in%20the%20subnet.%20I%20can%20ping%20the%20IP%20addresses%20of%20my%20on-prem%20and%20the%20Azure%20DCs.%20But%20not%20the%20host%20names.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20I%20need%20to%20set%20DNS%20server%20to%20my%20Dc%20in%20Azure%20for%20the%20VMs%20in%20azure%2C%20but%20can%20i%20do%20that%20upon%20provisioning%20of%20the%20WVD%3F%20Or%20I%20have%20to%20literally%20set%20the%20DC%20as%20THE%20DNS%20server%20for%20the%20entire%20VNet%20just%20so%20this%20one%20subnet%20can%20allow%20WVD's%20to%20join%20the%20domain%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1128209%22%20slang%3D%22en-US%22%3ERe%3A%20'joindomain'%20error%20with%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1128209%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F468579%22%20target%3D%22_blank%22%3E%40knowlite%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20I%20think%20it's%20working%20now%2C%20at%20least%20with%20a%20one-off%20VM%20I%20deployed.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CUL%3E%3CLI%3ECreated%20new%20VNet%20and%20subnet%20for%20the%20WVD%20network%3C%2FLI%3E%3CLI%3ESetup%20peering%20between%20it%20and%20the%20VNet%20that%20has%20the%20Domain%20Controller%20VM%26nbsp%3B%3C%2FLI%3E%3CLI%3ESet%20the%20WVD%20Vnet%20DNS%20server%20to%20the%20IP%20of%20the%20Domain%20Controller%20VM%20in%20the%20other%20VNet%3C%2FLI%3E%3CLI%3EAdded%20on-prem%20Firewall%20static%20route%20to%20the%20new%20WVD%20subnet%3C%2FLI%3E%3CLI%3EI%20can%20join%20it%20to%20the%20domain.%3C%2FLI%3E%3C%2FUL%3E%3CP%3EI'm%20not%20sure%20if%20that's%20the%20best%20route%20or%20not.%26nbsp%3B%3C%2FP%3E%3CP%3EBut%20I%20believe%20that%20will%20fix%20the%20WVD%20Host%20Pool%20deployment.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1129013%22%20slang%3D%22en-US%22%3ERe%3A%20'joindomain'%20error%20with%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1129013%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ELooks%20like%20it's%20all%20working%20now%20after%20the%20mentioned%20solution.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1129026%22%20slang%3D%22en-US%22%3ERe%3A%20'joindomain'%20error%20with%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1129026%22%20slang%3D%22en-US%22%3EGood%20to%20hear%2C%20it%20was%20all%20related%20to%20the%20new%20created%20WVD%20VM%20not%20being%20able%20to%20resolve%20your%20domain%20name.%20As%20a%20default%20vnet%20has%20azure%20dns%2C%20it%20was%20unable%20to%20resolve%20anything%20you%20created.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1129052%22%20slang%3D%22en-US%22%3ERe%3A%20'joindomain'%20error%20with%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1129052%22%20slang%3D%22en-US%22%3EThanks%20again.%20Do%20you%20mind%20if%20you%20could%20point%20me%20in%20the%20direction%20for%20figuring%20out%20the%20following%203%3CBR%20%2F%3Ethings%3F%3F%3CBR%20%2F%3E1.%20When%20I%20login%20to%20%3CA%20href%3D%22https%3A%2F%2Frdweb.wvd.microsoft.com%2Fwebclient%2Findex.html%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Frdweb.wvd.microsoft.com%2Fwebclient%2Findex.html%3C%2FA%3E%2C%20the%20icons%20are%20called%20%22Session%20Desktop%22.%20Is%20there%20a%20way%20to%20rename%20those%3F%3CBR%20%2F%3E2.%20How%20would%20I%20upgrade%20software%2Fapplications%20on%20these%20servers%20for%20users%20who%20will%20be%20using%20them%3F%20Do%20I%20just%20mstsc%20%2Fadmin%20into%20each%20of%20them%20and%20pull%20them%20out%20of%20the%20pool%2C%20then%20upgrade%3F%20or%20does%20each%20user%20get%20individual%20apps%20installed%3F%3CBR%20%2F%3E3.%20I%20use%20Okta%20SAML%2FSSO.%20While%20I%20get%20the%20prompt%20when%20logging%20into%20rdweb%20website%2C%20after%20authentication%20I%20still%20get%20a%20user%2Fpassword%20login%20screen%20so%20it's%20not%20passing%20through%20so%20I%20have%20to%20authenticate%20a%20second%20time.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1129095%22%20slang%3D%22en-US%22%3ERe%3A%20'joindomain'%20error%20with%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1129095%22%20slang%3D%22en-US%22%3E1.Check%20out%20this%20page%3A%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fpowershell%2Fmodule%2Fwindowsvirtualdesktop%2Fset-rdsremotedesktop%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fpowershell%2Fmodule%2Fwindowsvirtualdesktop%2Fset-rdsremotedesktop%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3E2.%20Your%20VM's%20should%20be%20a%201-on-1%20representation%20of%20your%20golden%20image%2C%20you%20should%20be%20able%20to%20update%20the%20golden%20image%2C%20destroy%20your%20WVD%20VM's%20and%20redeploy.%20The%20FSLogix%20profiles%20should%20hold%20the%20user%20data%2C%20not%20the%20WVD%20VM.%20If%20you%20don't%20want%20to%20do%20this%2C%20WVD%20VM's%20are%20also%20manageable%20by%20SCCM%20and%20other%20management%20tools.%3CBR%20%2F%3E%3CBR%20%2F%3E3.%20This%20is%20normal%2C%20when%20using%20the%20remote%20desktop%20app%2C%20it%20will%20cache%20your%20credentials%20so%20you%20don't%20have%20to%20authenticate%20twice%20(altough%20I'm%20not%20sure%20with%20Okta%2C%20haven't%20tested%20that%20myself).%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1129225%22%20slang%3D%22en-US%22%3ERe%3A%20'joindomain'%20error%20with%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1129225%22%20slang%3D%22en-US%22%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F468579%22%20target%3D%22_blank%22%3E%40knowlite%3C%2FA%3E%20thanks%20that%20helps.%20And%20as%20far%20as%20performance%20is%20there%20some%20minor%20lag%20to%20be%20expected%3F%20Just%20wondering%20where%20I%20should%20start%20with%20optimizing%20the%20%E2%80%9Csnapiness%E2%80%9D%20of%20the%20WVD.%20Suppose%20I%20could%20create%20other%20VMs%20to%20compare%20with%20WVD.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1130921%22%20slang%3D%22en-US%22%3ERe%3A%20'joindomain'%20error%20with%20Windows%20Virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1130921%22%20slang%3D%22en-US%22%3EImportant%20are%20the%20local%20disk%20type%20(ssd)%20and%20the%20FSLogix%20profile%20storage.%3CBR%20%2F%3EThe%20actual%20cpu%2Fmemory%20load%20is%20different%20for%20each%20company.%3CBR%20%2F%3EDepending%20on%20how%20many%20users%20you%20would%20want%20to%20squeeze%20on%201%20VM%2C%20the%20VM%20type%20will%20differ.%3C%2FLINGO-BODY%3E
Contributor

I have a single vnet with a subnet that has gateway and a subnet that has a Domain Controller successfully joined to our on-prem domain via VPN tunnel. 

I went through all the steps I've found online to getting Windows Virtual Desktop going.

Esssentially I've gotten to the deploy of the VM part however it fails with joindomain error:

 

VM has reported a failure when processing extension 'joindomain'. Error message: \"Exception(s) occured while joining Domain....

 

What could be causing this? A credential? I know it has permissions.  Do I need to change the subnet that this WVD Host Pool is on to the DNS server of the Domain Controller in the same VNet? 

13 Replies
best response confirmed by John Quile (Contributor)
Solution

@John Quile 

Hi John,

 

Is the VM in the same vnet as the DC?

What is the DNS server in the subnet where the WVD VM is created? The domain needs to be resolvable.

Another option is that the account used for joining the WVD VM to the domain is incorrect.

 

Looking forward to your feedback!

BR,

Dirk

Hi ,

Yes the WVD VM subnet is in the same VNET as the DC.
From on prem I can connect to other servers (like a print server) that are in other subnets (within the same vNET) that do not have any special DNS settings (they’re just set to default).
The only place I have a DNS setting pointing to an on-prem Domain Controller is on the NIC properties of the DC virtual machine in Azure (and that’s not in Windows it’s in the Azure DNS settings for the VM).
I’m not reading anywhere beyond that to need DNS settings for WVD or the WVD subnet. But do I need to? Because the subnet for it I created during the create WVD pool pool wizard.
And actually I just realized now I wonder if it’s because my on-prem firewall doesn’t have a static route to this WVD subnet. Also I wonder if I need to add it to the Azure DC site in AD.

You mention that you do not have special DNS settings on the Vnet (which is pointing to azure dns instead then).

Make sure that your DC is acting as the DNS server in the WVD vnet so your domain is resolvable inside the vnet itself. I would retry deploying the VM if you have made that change.
The vnet does not know that you have a DC installed in it which is acting as a DNS server.

The reason why these things aren't mentioned in the WVD tutorials is because this is not related to WVD (same behavior on every azure vm)

@knowlite 

Well I set the DNS of the VM DC to a DC on-prem.

But I don't know if I want to set the entire VNET to the same DNS, that seems a bit much.

And I can't set the DNS on a NIC for WVD because they can't provision for me to get to their NIC properties? 

Since this deployment fails, what do I do? The resource group is incomplete do I just delete it and start over? 

@knowlite 

Ok so I manually created a VM in the subnet. I can ping the IP addresses of my on-prem and the Azure DCs. But not the host names.  

So I need to set DNS server to my Dc in Azure for the VMs in azure, but can i do that upon provisioning of the WVD? Or I have to literally set the DC as THE DNS server for the entire VNet just so this one subnet can allow WVD's to join the domain? 

@knowlite 

 

So I think it's working now, at least with a one-off VM I deployed.

 

  • Created new VNet and subnet for the WVD network
  • Setup peering between it and the VNet that has the Domain Controller VM 
  • Set the WVD Vnet DNS server to the IP of the Domain Controller VM in the other VNet
  • Added on-prem Firewall static route to the new WVD subnet
  • I can join it to the domain.

I'm not sure if that's the best route or not. 

But I believe that will fix the WVD Host Pool deployment. 

 

Looks like it's all working now after the mentioned solution.

 

Good to hear, it was all related to the new created WVD VM not being able to resolve your domain name. As a default vnet has azure dns, it was unable to resolve anything you created.
Thanks again. Do you mind if you could point me in the direction for figuring out the following 3
things??
1. When I login to https://rdweb.wvd.microsoft.com/webclient/index.html, the icons are called "Session Desktop". Is there a way to rename those?
2. How would I upgrade software/applications on these servers for users who will be using them? Do I just mstsc /admin into each of them and pull them out of the pool, then upgrade? or does each user get individual apps installed?
3. I use Okta SAML/SSO. While I get the prompt when logging into rdweb website, after authentication I still get a user/password login screen so it's not passing through so I have to authenticate a second time.
1.Check out this page:
https://docs.microsoft.com/en-us/powershell/module/windowsvirtualdesktop/set-rdsremotedesktop

2. Your VM's should be a 1-on-1 representation of your golden image, you should be able to update the golden image, destroy your WVD VM's and redeploy. The FSLogix profiles should hold the user data, not the WVD VM. If you don't want to do this, WVD VM's are also manageable by SCCM and other management tools.

3. This is normal, when using the remote desktop app, it will cache your credentials so you don't have to authenticate twice (altough I'm not sure with Okta, haven't tested that myself).
@knowlite thanks that helps. And as far as performance is there some minor lag to be expected? Just wondering where I should start with optimizing the “snapiness” of the WVD. Suppose I could create other VMs to compare with WVD.
Important are the local disk type (ssd) and the FSLogix profile storage.
The actual cpu/memory load is different for each company.
Depending on how many users you would want to squeeze on 1 VM, the VM type will differ.