Internal server error when creating a HostPool


Hi, I'm using the Az.DesktopVirtualization module to create a Host Pool using this command:

New-AzWvdHostPool -Name "testHP" -ResourceGroupName WVDDemoHosts -Location eastus

The Host Pool is created, however I receive the following error in Powershell

New-AzWvdHostPool_CreateExpanded: The server responded with a Server Error, Status: InternalServerError

Is this expected? 




3 Replies

@Gastonlyons Looks like you have not specified -HostPoolType parameter (Personal|Pooled). The error should be better but I would suggest you add this and let me know if you still get that error.

Hi Pavithra,


Thanks for your answer, I'd tried that, but when specifing all the parameters:

New-AzWvdHostPool -Name TestingHostPool -ResourceGroupName WVDDemoHosts -Location eastus -WorkspaceName "TestingWS" -HostPoolType Pooled -LoadBalancerType DepthFirst

I get:

New-AzWvdHostPool_FullSenerioCreate: Cannot bind argument to parameter 'Name' because it is an empty string.

And the Host Pool is not created.


New-AzWvdHostPool -ResourceGroupName <resourcegroupname> -Name <hostpoolname> -WorkspaceName <workspacename> -HostPoolType <Pooled|Personal> -LoadBalancerType <BreadthFirst|DepthFirst|Persistent> -Location <region> -DesktopAppGroupName <appgroupname>