Intermitent issues writing files to Local_Username redirection.xml

%3CLINGO-SUB%20id%3D%22lingo-sub-1812178%22%20slang%3D%22en-US%22%3EIntermitent%20issues%20writing%20files%20to%20Local_Username%20redirection.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1812178%22%20slang%3D%22en-US%22%3E%3CP%3Ehaving%20an%20issue%20with%20Sage%20200%20trying%20to%20write%20a%20file%20into%20FSLogix%20profile%20disk%20so%20moved%20file%20using%20redirection.xml%20to%20local_username%5Cappdata%5Clocal%5C%20and%20it%20has%20successfully%20writes%20the%20folder%20structure%20there%20however%20intermittently%20it%20will%20fail%20on%20one%20file%20stopping%20the%20program%20open%2C%20logging%20users%20off%20and%20onto%20a%20different%20VM%20intermittently%20works%2C%20not%20sure%20if%20its%20an%20FSLogix%20issue%20or%20a%20WVD%20issue%20as%20dont%20have%20the%20issue%20on%20standard%20rdp%20with%20old%20UPD's%20or%20on%20on%20prem%20windows%2010%20machines.%20anyone%20seen%20similar%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1902872%22%20slang%3D%22en-US%22%3ERe%3A%20Intermitent%20issues%20writing%20files%20to%20Local_Username%20redirection.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1902872%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F815477%22%20target%3D%22_blank%22%3E%40StevenR%3C%2FA%3E%26nbsp%3Bwe%20are%20also%20experiencing%20the%20same%20issue%2C%20we%20are%20using%20WVD%20and%20FSLogix%20but%20not%20the%20redirections.xml.%20We%20have%20found%20that%20the%20issue%20moves%20between%20users%20after%20reboots%20and%20after%20using%20process%20monitor%20we%20established%20the%20issue%20arises%20when%20Sage%2F.NET%20attempts%20to%20rename%2Fmerge%20the%20user.config.%20This%20stackoverflow%20displays%20the%20same%20issues%20but%20using%20Citrix%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fstackoverflow.com%2Fquestions%2F64356026%2Fapplicationsettingsbase-save-unable-to-save-config-to-file%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fstackoverflow.com%2Fquestions%2F64356026%2Fapplicationsettingsbase-save-unable-to-save-config-to-file%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHis%20work%20around%20was%20to%20not%20use%20FSLogix%2C%20but%20this%20is%20far%20from%20ideal.%20Hope%20you%20find%20the%20extra%20information%20useful%20(or%20at%20least%20interesting).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20article%20suggests%20a%20development%20solution%2C%20which%20I%20am%20going%20to%20forward%20to%20our%20Sage%20support%20tomorrow.%20Fingers%20crossed%20they%20can%20ask%20Sage%20to%20implement%20a%20fix.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fstackoverflow.com%2Fquestions%2F20946627%2Fhow-to-work-around-localfilesettingsprovider-requiring-full-control-ownerrights%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fstackoverflow.com%2Fquestions%2F20946627%2Fhow-to-work-around-localfilesettingsprovider-requiring-full-control-ownerrights%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1902947%22%20slang%3D%22en-US%22%3ERe%3A%20Intermitent%20issues%20writing%20files%20to%20Local_Username%20redirection.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1902947%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F873920%22%20target%3D%22_blank%22%3E%40brmmmm78%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F873920%22%20target%3D%22_blank%22%3E%40brmmmm78%3C%2FA%3E%26nbsp%3B%20%2C%20well%20all%20the%20redirections%20didn't%20help%20basically%20%22clickonce%22%20installers%20are%20not%20supported%20on%20VDI's%2FRoaming%20profiles%20and%20since%20Sage%20use%20that%20then%20there%20in%20lies%20the%20issue%2C%20Unless%20Sage%20are%20prepared%20to%20change%20to%20another%20type%20of%20installer%20this%20issue%20wont%20go%20away.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBasically%20FSLogix's%20uses%20a%20driver%20to%20obscure%20the%20path%20of%20where%20config%20file%20actually%20exists%20and%20whether%20you%20exclude%20from%20the%20disk%20or%20not%20.net%20still%20needs%20to%20run%20through%20that%20driver%2C%20Perhaps%20FSLogix%20may%20improve%20that%20driver%20over%20time%20but%20right%20now%20its%20doesn't%20work%20100%25%20of%20the%20time.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%20I%20would%20be%20very%20interested%20to%20here%20how%20you%20get%20on%20with%20your%20Sage%20support%2C%20as%20for%20now%20I%20have%20had%20to%20move%20the%20sage%20user%20away%20from%20WVD%20for%20now%20and%20hope%20this%20is%20resolved%20later%20on.%20Hope%20you%20have%20more%20luck%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1903043%22%20slang%3D%22en-US%22%3ERe%3A%20Intermitent%20issues%20writing%20files%20to%20Local_Username%20redirection.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1903043%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F815477%22%20target%3D%22_blank%22%3E%40StevenR%3C%2FA%3E%2C%20Im%20not%20going%20to%20hold%20my%20breath%20with%20Sage%2C%20but%20our%20accounts%20team%20is%20quite%20small%20so%20we%20are%20just%20join%20to%20create%20a%20host-pool%20with%20a%20single%20host%20and%20disable%20FXLogix%20for%20the%20sage%20users.%20Not%20ideal%20but%20a%20solution%20for%20the%20time%20being.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20the%20info%20and%20good%20luck%20to%20you%20also.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2117143%22%20slang%3D%22en-US%22%3ERe%3A%20Intermitent%20issues%20writing%20files%20to%20Local_Username%20redirection.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2117143%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F815477%22%20target%3D%22_blank%22%3E%40StevenR%3C%2FA%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F873920%22%20target%3D%22_blank%22%3E%40brmmmm78%3C%2FA%3E%26nbsp%3B%26nbsp%3B%20Did%20you%20manage%20sort%20out%20a%20permanent%20solution%20%3F%20rather%20bypassing%20FSLogix%20%26amp%3B%20running%20on%20a%20single%20host%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2117407%22%20slang%3D%22en-US%22%3ERe%3A%20Intermitent%20issues%20writing%20files%20to%20Local_Username%20redirection.xml%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2117407%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F958599%22%20target%3D%22_blank%22%3E%40accounts2021%3C%2FA%3E%26nbsp%3BHi%2C%20unfortunately%20I%20haven't%20I%20hit%20a%20brick%20wall%20of%20support%20from%20vendor%20as%20Sage%20do%20not%20support%20VDI%20environments%2C%20however%20that%20appears%20to%20be%20more%20of%20an%20issue%20with%20using%20%22ClickOnce%22%20installers%20as%20thats%20a%20limitation%20of%20that%20and%20until%20that%20changes.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20I%20haven't%20tested%20mostly%20due%20to%20time%2C%20is%20mounting%20the%20FSLogix%20accounts%20in%20Azure%20Files%20rather%20than%20direct%20on%20a%20fileserver%20in%20azure.%26nbsp%3B%3C%2FP%3E%3CP%3EWith%20another%20WVD%20deployment%20I%20ran%20into%20performance%20issues%2Flimitations%20of%20locating%20them%20on%20a%20fileserver%20then%20the%20bottleneck%20of%20access%20becomes%20the%20singulare%20fileserver%2C%20whereas%20if%20they%20were%20in%20Azure%20Files%20it%20is%20far%20higher%20and%20the%20bottleneck%20becomes%20the%20higher%20spec'd%20WVD%20that%20is%20trying%20to%20connect%20to%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20another%20project%20to%20deploy%20and%20will%20be%20using%20this%20method%20instead%20hopefully%20with%20better%20results.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

having an issue with Sage 200 trying to write a file into FSLogix profile disk so moved file using redirection.xml to local_username\appdata\local\ and it has successfully writes the folder structure there however intermittently it will fail on one file stopping the program open, logging users off and onto a different VM intermittently works, not sure if its an FSLogix issue or a WVD issue as dont have the issue on standard rdp with old UPD's or on on prem windows 10 machines. anyone seen similar

23 Replies

@StevenR we are also experiencing the same issue, we are using WVD and FSLogix but not the redirections.xml. We have found that the issue moves between users after reboots and after using process monitor we established the issue arises when Sage/.NET attempts to rename/merge the user.config. This stackoverflow displays the same issues but using Citrix:

 

https://stackoverflow.com/questions/64356026/applicationsettingsbase-save-unable-to-save-config-to-f...

 

His work around was to not use FSLogix, but this is far from ideal. Hope you find the extra information useful (or at least interesting).

 

This article suggests a development solution, which I am going to forward to our Sage support tomorrow. Fingers crossed they can ask Sage to implement a fix.

 

https://stackoverflow.com/questions/20946627/how-to-work-around-localfilesettingsprovider-requiring-...

 

 

 

 

@brmmmm78 

 

Hi @brmmmm78  , well all the redirections didn't help basically "clickonce" installers are not supported on VDI's/Roaming profiles and since Sage use that then there in lies the issue, Unless Sage are prepared to change to another type of installer this issue wont go away.

 

Basically FSLogix's uses a driver to obscure the path of where config file actually exists and whether you exclude from the disk or not .net still needs to run through that driver, Perhaps FSLogix may improve that driver over time but right now its doesn't work 100% of the time.

 

However I would be very interested to here how you get on with your Sage support, as for now I have had to move the sage user away from WVD for now and hope this is resolved later on. Hope you have more luck

Hi @StevenR, Im not going to hold my breath with Sage, but our accounts team is quite small so we are just join to create a host-pool with a single host and disable FXLogix for the sage users. Not ideal but a solution for the time being.

 

Thanks for the info and good luck to you also.

Hi 

 

@StevenR @brmmmm78   Did you manage sort out a permanent solution ? rather bypassing FSLogix & running on a single host 

@accounts2021 Hi, unfortunately I haven't I hit a brick wall of support from vendor as Sage do not support VDI environments, however that appears to be more of an issue with using "ClickOnce" installers as thats a limitation of that and until that changes.

 

What I haven't tested mostly due to time, is mounting the FSLogix accounts in Azure Files rather than direct on a fileserver in azure. 

With another WVD deployment I ran into performance issues/limitations of locating them on a fileserver then the bottleneck of access becomes the singulare fileserver, whereas if they were in Azure Files it is far higher and the bottleneck becomes the higher spec'd WVD that is trying to connect to it.

 

I have another project to deploy and will be using this method instead hopefully with better results.

@StevenR we think we have found a solution, it seems the problem is related to the UAC virtualization. If you disable the UAC virtualization and restart the host it seems to work.

 

Has this been a run the fix once and it has worked so far, I will give it a try as WVD is the better solution long term for this customer as long as sage 200 work :)

@StevenR @brmmmm78 

Just stumbled across this and was wondering if it still appears to be working OK with UAC Virtualization disabled? 

I have a few Sage apps on the WVD and a couple of them run with UAC V enabled, so I'm not too sure about completely disabling it on the hosts.

@dmidec For me I haven't actually tried it as I had to migrate off but I will be bearing in mind for the future.

@dmidec 

 

It does seem to be working, however we did not disable UAC V on the entire server.

 

We did not install our sage200 client using the click once installer, but instead have a single installation location for all users. This meant that in theory we only need to create a "Sage200Desktop.exe.manifest" file and set the correct "requestedExecutionLevel", but found that Sage had already generated one but renamed it to "Sage200desktop.manifest.manifest" (this is from memory so it might be named something else). We simply renamed this file and restarted the WVD host, its worked ever since.

 

We are are not sure why Sage had chosen to rename the manifest file, but so far we have not noticed any unexpected behavior.

@brmmmm78 Ah, that's useful. We too are running using the RDS installation method, so I'll look for the file!

Just dealing with this for a customer now. WVD, FSLogix and Sage 200. Getting intermittent error of ", Failed to save settings: Unable to Save config file c:\Users\%username%\AppData\Local\Sage_UK_Limited\Sage200Deesktop.exe_Strongname_.....\19.0.00\user.config"
Stack: at system.Configuration.ClientSettingsStore.write

Any type of solution for this?
See following from further up, let us know if it fixes your issue too.
--------------------------------
brmmmm78 replied to StevenR
‎Feb 08 2021 12:55 AM - edited ‎Feb 08 2021 12:58 AM

@StevenR we think we have found a solution, it seems the problem is related to the UAC virtualization. If you disable the UAC virtualization and restart the host it seems to work.
I couldn't get UAC Virtualization to disable. There's a manifest file created when you install the per user client, called Sage200desktop.manifest.manifest which you just need to rename as above and stick it next to the Sage200Desktop.exe file. When setting this to 'RequireAdministrator' the Sage 200 icon would change to show the UAC badge but it wouldn't disable UAC Virtualization when run in 'AsInvolker'.

The issue is very rare, so we're just living with it for now.

@dmidec 

 

We have been following this forum and also the suggestions made within to get sage 200 working with FSLogix and WVD

 

Our FSLOGIX is in azure premium storage and we have 2 servers that never have this issue. we have tried with and without UAC virtualisation and still receive the error writing the user.config file. as others have mentioned we see the folder structure be created for the user but just not the file. I could delete the file on 2 other servers and it immediately recreates it and runs with no issue yet other servers always present this error. 

 

I am looking at this manifest file and have as instructed renamed the file and copied the entire install directory to a local drive c:\program files (x86)\sage200\   

 

I run the Sage200desktop.exe application from here and still it will write this user.config file 

 

I have edited the manifest file as follows

 

<requestedPrivileges xmlns="urn:schemas-microsoft-com:asm.v3">
<!--
UAC Manifest Options
If you want to change the Windows User Account Control level replace the
requestedExecutionLevel node with one of the following.

<requestedExecutionLevel level="asInvoker" uiAccess="false" />
<requestedExecutionLevel level="requireAdministrator" uiAccess="false" />
<requestedExecutionLevel level="highestAvailable" uiAccess="false" />

If you want to utilize File and Registry Virtualization for backward
compatibility then delete the requestedExecutionLevel node.
-->
<requestedExecutionLevel level="requireAdministrator" uiAccess="false" />
</requestedPrivileges>

 

I presume the <!-- is the beginning of a comment-out statement and that I merely needed to take one of these statements and place it at the bottom. 

 

Others have stated when you use require administrator that it changes the icon but I'm not seeing this behavior. 

 

I am unsure if it is in fact even referring to the manifest file at all. 

 

I'm puzzled as to why on some of my WVD servers I have no issue and yet others i always get the problem. 

 

I have checked the .net versions and they are all correct. I have checked c++ and they also are correct

the version of windows is all the same and yet some machines refuse to write to this location at all.

 

Any clarity of any sort as to the specifics around the manifest file would be appreciated

 

Hi all, yes if you disable UAC Virtualisation, then this resolves the issues, have been running Sage 200 since early February with this setting disabled and the issues previously experienced have not re-occurred. thanks

@accounts2021 

We are using the local Program Files (not click-to-run) version and have updated the manifest file but are still experiencing the issue for some users.

 

It's really odd - is anyone else continuing to have problems?

I actually reduced my user count limit to 2 per host and haven't seen the issue since. Speaking with our Sage support vendor, they mentioned something about this, so it lines up I guess.
Hi dmidec,

Can I ask what size VMs you are using? I was hoping to get around 10 users per host so will need a dramatic rethink if that is the case! Did they give you any indication of why this may be?

Thanks!