Implement SSO for rds web client HTML 5

New Contributor

Hi everyone, 

I have deployed a new RDS on Windows Server 2019. 1 server with connection broker, gateway, web server and licensing role installed. I have recently deployed the new RDS HTML5 web client for a client. However, it is unable to implement SSO like with the old web access (windows auth in IIS).

After researching, I realize that the new RDS web client (HTML5) doesn't support SSO. So, I'm going to integrate RDS with Azure AD Application Proxy on following article: https://docs.microsoft.com/en-us/azure/active-directory/app-proxy/application-proxy-integrate-with-r...

Then enable SSO on Azure AD Application Proxy.

Questions: Is it the solution to implement SSO for the web client ?

Thanks in advance for your precious.

1 Reply

@PAnTran I configured RDS with app proxy with the new HTML 5 client. I tried to include SSO by using the username and password method. First thing I noticed was that for some reason, the username and password fields on the web form were not detected.

 

There is a option for manual detection so I tired using that. I entered the username and password. After doing each, the web form gets highlighted to indicate that the detection is happening. After successfully logging into the app however, there isn't an option to stop the detection. It stopped and saved only after I signed out after authentication (no need to launch the apps). It appeared to have detected the form successfully.

 

I then tried again and entered my username and password. The expectation now was that the credentials would have been passed to the other web form that pops up after going through the  app proxy auth web form. But, not to be so. Still have to enter username and password. I have pre-authenticaton enabled so I only needed to enter the username and password twice in the whole process. (After the apps are displayed in the web browser, there isn't any additional password prompt to launch them.)

 

Unless I'm missing something Sso with HTML5 seems like a bust. Then there is this weird missing credentials when authenticating to firewall error when I download the rdp app and try to launch it that way. Only html5 web client seems to work with app proxy. No SSO or launching from Rdp file though.