How to troubleshoot Unavailable Status of SessionHost


I am trying to make a Customer's custom image work. I can add it to a hostpool but I can't connect to it.

All prerequisites were done, sysprep ended without error;
Hostpool creation completes without error, virtual machines join domain and register with hostpool; However, I can't connect, what I have seen is that all session hosts report as Unavailable;


Sessions : 0
LastHeartBeat : 01/05/2020 9:36:51
AgentVersion : 1.0.1932.4800
AssignedUser :
OsVersion : 10.0.14393
SxSStackVersion : rdp-sxs200326004
Status : Unavailable
UpdateState : Succeeded
LastUpdateTime :
UpdateErrorMessage :



When I restart RDAgentBootLoader, the status shows as 'available', but in a few seconds (less than 60) it returns to Unvailable;

I can connect through RDP without problems, I have reviewed all RDS policies, I have reinstalled the agents several times (the last ones); I tried to join Version1 hostpool and Spring 2020 Hostpools, but the result is the same, I am stuck.

The image is a Windows 10 ENT in Catalan with  30 or 40 applications installed; I don't know if we has issues with localizations.


Other virtual machines created from Marketplace images  in the same subnet work well. There are no NSG, firewall restrictions on WDS services;


I don't know how to continue, I open a support ticket in parallel.
Any ideas?


9 Replies
best response confirmed by Eva Seydl (Microsoft)

@Martinsd Thanks for opening the support ticket. That is the right approach as we would need to troubleshoot where the failures are coming from by looking at your logs.




i can relate to this. Created multible tenats via powershell. (Azure template does not work ?).

Each VM regsitered in the host pool successfully. But each VM is unavailable. Tried different VM´s and different Host Pools. 


- Eventlog displays an error like this:


Fail to set default dimensions Invalid Operation: Fail to set default dimensions, error code is 2147942487.. Error code is 80070057"


- I think the SxS Network Stack is broken , because i´m not able to update it (corrupt ressources?).


- qwinsta is not very helpfull.

services 0 Disc
console 1 Conn
>rdp-tcp#1 appAdmin 3 Active
31c5ce94259d4... 65536 Listen
rdp-tcp 65537 Listen


corrupt installation files? Anyone with a brilliant idea?


Follow the step by step to resolve this situation:

Error: The status filed in Get-AzWvdSessionHost cmdlet shows status as Unavailable
Get-AzWvdSessionHost cmdlet shows status as Unavailable.

Cause: The agent isn't able to update itself to a new version.

Fix: Follow these instructions to manually update the agent.

Download a new version of the agent on the session host VM.
Launch Task Manager and, in the Service Tab, stop the RDAgentBootLoader service.
Run the installer for the new version of the Windows Virtual Desktop Agent.
When prompted for the registration token, remove the entry INVALID_TOKEN and press next (a new token isn't required).
Complete the installation Wizard.
Open Task Manager and start the RDAgentBootLoader service.

@BenjaminNiemann :


Did you get around an solution to this. My problem is similar, I have 2 tenant created and I have 2 host pools . Everytime I build a VM it's resides as unavailable. The agents were reinstalled , but still the problem persists.  -- Ayan




Did you manage to find a solution for this? Having the same problem.




Any luck with this? This just suddenly started happening to me today. My test user can connect to the host still despite it saying Unavailable. I can also login with the local admin account via Bastion. But I can't use MSIX App attach as it says none of my hosts have VMs.

Unfortunately, it was a year ago and I built a demo environment that no longer exists. Make sure that the VM is joined in the domain. I had password issues here. You need two passwords for Broker and AD. Make sure all prerequisites are installed. Microsoft has also reworked the management portal. You can now manage wvd in the Azure portal for a longer time. The Powershell patchwork is no longer necessary.



Ha yeah... little aged.

Ours was fine and working, showing available and then yesterday both were unavailable, but we can connect fine. I've uninstalled and reinstalled the agent, bootloader, and did a new reg key, and entered that when I reinstalled the wvd-agent. What I don't get is the link to download the agent appears to be substantially older than the agent listed in the Azure Portal, and it never seems to reflect the Agent version after uninstalling/reinstalling.

We have the same problem, keep getting Update Failed in Azure Portal on one VM. I manually updated the Agent 3 days ago, now it gives the same error again. Two other VM's are updating correctly.
1 best response

Accepted Solutions
best response confirmed by Eva Seydl (Microsoft)

@Martinsd Thanks for opening the support ticket. That is the right approach as we would need to troubleshoot where the failures are coming from by looking at your logs.

View solution in original post