HostPoolName xxxx does not exist ?!

Copper Contributor

I have set WVD in my Azure Tenant, following Microsoft guides line by line and throught the Azure host pool UI wizard. Everything seems to be fine, permissions, entitlements, vms, etc...
but once I login in the app or the url, it promtps me an error about there is no resources assigned. Contant yout IT Admin.

Surprisingly, get-rdshostpool don´t list any PoolName, even it´s clearly showed on the azure UI, and set-rdshostpool creates Pools which never shown on Azure UI. Since every action was made for the same TenantName, what´s going on with this?
Another weird behaviour is about the properties of the HostPool, "Validation environment" option seems to be in a undefined status and set it to "yes" or "no" and save the settings succesfully, have no effect. At least at UI level that settings keeps showing undefined, like if no change were ever made.

:facepalm:Any idea, please? Thanks!

2 Replies
best response confirmed by Lebrack (Copper Contributor)
Are you using the Spring 2020 update? Can you please try the following powershell:

So seems like I was running AzureWVD on 2020 Spring realease and I was following old guides related to previous version.
Thank You @Soo Kuan Teo It´s solved now as you point me to the key.
Steps to solve the issue:

1-) PowerShell 7
2-) Azure Powershell Module
3-) Azure UI Wizard HostPool Creation was run previously with success including vm creation, entitlements and permissions, but GET-AzWvdRegistrationInfo outputs no data, just an empty token value. So to get the token I run:
New-AzWvdRegistrationInfo -ResourceGroupName <resourcegroupname> -HostPoolName <hostpoolname> -ExpirationTime $((get-date).ToUniversalTime().AddHours(2).ToString('yyyy-MM-ddTHH:mm:ss.fffffffZ'))

Note1: Once step 3 was done. My published WVD Desktop and apps resources were finally showed up! (Eureka!) But fails connecting to them. So keep pushing!
Note2: I Skipped the role assignment step since it was done previously on Azure UI

5-) Token to a VAR & VAR content to a TXT
$token = Get-AzWvdRegistrationInfo -ResourceGroupName <resourcegroupname> -HostPoolName <hostpoolname>
$token | select-object token | format-list > C:\TOKEN.TXT


6-) RDP to the WVD vm. Download and install WVD Agent:
Paste the step 5 token into the Agent Installer Wizard
Download and install WVD Agent Bootloader:

Note3: I think the whole steps would have to be completed automatically by the HostPool Azure UI Wizard, but for some reason it didn´t happens, maybe an error or maybe it´s as is by design.
In fact running appwiz.cpl after Install WVD Agent with the token on my wvd vm shows 4 entries for "Remote Desktop Services Infrastructure Agent" with build numbers:

(Very Weird)

Note4: The Bootloader Agent didn´t install as the same build version seems to was already installed on that machine.
Anyway, SUCCESS!