Having multiple problems using AVD published applications

Copper Contributor

I have a customer which is experiencing multiple issue working with AVD through the Remote Desktop Client. These issues have been reported for a few months and we have looked into them. Some got sorted out or got solved in new version of the Remote Desktop Client (or with newer Azure stack). But we still have some open issues which we cannot solve because it looks to be bugs in the Remote Desktop Client itself.


Before I start summing up the problems I will describe the environment.



A user works on their company owned and Intune managed device, an example is a Lenovo with i5 (11th), 16 GB of RAM running OS Windows 10 Enterprise 22H2 (build 19045.2965). We are using Windows Defender as anti-virus program. And the Intune deployed Remote Desktop Client version 1.2.4240.0. There were earlier versions installed but moving to the newer one did not solve the issues.

The user works with local Office applications, Adobe Acrobat, Edge, etc. For the multiple business application the user AVD Published application. That’s where the issues start.


AVD environment

They have 25 machines in AVD with Windows 11 Enterprise multisession installed. Today they have 121 sessions (106 active) running on Standard D4ds v5 Azure virtual machines. They do not use the public preview RDP shortpath. They connect form multiple locations throughout the Netherlands.



  • An user has two Excel sheets, both AVD published applications, on one screen (multimonitor setup). When initiating a drag and drop action, during the drag action (mouse button is hold) the other Excel sheet jumps to the front. When the drop action (mouse button release) the original sheet is shown. (Reproducible)
  • In some application the application popups (e.g. login screen business application or print preview window) parts are invisible, hovering over them makes then visible. Some screen vectors looks as if they are not updated, until you hover over them. (Reproducible)
  • Some application pop ups are scaled very small. (not reproducible)
  • They open their accounting software multiple times to open different clients of them. This are AVD published applications. When hovering over the taskbar setting the thumbnails with description is shown for the multiple opened application. The description normally looks like something like: “<xxxxxx customer name> – <Application Name>”. Sometimes all of them are populated, other times only a few (or all) show only “<Application Name>”. So without the description. (somewhat reproducible)
  • Users have been reporting that selecting for example a button in the Word ribbon selects the button next to it. As if the local mouse cursor is not in sync with AVD. (not reproducible)
  • Copy and paste from local to published application does not always work, sometimes have to try it 2-3 times before they can paste in AVD.

What have we done

  • Went to client locations and tested the network
  • Saw the problems first handed and the frequency of them
  • Switched the transport protocol of the Remote Desktop Client to TCP
  • Got dozens of screenshots of the connection details of the Remote Desktop Client
  • Let some key users test on a UAT (user acceptance test) server, even isolated one on that server.
  • Analyzed the resource uses of the AVD environment in Azure and within the Windows OS.
  • Upgraded and tested multiple Remote Desktop Client versions
  • Contact their ISP provider (SD WAN) and let them analyze the line.
  • Contacted the party who is responsible for the network
  • Let the users test from different location, also non corporate, and using different network mediums (WiFi, LAN and hotspots)
  • Customer supplied a representable laptop to do test work
  • Changed RDP hostpool setting from only having the first listed option.
    • enablerdsaadauth:i:1
    • smart sizing:i:1
    • bandwidthautodetect:i:0
    • networkautodetect:i:0
    • redirected video capture encoding quality:i:1
  • Added user keys
    • HKCU:\Software\Microsoft\Office\16.0\Excel\Options; DisableMergeInstance value 1 (DWORD),
    • HKCU:\Software\Microsoft\Office\16.0\Common\Graphics; DisableHardwareAcceleration with value 1 (DWORD
    • HKCU:\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced; ShowInfoTip with value 0 (DWORD)
    • HKCU:\Software\Microsoft\Windows\CurrentVersion\Themes\Personalize; EnableTransparency with value 0 (DWORD)
  • Added GPO
    • GPO: Microsoft Office 2016/Miscellaneous Disable Office animations
    • GPO: Microsoft Office 2016/Global Options/Customize/Menu animations disabled
  • New Remote Desktop Services SxS network stack did not solve issues
  • Searched almost the whole internet
  • Multiple engineers have looked at the problem and I am the last station before it goes to you guys.


At this moment there is one user testing the full desktop instead of using published applications. I think focus, rendering, etc. will be better or even not exist in full desktop. But this customer needs the AVD published applications. 

I have already made a Microsoft Support case but thought might as well post it here seeing allot of people may have ran into these issues.

12 Replies

Hi Paul,

The Remote App issues that I encountered could solved by this registry workaround:
Key: HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RdpCloudStackSettings
Value: RAILDVCActivateThreshold
Data: 0
Microsoft has requested internally for a permanent fix on SXS.

All other AVD issues last months were related to:
- the lastest FSLogix builds. As a workaround I keep al my customer's session hosts on FSLogix 2201 hotfix 2 (2.9.8228.50276)
- RDP shortpath. As a workaround I enforce TCP connections on the client-side

Thnx Mathieu,

I will have a look into it, don't think it would solve the issues but I can be wrong. No action on the Microsoft case so far. I will keep you informed.
This did not work. Any other recommendations?

@PowerToThePeople  This did not solve any of the problems, MS never responded to the MS case. I will be making new one through our group CSP account. This will speed up things.

@PaulStruik Did you ever get this figured out?

Any solution for this issue?

I have opened multiple cases with Microsoft Support for the Excel flipping issue, but none of my tickets have been resolved by Microsoft.

Hi Paul,
I first encountered the issue you are describing with Excel in early 2021 for a customer. After a while I finally found a solution that has saved us a ton of trouble over the last years for multiple applications that are either behaving really wierd with window popping/flipping or small interactive windows hiding behind other windows etc.

When a user logs on to AVD they will all have these 2 Values in the Regedit Hive.
HKEY_CURRENT_USER\Control Panel\Desktop
Dword: "ForegroundLockTimeout"
Default Value = 200000 (30d40 hex)

HKEY_CURRENT_USER\Control Panel\Desktop
Dword: "ForegroundFlashCount"
Default value = 3 to 7

I solved the issue by making a user GPO that sets the value for both these to 0.
This will force your active application/window to always be "on top". Haven't had Excel flipping issues for a customer since this was implemented.

Really hope this can help!

@FBacke Hi,

Thnx for the registry settings. I am leaving the company and will be transfering this problem to a coworker. I have added these settings and the link to the post to our problem ticket. 


The timing of your post is perfect, seeing i am leaving. The Microsoft case reached multiple deadends and customer was in the process of accepting the issues. :S


If I hear that it works than i will post it here.

FBacke, does this solution worked for the Remote App?
rajldt, Yes both for Remote App and Full Desktop.

You wouldn't think that the "ForegroundFlashCount" Dword would have any impact regarding this issue because that value has to do with how many times an application "flashes" on your taskbar when something happens in an application (ex UAC prompt). But it did not work until both of these values were set.
Hi Fbacke,

I've implemented the registry keys on both AVD servers, but I'm still experiencing the same issue with Excel flipping. I'm currently using Windows 11. Any other suggestions would be greatly appreciated.
Any update on this, still facing the issue.