Getting error 0x9735 when trying to connect using AAD account. Local Account works

Copper Contributor

I'm getting error 0x9735 when trying to connect using AAD account. Local Account works fine.

I have check with dsregcmd /status that both the client and the VM are joined to AAD


AzureAdJoined : YES
EnterpriseJoined : NO
DomainJoined : NO
Device Name : xxxxxxx



I can successfully connect directly to the VM after giving it a public IP by using the old fashion "Remote Desktop Connection" app (the blue one).

But I can't connect directly to the VM using the "Remote Desktop" app (the red one).



Any idea?

6 Replies
Have you added targetisaadjoined:i:1 to the custom rdp properties of the host pool?

Yes, targetisaadjoined:i:1 is added to the RDP properties of the host pool

I found the following blogpost from Anoop. He talks about the same error message.
Are you connected from a device that is either
Windows device should be Azure AD Joined.
Windows device should be Hybrid Azure AD joined.
check out he's post here:

Thanks Johan.
I didn’t fully understand how he solved his issue, but my guess is that he from the start didn’t use a AAD joined device and then fixed his pre-req, this as he says:

I tried to login to AVD Azure AD joined VM from Cloud PC, which is Hybrid Azure AD joined, and it started working

In his case he used an O365 VM that was hybrid AAD joined
In my case I’m using a physical Windows device that is AAD joined and that should be ok s as well.

As I understand I have all the pre-req in place, even the register settings for PKU2U

And as I can login directly to the VM with my AAD credentials using the old fashion blue RDP client, but not using the newer red RDP client (that is a pre-req for connecting to AVD and workspaces), I guess the problem is somehow related to the differences in the clients. Could it maybe have something to do with certificates?

Make sure you are using the correct RDP manager

It needs to be 1.2.3667.0 which IS NOT DOWNLOADED from the store