FSLogix profiles failing on all new hosts all of a sudden

Copper Contributor

All of a sudden any new host I try to setup is failing to map all users to their network shared FSLogix profile. I have 10 hosts in one pool, 1 host in another pool, and am testing new hosts into a 3rd pool.  All original hosts and users are mapping perfectly fine, just the new hosts fail to load FSLogix.


Upon logging in to a new host the following 5 separate entries are shown in the FSLogix event log, in this order:

1. LoadProfile failed. User: jdoe. SID: S-1-5-21-33345542-4546743754-4675457643-1207. (An exception occurred in the service when handling the control request.)
2. Unable to find parent path of "" (An exception occurred in the service when handling the control request.)
3. IPlugins::Add (Search.TripoliIndexer) failed (The security ID structure is invalid.)
4. Catalog Creation operation failed (The security ID structure is invalid.)
5. Search catalog mount failed (The security ID structure is invalid.)


After logging in and receiving these messages in the event log I've confirmed the user does have proper access to the profile folder and disk image. I've confirmed this by browsing to it and renaming it to test.


All hosts get the same set of GPO's, and there really aren't any GPOs that make any changes to any FSLogix policies, so it's very vanilla.


I've tried adding my custom image into the test pool as well as a 100% vanilla EVD with the basic FSLogix services installed.


Not sure where to go from here.


7 Replies

@northcide Can you check your profile share and verify that it isn't full or restricting storage use? and can you verify whether permissions have changed to the share? does the user in question have permissions? 

@WillCherry Yes, share permissions are open and confirmed from the context of a user.  Can access and even rename the FSLogix profile disk image.

@northcide re-read, it doesn't seem to be a permissions issue. can you check how full the storage is? or if it its restricting usage? 

check the actual profile share and check the users vhd. are either of them full?

@WillCherry  Profile storage is Azure Files and is no where near any sort of limits. 


As a test I renamed the original profile disk image, logged into one of the "new" image hosts and it did not create a new FSLogix profile, but instead logged in locally.  But then when I logged into one of the "original" hosts, it created the new profile disk image just as would be expected. After the new profile image was created, logging back in under the "new" image host it would still not log into the FSLogix profile - it still stayed local.

@northcide Please reach out to the fslogix support team, with the limited information here i can't do much, sometimes the issue isn't as obvious, the log you pasted seemed to indicate and issue with the storage location. if the support team can't get it sorted they'll have you gather some logs and escalate it. 

best response confirmed by northcide (Copper Contributor)

Just an update for future visitors, the issue is resolved. The registry keys that point to the share path for the profiles wasn't getting updated correctly by the platform server.....


I think this issue is unique to my setup, so the only thing I'd say that might be helpful is check the registry to ensure the correct share path exists:  HKLM\SOFTWARE\FSLogix\Profiles