Error in deploying windows virtual Desktop

%3CLINGO-SUB%20id%3D%22lingo-sub-2175361%22%20slang%3D%22en-US%22%3EError%20in%20deploying%20windows%20virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2175361%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20the%20error%20below%20while%20creating%20Windows%20virtual%20Desktop%20hostpool%2C%3C%2FP%3E%3CDIV%20class%3D%22fxc-copyablelabel-temp-element%22%3E%7B%22code%22%3A%22DeploymentFailed%22%2C%22message%22%3A%22At%20least%20one%20resource%20deployment%20operation%20failed.%20Please%20list%20deployment%20operations%20for%20details.%20Please%20see%20%3CA%20href%3D%22https%3A%2F%2Faka.ms%2FDeployOperations%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2FDeployOperations%3C%2FA%3E%20for%20usage%20details.%22%2C%22details%22%3A%5B%7B%22code%22%3A%22VMExtensionProvisioningError%22%2C%22message%22%3A%22VM%20has%20reported%20a%20failure%20when%20processing%20extension%20'dscextension'.%20Error%20message%3A%20%5C%22The%20DSC%20Extension%20failed%20to%20execute%3A%20Error%20downloading%20%3CA%20href%3D%22https%3A%2F%2Fwvdportalstorageblob.blob.core.windows.net%2Fgalleryartifacts%2FConfiguration_1-25-2021.zip%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwvdportalstorageblob.blob.core.windows.net%2Fgalleryartifacts%2FConfiguration_1-25-2021.zip%3C%2FA%3E%20after%2029%20attempts%3A%20The%20remote%20name%20could%20not%20be%20resolved%3A%20'wvdportalstorageblob.blob.core.windows.net'.%5Cr%5CnMore%20information%20about%20the%20failure%20can%20be%20found%20in%20the%20logs%20located%20under%20'C%3A%5C%5CWindowsAzure%5C%5CLogs%5C%5CPlugins%5C%5CMicrosoft.Powershell.DSC%5C%5C2.83.0.0'%20on%20the%20VM.%5C%22%5Cr%5Cn%5Cr%5CnMore%20information%20on%20troubleshooting%20is%20available%20at%20%3CA%20href%3D%22https%3A%2F%2Faka.ms%2FVMExtensionDSCWindowsTroubleshoot%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2FVMExtensionDSCWindowsTroubleshoot%3C%2FA%3E%20%22%7D%5D%7D%3C%2FDIV%3E%3CDIV%20class%3D%22fxc-copyablelabel-temp-element%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22fxc-copyablelabel-temp-element%22%3EPlease%20has%20anyone%20came%20across%20this%20error%20before%20and%20how%20was%20it%20resolved%3F%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2294742%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20in%20deploying%20windows%20virtual%20Desktop%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2294742%22%20slang%3D%22en-US%22%3EI%20am%20having%20the%20same%20problem%2C%20but%20with%20a%20later%20date%20on%20the%20zip%20file%20(3-10-2021).%20The%20host%20pool%20is%20created%20OK%20and%20a%20VM%20is%20created%2C%20but%20the%20VM%20is%20not%20successfully%20added%20to%20the%20host%20pool%20as%20a%20session%20host.%3CBR%20%2F%3E%3CBR%20%2F%3EDid%20you%20get%20a%20resolution%20on%20this%3F%3C%2FLINGO-BODY%3E
New Contributor

I have the error below while creating Windows virtual Desktop hostpool,

{"code":"DeploymentFailed","message":"At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details.","details":[{"code":"VMExtensionProvisioningError","message":"VM has reported a failure when processing extension 'dscextension'. Error message: \"The DSC Extension failed to execute: Error downloading https://wvdportalstorageblob.blob.core.windows.net/galleryartifacts/Configuration_1-25-2021.zip after 29 attempts: The remote name could not be resolved: 'wvdportalstorageblob.blob.core.windows.net'.\r\nMore information about the failure can be found in the logs located under 'C:\\WindowsAzure\\Logs\\Plugins\\Microsoft.Powershell.DSC\\2.83.0.0' on the VM.\"\r\n\r\nMore information on troubleshooting is available at https://aka.ms/VMExtensionDSCWindowsTroubleshoot "}]}
 
Please has anyone came across this error before and how was it resolved?
1 Reply
I am having the same problem, but with a later date on the zip file (3-10-2021). The host pool is created OK and a VM is created, but the VM is not successfully added to the host pool as a session host.

Did you get a resolution on this?