Deplyment Failing in South Central US - VM has reported a failure when processing extension 'dscexte

%3CLINGO-SUB%20id%3D%22lingo-sub-1294291%22%20slang%3D%22en-US%22%3EDeplyment%20Failing%20in%20South%20Central%20US%20-%20VM%20has%20reported%20a%20failure%20when%20processing%20extension%20'dscexte%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1294291%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20using%20two%20different%20tenants%20and%20up%20until%20today%20both%20were%20failing%20in%20South%20Central%20US.%3C%2FP%3E%3CP%3EHowever%20my%20Lab%20was%20working%20in%20East%20US%20just%20fine.%26nbsp%3B%20My%20lab%20succeed%20at%202%3A07%20PM%20for%20some%20reason.%20However%20prod%20still%20has%20an%20issue.%20My%20Prod%20environment%20is%20having%20DOM%20Join%20issues%20so%20I%20am%20not%20sure%20about%20East%20US%20working%20as%20of%20yet.%20I%20think%20it%20is%20peering%20so%20I%20can't%20prove%20that%20it%20works%20in%20East%20US%20yet%20in%20Prod.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EInfo%3A%20Windows%20Multi%20User%20Edition%20with%20Office%20from%20ARM%20Catalog%3C%2FP%3E%3CP%3EI%20am%20using%20a%20SPN%20in%20both%20environments.%20I%20have%20a%20couple%20working%20host%20pools%20from%20using%20the%20exact%20steps%20previously.%20Seems%20strange.%26nbsp%3B%E2%80%83%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20suggestions%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%E2%80%83%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22csp.jpg%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F183256iF7FA70FE93DB8FAF%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22csp.jpg%22%20alt%3D%22csp.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%5D%2C%3CBR%20%2F%3E%22error%22%3A%20%7B%3CBR%20%2F%3E%22code%22%3A%20%22DeploymentFailed%22%2C%3CBR%20%2F%3E%22message%22%3A%20%22At%20least%20one%20resource%20deployment%20operation%20failed.%20Please%20list%20deployment%20operations%20for%20details.%20Please%20see%20%3CA%20href%3D%22https%3A%2F%2Faka.ms%2FDeployOperations%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2FDeployOperations%3C%2FA%3E%20for%20usage%20details.%22%2C%3CBR%20%2F%3E%22details%22%3A%20%5B%3CBR%20%2F%3E%7B%3CBR%20%2F%3E%22code%22%3A%20%22Conflict%22%2C%3CBR%20%2F%3E%22message%22%3A%20%22%7B%5Cr%5Cn%20%5C%22status%5C%22%3A%20%5C%22Failed%5C%22%2C%5Cr%5Cn%20%5C%22error%5C%22%3A%20%7B%5Cr%5Cn%20%5C%22code%5C%22%3A%20%5C%22ResourceDeploymentFailure%5C%22%2C%5Cr%5Cn%20%5C%22message%5C%22%3A%20%5C%22The%20resource%20operation%20completed%20with%20terminal%20provisioning%20state%20'Failed'.%5C%22%2C%5Cr%5Cn%20%5C%22details%5C%22%3A%20%5B%5Cr%5Cn%20%7B%5Cr%5Cn%20%5C%22code%5C%22%3A%20%5C%22VMExtensionProvisioningError%5C%22%2C%5Cr%5Cn%20%5C%22message%5C%22%3A%20%5C%22VM%20has%20reported%20a%20failure%20when%20processing%20extension%20'dscextension'.%20Error%20message%3A%20%5C%5C%5C%22DSC%20Configuration%20'CreateHostPoolAndRegisterSessionHost'%20completed%20with%20error(s).%20Following%20are%20the%20first%20few%3A%20The%20client%20cannot%20connect%20to%20the%20destination%20specified%20in%20the%20request.%20Verify%20that%20the%20service%20on%20the%20destination%20is%20running%20and%20is%20accepting%20requests.%20Consult%20the%20logs%20and%20documentation%20for%20the%20WS-Management%20service%20running%20on%20the%20destination%2C%20most%20commonly%20IIS%20or%20WinRM.%20If%20the%20destination%20is%20the%20WinRM%20service%2C%20run%20the%20following%20command%20on%20the%20destination%20to%20analyze%20and%20configure%20the%20WinRM%20service%3A%20%5C%5C%5C%22winrm%20quickconfig%5C%5C%5C%22.%5C%5C%5C%22%5C%5Cr%5C%5Cn%5C%5Cr%5C%5CnMore%20information%20on%20troubleshooting%20is%20available%20at%20%3CA%20href%3D%22https%3A%2F%2Faka.ms%2FVMExtensionDSCWindowsTroubleshoot%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2FVMExtensionDSCWindowsTroubleshoot%3C%2FA%3E%20%5C%22%5Cr%5Cn%20%7D%5Cr%5Cn%20%5D%5Cr%5Cn%20%7D%5Cr%5Cn%7D%22%3CBR%20%2F%3E%7D%3CBR%20%2F%3E%5D%3CBR%20%2F%3E%7D%2C%3CBR%20%2F%3E%22validationLevel%22%3A%20%22Template%22%3CBR%20%2F%3E%7D%3CBR%20%2F%3E%7D%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1316227%22%20slang%3D%22en-US%22%3ERe%3A%20Deplyment%20Failing%20in%20South%20Central%20US%20-%20VM%20has%20reported%20a%20failure%20when%20processing%20extension%20'dsc%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1316227%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F615077%22%20target%3D%22_blank%22%3E%40BryanHeath%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3EGood%20morning%20Bryan%2C%20I%20have%20the%20same%20problem%2C%20could%20you%20solve%20it%20somehow%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1484834%22%20slang%3D%22en-US%22%3ERe%3A%20Deplyment%20Failing%20in%20South%20Central%20US%20-%20VM%20has%20reported%20a%20failure%20when%20processing%20extension%20'dsc%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1484834%22%20slang%3D%22en-US%22%3E%3CP%3EI%20%3CSTRONG%3E%3CU%3EJUST%3C%2FU%3E%3C%2FSTRONG%3E%20figured%20out%20how%20to%20fix%20this%20in%20%3CSTRONG%3E%3CU%3Emy%20prod%20environment%3C%2FU%3E%3C%2FSTRONG%3E.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20not%20sure%20if%20this%20is%20specific%20to%20our%20setup%20or%20not.%20It%20is%20worth%20a%20shot%20if%20you%20are%20stuck.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3EDisable%20IPv6%20on%20nontunnel%20interfaces%20(except%20the%20loopback)%20and%20on%20IPv6%20tunnel%20interface%3C%2FLI%3E%3C%2FOL%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Fhelp%2F929852%2Fguidance-for-configuring-ipv6-in-windows-for-advanced-users%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Fhelp%2F929852%2Fguidance-for-configuring-ipv6-in-windows-for-advanced-users%3C%2FA%3E%26nbsp%3B%20use%20the%20fix%20it.%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3ESysprep%20%2C%20genralize%2C%20OBE%2C%20shutdown.%3C%2FLI%3E%3CLI%3EConvert%20the%20VHD%20to%20an%20Image.%3C%2FLI%3E%3C%2FOL%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%24disk%20%3D%20Get-AzDisk%20-ResourceGroupName%20%3CSTRONG%3E'your-rg%3C%2FSTRONG%3E'%20-DiskName%20%3CSTRONG%3E'your-disk'%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%24location%20%3D%20'South%20Central%20US'%3C%2FP%3E%3CP%3E%24imageName%20%3D%20%3CSTRONG%3E'golden-image-name-ipv6-disabled'%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%24rgName%20%3D%20%3CSTRONG%3E'your-rg'%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%24imageConfig%20%3D%20New-AzImageConfig%20%60%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%20-Location%20%24location%3C%2FP%3E%3CP%3E%24imageConfig%20%3D%20Set-AzImageOsDisk%20%60%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%20-Image%20%24imageConfig%20%60%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%20-OsState%20Generalized%20%60%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%20-OsType%20Windows%20%60%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%20-ManagedDiskId%20%24disk.Id%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%24image%20%3D%20New-AzImage%20%60%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%20-ImageName%20%24imageName%20%60%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%20-ResourceGroupName%20%24rgName%20%60%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%20-Image%20%24imageConfig%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3EDeploy%20Session%20hosts%20to%20the%20host%20pool.%26nbsp%3B%3C%2FLI%3E%3C%2FOL%3E%3CP%3EGood%20luck!!!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1484839%22%20slang%3D%22en-US%22%3ERe%3A%20Deplyment%20Failing%20in%20South%20Central%20US%20-%20VM%20has%20reported%20a%20failure%20when%20processing%20extension%20'dsc%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1484839%22%20slang%3D%22en-US%22%3E%3COL%3E%3CLI%3ECreate%20a%20new%20VM%20from%20your%20disk%20template.%20I%20suggest%20you%20create%20a%20separate%20RG%20for%20workspaces.%3C%2FLI%3E%3CLI%3EDisable%20IPv6%20on%20nontunnel%20interfaces%20(except%20the%20loopback)%20and%20on%20IPv6%20tunnel%20interface%26nbsp%3B%26nbsp%3B%26nbsp%3B%20-ERR%3AREF-NOT-FOUND-%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Fhelp%2F929852%2Fguidance-for-configuring-ipv6-in-windows-for-advanced-users%26nbsp%3B%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Fhelp%2F929852%2Fguidance-for-configuring-ipv6-in-windows-for-advanced-users%26nbsp%3B%3C%2FA%3E%20use%20the%20fix%20it.%26nbsp%3B%3C%2FLI%3E%3CLI%3ESysprep%20%2C%20genralize%2C%20OBE%2C%20shutdown.%3C%2FLI%3E%3CLI%3EConvert%20the%20VHD%20to%20an%20Image%20%26nbsp%3B(your%20mojo)%3C%2FLI%3E%3C%2FOL%3E%3CP%3E%26nbsp%3B%24disk%20%3D%20Get-AzDisk%20-ResourceGroupName%20%3CSTRONG%3E'your-rg%3C%2FSTRONG%3E'%20-DiskName%20%3CSTRONG%3E'your-disk'%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%24location%20%3D%20'South%20Central%20US'%3C%2FP%3E%3CP%3E%24imageName%20%3D%20%3CSTRONG%3E'golden-image-name-ipv6-disabled'%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%24rgName%20%3D%20%3CSTRONG%3E'your-rg'%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%24imageConfig%20%3D%20New-AzImageConfig%20%60%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%20-Location%20%24location%3C%2FP%3E%3CP%3E%24imageConfig%20%3D%20Set-AzImageOsDisk%20%60%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%20-Image%20%24imageConfig%20%60%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%20-OsState%20Generalized%20%60%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%20-OsType%20Windows%20%60%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%20-ManagedDiskId%20%24disk.Id%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%24image%20%3D%20New-AzImage%20%60%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%20-ImageName%20%24imageName%20%60%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%20-ResourceGroupName%20%24rgName%20%60%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%20-Image%20%24imageConfig%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3EDeploy%20new%20Host%20pool%20and%20Session%26nbsp%3Bhosts%20with%20the%20new%20image%3C%2FLI%3E%3C%2FOL%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hello, 

I am using two different tenants and up until today both were failing in South Central US.

However my Lab was working in East US just fine.  My lab succeed at 2:07 PM for some reason. However prod still has an issue. My Prod environment is having DOM Join issues so I am not sure about East US working as of yet. I think it is peering so I can't prove that it works in East US yet in Prod.

 

Info: Windows Multi User Edition with Office from ARM Catalog

I am using a SPN in both environments. I have a couple working host pools from using the exact steps previously. Seems strange.  

 

Any suggestions?

 

 

csp.jpg

 

],
"error": {
"code": "DeploymentFailed",
"message": "At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details.",
"details": [
{
"code": "Conflict",
"message": "{\r\n \"status\": \"Failed\",\r\n \"error\": {\r\n \"code\": \"ResourceDeploymentFailure\",\r\n \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n \"details\": [\r\n {\r\n \"code\": \"VMExtensionProvisioningError\",\r\n \"message\": \"VM has reported a failure when processing extension 'dscextension'. Error message: \\\"DSC Configuration 'CreateHostPoolAndRegisterSessionHost' completed with error(s). Following are the first few: The client cannot connect to the destination specified in the request. Verify that the service on the destination is running and is accepting requests. Consult the logs and documentation for the WS-Management service running on the destination, most commonly IIS or WinRM. If the destination is the WinRM service, run the following command on the destination to analyze and configure the WinRM service: \\\"winrm quickconfig\\\".\\\"\\r\\n\\r\\nMore information on troubleshooting is available at https://aka.ms/VMExtensionDSCWindowsTroubleshoot \"\r\n }\r\n ]\r\n }\r\n}"
}
]
},
"validationLevel": "Template"
}
}

3 Replies

@BryanHeath 
Good morning Bryan, I have the same problem, could you solve it somehow?

I JUST figured out how to fix this in my prod environment.

 

I am not sure if this is specific to our setup or not. It is worth a shot if you are stuck.

 

  1. Disable IPv6 on nontunnel interfaces (except the loopback) and on IPv6 tunnel interface

https://support.microsoft.com/en-us/help/929852/guidance-for-configuring-ipv6-in-windows-for-advance...  use the fix it. 

  1. Sysprep , genralize, OBE, shutdown.
  2. Convert the VHD to an Image.

 

$disk = Get-AzDisk -ResourceGroupName 'your-rg' -DiskName 'your-disk'

 $location = 'South Central US'

$imageName = 'golden-image-name-ipv6-disabled'

$rgName = 'your-rg'

 $imageConfig = New-AzImageConfig `

   -Location $location

$imageConfig = Set-AzImageOsDisk `

   -Image $imageConfig `

   -OsState Generalized `

   -OsType Windows `

   -ManagedDiskId $disk.Id

    $image = New-AzImage `

   -ImageName $imageName `

   -ResourceGroupName $rgName `

   -Image $imageConfig

 

  1. Deploy Session hosts to the host pool. 

Good luck!!!

  1. Create a new VM from your disk template. I suggest you create a separate RG for workspaces.
  2. Disable IPv6 on nontunnel interfaces (except the loopback) and on IPv6 tunnel interface    https://support.microsoft.com/en-us/help/929852/guidance-for-configuring-ipv6-in-windows-for-advance...  use the fix it. 
  3. Sysprep , genralize, OBE, shutdown.
  4. Convert the VHD to an Image  (your mojo)

 $disk = Get-AzDisk -ResourceGroupName 'your-rg' -DiskName 'your-disk'

 $location = 'South Central US'

$imageName = 'golden-image-name-ipv6-disabled'

$rgName = 'your-rg'

 $imageConfig = New-AzImageConfig `

   -Location $location

$imageConfig = Set-AzImageOsDisk `

   -Image $imageConfig `

   -OsState Generalized `

   -OsType Windows `

   -ManagedDiskId $disk.Id

    $image = New-AzImage `

   -ImageName $imageName `

   -ResourceGroupName $rgName `

   -Image $imageConfig

 

  1. Deploy new Host pool and Session hosts with the new image