Default apps in WVD

Brass Contributor

We are dealing with an issue with WVD Remote Apps where we cannot set or maintain default apps for users.  For instance, we want the default browser to be Chrome, mail to be OutLook, .doc files to open in Word, PDFs to open in Reader and the settings are not sticking.  We've tried to apply GPO using the app associations .xml file and it doesn't work.  We even went as far as writing policy to modify registry for all app extensions and that doesn't work.  NOTE: we are using only remote apps and not a full desktop.  This is really the last thing that we can't get to work and are stumped.  Any help would be appreciated and would like to know if others have experienced this.


A little more about the setup.  We have deployed 2 session hosts with FSLogix containers to host our profiles on a file share.

17 Replies

@stevenzelenko : Let me send around to the rest of the team, to see if they have guidance on this.

Hi @stevenzelenko, am I correct that you want files on the remote server to open with the right app as defined on that remote server?


Or are you trying to associate local files to open in a remote app?



@David Belanger 

Essentially correct.  We want the server apps to be associated with the files in user's FSLogix profile.  So if a user has a pdf file in OneDrive or in their documents folder, it should associate with Reader.


So far we have tried an associations xml file via GPO as well as some registry settings.  We'd like chrome for browser, outlook for mail, word for doc and docx, etc.  Every session all apps return to Windows 10 default.  So for instance, if we click a URL it will open in edge, a mailto: within outlook will prompt which app to open with and will always default to the windows mail client.  Even if the user selects outlook and check to remember this app, if they log off and back in, that gets reset.  We are forcing users to one drive and opening files like PDFs and .docs seem to work ok but PDF will always prompt the user to choose a default application for PDFs.  It's like it doesn't honor the GPO or registry and will always default to using Windows 10 default apps.


We are using remote apps only and the profiles are handled with FSLogix containers.

@stevenzelenko Did you find a solution to this? We have the exact same problem. The XML file through GPO works fine for full desktops, but looks like its ignored with RemoteApps. 

@Mtollex70. We have just experienced the same issue. if we setup a user without launching full desktop the default app associations don't apply but if we log in as full desktop then convert back to remote app, default associations start working. has anyone else experienced this or know of a fix?

@stevenzelenko I am not even able to configure default apps for my desktops. WE used GPOs to do it but they are not sticking. Anyone aware about this? or just me?

did you ever get a solution for this? @stevenzelenko 

Something else to try - I use this for setting up my user associations (on a script I use for setting up Windows 10 associations, sets Mail etc, I would assume it would work in AVD, but haven't tested it) -

Hi @Luke Murray 


Do you have an example script?


I think the issue I have is the target location is as below as it is not a local installed app.

"C:\Users\jonpaul\AppData\Local\Apps\Remote Desktop\msrdc.exe" "C:\Users\jonpaul\AppData\Local\rdclientwpf\1ed5d778-cf01-41d2-996d-ffe4d90b44d1\0c3203ce-050b-4fb0-a5b2-08d9520686ac.rdp" / /l:2 /p:13188 /r:3  /n:"Adobe Acrobat DC"


SetUserFTA.exe -Parameters "mailto Outlook.URL.mailto.15"

SetUserFTA.exe -Parameters "http ChromeHTML" 
SetUserFTA.exe -Parameters "https ChromeHTML" 
^ is what I used, the first one sets the mail app to Outlook.
Try using to get the associations/apps:
SetUserFTA.exe get

Hi @Luke Murray 


I think the issue when looking into this is all the local apps associate themselves with an "AppXxxxxx" ID for Regedit to identify what application needs to run for the file type.


1) I am running Azure Virtual Desktop which runs locally on the machine via the installed app "Remote Desktop" however if you assign this as the default app as expected you will only be able to open the "Remote Desktop" however get an error of unable to open file with this application as it can't read the file (Obviously) which is why I am saying the file needs a couple of things to run.


Target File =  "C:\Users\jonpaul\AppData\Local\Apps\Remote Desktop\msrdc.exe" "C:\Users\jonpaul\AppData\Local\rdclientwpf\4ec108f6-9882-4f6b-879b-6c38fda0c6e2\0c3203ce-050b-4fb0-a5b2-08d9520686ac.rdp" / /l:2 /p:12872 /r:3 /n:"Adobe Acrobat DC"


When you split the Target file up you get the below:

"C:\Users\jonpaul\AppData\Local\Apps\Remote Desktop\msrdc.exe"


This is "Remote Desktop"



This is "Adobe Pro DC"

/ /l:2 /p:12872 /r:3 /n:"Adobe Acrobat DC"


This is for Adobe Pro DC and Remote Desktop to authenticate you have access to read the Remote installed app.


2) As I see it within SetUserFta you would either need a second field to read the authentication (/ /l:2 /p:12872 /r:3 /n:"Adobe Acrobat DC") to be able to get your machine to even think of running the "Remote Desktop Application"


Please let me know if I am missing a vital part of assigning the "Remote Desktop App"

Maybe I shouldn't be using the path of  C:\user\username\Appdata\..... feel free to look me up on LinkedIn Jon-Paul Lewis

I can't think of anything specific off the top of my head.

It may be that that kind of seamless interaction may not be possible, even if you could get the PDF to open with Remote Desktop, it won't pass through the file, you may have to use OneDrive on the session hosts to share the files between the two.

@Luke Murray 

I think you may have nailed it on the head with not being able to read the files from the local machine even though the app seamlessly works as a local app.


We are using OneDrive replication so we are able to use the application to detect the file as OneDrive appears as a folder within the server.


I think the workaround or the solution that actually works is have all your apps installed on the "Remote Desktop" then you are able to assign "Server Defaults" so "Outlook" is able to open "Excel, Adobe, and any other file type"


Which in turn means that your local machine should be used like a "Thin Client" with nothing installed except "Remote Desktop"

Might be of interest, new Video from Azure Academy, requires third party software but integrates with AVD and looks to make user experiance easier:
Has anyone found a solution how to do the file association even with Seamless Applications (without starting a desktop once)?

Same here. Don't confuse the issue with trying to associate local files with remote apps. That's not what the poster is asking.


Poster has a situation where he needs to have a Remote App start from within another Remote App. E.g. the primary Remote App has an "Export to PDF" button, so you expect the file to exported, saved somewhere in a temp directory and then to be opened by you preferred PDF reader. Instead, it asks the user with which application the file should be opened. This is annoying, especially in some cases where the required association is not standard and the user has to go browsing the file system to choose the executable file of the secondary application.


His problem (and mine and many others) is that the default association xml file that you can set through Group Policies, has no effect if you open the Remote App only. It does work when connecting to a full desktop session and after having logged on once to a full desktop session, it also works for the Remote App.

Has a solution been found for the inability to set default apps using the "Set Default File Associations" XML with GPO in a WVD setup utilizing only RemoteApps?