Critical Error on Session Hosts when clicking the Start Button

Brass Contributor

We started encountering the following errors on our Session hosts: 


Critical Error:

 Your Start menu isn't working. We'll try to fix it the next time you sign in.

                                                                                    [sign out now]





so far a restart temporarily fixes the issue; but it comes back later on. It appears to be profile related since, not every login it encounters it.   


I'll update this thread once I get more info.                                              

8 Replies
Thanks for reporting. Please also check for windows event log to see any errors being reported there. Did you also deploy FSLogix?
no significant Events related to this. Yes, we do have FSLogix deployed.

@MarkF26 - we have just started having the same issue and keyboard click causes the same.  Did you get to the bottom of the issue?

@MarkF26 We're getting this message on some of our VDIs after upgrading them to 1809.  Please let me know if you find a resolution.



@MarkF26 just to join the party, we are deploying WVD with Windows 10 2004 Multi Session with FSLogix and we are seeing the issue. It seems to be fairly random as the user was working fine for a good while.

This is a known issue which already fixed. If you still experience it, please open a support case and recommend them support to escalate the case to Product team. and add the link of this post to your support case. Thanks.

@Soo Kuan Teo Not wanting to dig up an old thread but hoping this will help someone with the same issue. I've logged it with support but they weren't able to figure it out unfortunately. Running Windows 10 2004.


I found that when running Get-AppxPackage in PowerShell as the user it would return no results.

As a workaround, not a fix, I manually added the packages at logon.


Add-AppxPackage -Register "C:\Windows\SystemApps\Microsoft.Windows.StartMenuExperienceHost_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown
Add-AppxPackage -Register "C:\Windows\SystemApps\Microsoft.Windows.Search_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown
Add-AppxPackage -Register "C:\Windows\SystemApps\ShellExperienceHost_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown


It's not flawless as if the user clicks on the Start Menu before the script kicks in then they get the same error and the explorer process needs to be restarted for Search to work (or logout and back in again). To get around that I ran the script instead of the explorer shell with explorer being launched at the end of the script.

A reboot clears the AppxPackage list again so the script needs to run at every logon.


If anyone has an actual fix it would be nice to know.

After various updates to OS, and updates to the WVD Client, we are not experiencing this issue anymore.