SOLVED

Cannot log on to AADJ AVD when StrongAuthenticationRequired?

Occasional Contributor

Afternoon all

 

I tried setting up a pooled (but single host) environment just to test, with both win10 and win11. I've followed all the guides at the below link and Dean's video at Azure Academy for AADJ, but to no avail - getting an Incorrect Password (and it's definitely not). If I use another account without MFA, it logs in fine.

https://docs.microsoft.com/en-us/azure/virtual-desktop/deploy-azure-ad-joined-vm

https://docs.microsoft.com/en-us/azure/virtual-desktop/set-up-mfa

 

My conditional access policy is for "Azure Windows VM Sign-in" with zero conditions, under Access Controls/Grant I have nothing (MFA is NOT ticked), under Session, I have "sign-in frequency" of 1 day (not entirely sure this is correct however).

 

I traced my attempted connection through the sign-in logs, and it says it succeeded - which is weird. But it also says no Conditional Access policy applied. The appid of that success is 38aa3b87-a06d-4817-b275-7a316988d93b which led me here: https://cloudbrothers.info/en/the-case-of-signin-method-isnt-allowed/ and again, they're saying to use the app as designated at the above link. So it appears I have everything right, but still no joy.

Little help? Thanks in advance!

1 Reply
best response confirmed by andyinv (Occasional Contributor)