Basic auth / redirect clipboard without drives / controlling logout timings of subscription

Copper Contributor

Hello. I'm new to WVD. I have a few questions I hope you can help me with :smile:


  1. We subscribe to the applications in Remote Desktop with modern authentication. But then when we start the first application everytime we get this (please see attached image). We can say remember my credentials, which makes it go away, but is it really normal for this oldschool prompt to show up in the first place?

  2. When we redirect clipboard and disable the redirection of drives, it still redirects drives. We must disable clipboard redirection to not get the drives. We had a consultant which tried it in his demo environment and got the same behaviour. Is this really expected? Ideally, we want to be able to copy/paste text and nothing else. Is this possible?

  3. How do we control the logout timings of the Remote Desktop client? It seems that if we have a user log in (subscribe) and they leave their computer on they almost never have to login to that subscription again? Ideally we want it to require modern authentication with MFA daily.

Thank you so much! :smile:

3 Replies
best response confirmed by Melmix (Copper Contributor)

@Melmix For your first question, yes that is expected today as it's prompting for standard Active Directory credentials to sign in to the remote VM. This is similar to doing a manual RDP connecting to a remote system. We are working on functionality to improve this like supporting SSO using AD FS and eventually supporting AADJ VMs.


For the second question, this isn't expected. You should be able to disable drive redirection and leave clipboard redirection on. How are you disabling drive redirection?


For the prompting for MFA again on a daily basis, you can currently use the Sign In Frequency in AAD. Information can be found here:


@David Belanger thank you for your response. Regarding the second question, I have attached a screenshot (pic2.png) of the setting. I also tried some stuff in Advanced RDP Properties, but with no effect. When I change something in the Device redirection tab it automatically reflects in the Advanced RDP Properties. It currently shows like pic3.png.

Not sure why the 'Don't redirect any drives' option doesn't work, but try changing the advanced properties to drivestoreredirect:0 or in the GUI option, change to manually enter drive letters and enter 0.