Azure Compute Gallery  "'VMCustomization' is not enabled for the Subscription"

%3CLINGO-SUB%20id%3D%22%5C%26quot%3Blingo-sub-3151871%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Ben-US%5C%26quot%3B%22%3EAzure%20Compute%20Gallery%20%26nbsp%3B%22'VMCustomization'%20is%20not%20enabled%20for%20the%20Subscription%22%26lt%3B%5C%2Flingo-sub%26gt%3B%3CLINGO-BODY%20id%3D%22%5C%26quot%3Blingo-body-3151871%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Ben-US%5C%26quot%3B%22%3E%3CP%3EI%20started%20working%20a%20few%20months%20back%20with%20Azure%20Compute%20Gallery%20to%20build%20custom%20images%20for%20AVD.%20Yesterday%20suddenly%20getting%20deployment%20error%20when%20building%20a%20VM%20from%20my%20image%20that%26nbsp%3B%22'VMCustomization'%20is%20not%20enabled%20for%20the%20Subscription%22%26nbsp%3B%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EAnyone%20seen%20this%20before%3F%20Searching%20on%20this%20error%20has%20turned%20up%20nothing%20and%20so%20far%20nothing%20from%20Microsoft%20support%20either.%3CBR%20%2F%3E%3CBR%20%2F%3EOur%20Azure%20engineering%20team%20tried%20to%20enable%26nbsp%3B'Microsoft.Compute%2FVMCustomizationPreview'%20as%20per%20the%20error%20message%20and%20get%20error%20that%26nbsp%3B'Microsoft.Compute%2FVMCustomizationPreview'%20does%20not%20support%20registration.%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3EAnyone%20seen%20and%20solved%20this%20issue%3F%26lt%3B%5C%2FP%26gt%3B%26lt%3B%5C%2Flingo-body%26gt%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3C%2FLINGO-SUB%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3151871%22%20slang%3D%22en-US%22%3EAzure%20Compute%20Gallery%20%26nbsp%3B%22'VMCustomization'%20is%20not%20enabled%20for%20the%20Subscription%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3151871%22%20slang%3D%22en-US%22%3E%3CP%3EI%20started%20working%20a%20few%20months%20back%20with%20Azure%20Compute%20Gallery%20to%20build%20custom%20images%20for%20AVD.%20Yesterday%20suddenly%20getting%20deployment%20error%20when%20building%20a%20VM%20from%20my%20image%20that%26nbsp%3B%22'VMCustomization'%20is%20not%20enabled%20for%20the%20Subscription%22%26nbsp%3B%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EAnyone%20seen%20this%20before%3F%20Searching%20on%20this%20error%20has%20turned%20up%20nothing%20and%20so%20far%20nothing%20from%20Microsoft%20support%20either.%3CBR%20%2F%3E%3CBR%20%2F%3EOur%20Azure%20engineering%20team%20tried%20to%20enable%26nbsp%3B'Microsoft.Compute%2FVMCustomizationPreview'%20as%20per%20the%20error%20message%20and%20get%20error%20that%26nbsp%3B'Microsoft.Compute%2FVMCustomizationPreview'%20does%20not%20support%20registration.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20seen%20and%20solved%20this%20issue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

I started working a few months back with Azure Compute Gallery to build custom images for AVD. Yesterday suddenly getting deployment error when building a VM from my image that "'VMCustomization' is not enabled for the Subscription"  

Anyone seen this before? Searching on this error has turned up nothing and so far nothing from Microsoft support either.

Our Azure engineering team tried to enable 'Microsoft.Compute/VMCustomizationPreview' as per the error message and get error that 'Microsoft.Compute/VMCustomizationPreview' does not support registration.

 

Anyone seen and solved this issue?

3 Replies
Have you had success solving this? Running into the same issue.
Yes I found root issue is CLI. Have to wait for a fix in Azure CLI online, but in mean time have installed older version of Azure CLI on desktop which has resolved my issue.