AVD Agent 1.0.4574.900_release does not work with remote apps

Copper Contributor

Our validation pool recently got updated with AVD Agent version 1.0.4574.900_release. This version seems to be bad as remote apps does not work any more. The problems started at the same time as the agent was updated.  All connections using this version experienced the problems.


The behaviour we are seeing is that the app starts, but on the client we only see the icon representing the app in the taskbar. Activating the window is not possible. Connection info says that everything is OK. All operating systems are Windows 11 and the Remote Desktop Windows client is the latest version. We have also tried two previous versions of the client but the result is the same.


Anyone else seeing the same behaviour?


8 Replies
Swapping back to the production release 1.0.4230.1600 solved the problem (ValidationPool=False). Unfortunately this is not an option if version 1.0.4574.900 makes it into production.

@Xandven_ What process did you use to roll back to an older version of the application? Also where did you download the older agent?

@James Price When turning off validation pool the older version of the agent gets installed automatically. To roll back to an older version of the Windows Remote Desktop Client I uninstalled the current version and downloaded the older version from: What's new in the Windows Desktop client | Microsoft Docs


We see this exact problem for multiple deployments now. Agent version is 1.0.4452.2100, and client is latest 3130. Works intermittently, users need to keep logging out and in again, and just hopes that it works.. Any new info here?
We have a open support ticket on this, so the AVD team knows about the problem. Apparently lots of their customers have this problem. Personally I think this affects all users on the Windows Remote Desktop Client > v1.2.3004.

The problem got a lot worse on Monday/Tuesday and I suspect the reason was a AVD Agent Update. Only workaround that works for us is downgrading to the Windows Remote Desktop Client 1.2.3004.
We also have an Severity A case going. And yes, client 3004 was the "solution" for us too. Also downgraded the agent on the hosts to 1.0.4230.1600. One of our customers that had major problems yesterday, now reports that it works for them with latest client... other customers still have major issues and we downgrade their clients to 3004 to get them in. Or use the webclient.
We are getting closer to a solution. If the AVD Web Client is working ok then
GPO: Administrative Templates/Remote Desktop Services/Remote Desktop Session Host/Remote Session Environment [Use advanced RemoteFX graphics for RemoteApp] (or the corresponding registry key) might be causing the issue if set to disabled. Try changing it to Enabled (or not configured).
Yes, we did this on friday and everything was good. MS Support has informed me that the issue where windows can't render in non-HiDef+DVC mode was the cause, and that mitigations has been rolled out in Azure.