Adding Session Hosts to Pool from SIG fails

Copper Contributor

So I've run into this bizarre issue where most of the time when I try to add a session host to an existing WVD host pool, deployment fails with "OS provisioning for VM %Myhostname% failed. Error details: This installation of Windows is undeployable". This happens if I try to deploy two or more hosts through Azure portal.

However, after about a day I'm then able to add a single session host to the same pool with the same image version from the same SIG.


I wanted check if the image was sysprepped correctly, and stood up a couple of standalone VMs using this image - no issues whatsoever.

I also set Image replica count to 3 and Storage account type to premium SSD, thinking perhaps the storage didn't have enough throughput to handle more than one installation but received the same error.

All of the resources involved are located in East US region.
Has anyone faced anything strange like this with your WVD host pool?
2 Replies
best response confirmed by Roman_Pelekh (Copper Contributor)

Hi @Roman_Pelekh 


Never had this but it sounds like maybe your image in the SIG maybe corrupt? Have you tried creating a new SIG and see if that helps? Also what happens in your source region that the image originate from, do you get the same problem?

Hi @Neil McLoughlin 


We had to restore an older backup of the VM used for building the image and that one was still intact.


Still, I was quite puzzled why would I be able to create a regular VM without issues only to be be greeted with an error while deploying a WVD session host from it.


Thank you for the response.