Adding MSIX applications to the host pool

Brass Contributor


I've been trying to create some test MSIX packages for WVD project and currently facing a strange issue regarding uploading the apps. They've been signed, packed, converted to vhd on a test VM.
Tried to map the .vhd files and point the path out to add the apps but the same error pops up - "No MSIX packages could be retrieved from the image path" / "Error: Virtual disk not found".
I even included the .msix package into the .vhd alongside the unpacked files but it still didn't do the trick. Well.

On the other hand when I moved the prepared .vhd to a test storage account it just didn't accept the URL.
It starts with http:// though, should the path be somewhat converted and supplied in a different format while referencing the storage account?
Is anyone else experiencing issues when adding new msix packages to the host pool?



12 Replies
Have you tried putting the VHD on the c drive? and do the operation with one VM on a host pool

@Stefan Georgiev tried to do it from a VM outside the host pool. I will test it on a VM inside the host pool and we'll see what happens.

@Stefan Georgiev so I tried it as well and it didn't like my cert. Had to repack using Device Guard but then it said there is no msix on .vhd I linked.

I'm really confused because when trying to upload the .vhd either from VM or storage account I get below errors:
- can't find vhd
- cert issue

I repacked the thing today like 15 times using Device Guard as well as self-generated cert using PowerShell, signing during packing or adding cert later. Still nothing.

@ArkadiuszOpoczko Did you put the new certificate (with which the applications are packaged) on each machine in Trusted People? As for cannot find VHD, all session host machines must have access to the location

I am not expecting that VM outside of the host pool to work.

@Stefan Georgiev I tried adding a .vhd from a VM inside a host pool as well, still got the same errors though. Most of the time it just doesn't recognize the msix inside .vhd for some reason

You should never manually add files into the VHD that are not part of the MSIX, That breaks the validity of the MSIX package and we will report no valid MSIX is present.
Here is a video explaining the creation of the MSIX image
Now for the HTTPS? That is not how Azure Files work over SMB. I would recommend that on 1 of your machines you create a c:\share folder. Share it to everyone (read) put the package there and pass the path \\shares\<name of msix image>
I'm running into this error when trying to upload my vhd file.

ActivityId: bc38b82b-6c0b-42a3-96b7-191a6d8428f9 Error: The MSIX Application metadata expand request failed on all Session Hosts that it was sent to. Session Host: host-1, Error: Native error 32..Session Host: host-2, Error: Native error 32..Session Host: bio-4, Error: Native error 32.. (Code: 400)

There are 6 hosts in total from 0 to 5
Got similar error on the top "No MSIX Packages could be retrieved from the image path" but the error type was empty, my solution after more than 3 months with MS support was, have the -Desktop Virtualization Contributor BuiltInRole - and follow all the procedures to set the storage account
Hi, I am facing exactly the issue above, can you elaborate on what you did to resolve this?

@Victor Caicedo Just wanted to clarify your resolution. You add the -Desktop Virtualization Contributor BuiltInRole - to the admin user that you were using to add the MSIX package via the portal?



My issue had a different resolution. The certificate used for signing the msix package was not installed on the session hosts. This needs to be done prior to adding the MSIX as an available package to distribute. I thought this could be done after but this is not the case.