SOLVED

AAD Authentication Error

New Contributor

I have set up a fresh WVD host pool with two domain joined virtual machines running. I can subscribe to the feed with the Windows Virtual Desktop app from the store, but whenever I go through the webclient, I get an "AAD Authentication Error - Your credentials do not have access to this web application. Please try again with different credentials or from an InPrivate browser session".

I tried it in 3 different browsers and another device which is running under the AD account I have assigned to the application group. I also tried with a different account from the same assigned group.

 

I can open a desktop session when using the store client, but why is the website not allowing access?

3 Replies

@Niels_Ziegler  Hello. I am having this exact same issue when using the website to attempt to login. The Remote App works fine though. Have you managed to find the solution yet ?

 

Marcus

best response confirmed by Niels_Ziegler (New Contributor)
Solution

@MarcusMSRA 

 

Yes, I made the stupid mistake of using

https://rdweb.wvd.microsoft.com/webclient/index.html

 

instead of the link for the "after spring upate" version

https://rdweb.wvd.microsoft.com/arm/webclient/index.html

 

because the shortlink aka.ms/wvdweb led me to the older one.

@Niels_Ziegler it looks like I made the same mistake. Thanks for replying so quickly. This helped me out no end.

 

Marcus