Vertical Lines appear for Azure Virtuals

Vertical Lines appear for Azure Virtuals
7

Upvotes

Upvote

 Jun 04 2024
11 Comments (11 New)
New

For the past week or so, We have been getting vertical lines when connecting to our Azure virtuals. We have had complaints from Mac Users.. If we take a screen shot on the host pc, the vertical lines show up in it.

Comments
Copper Contributor

Following for updates. Mac users here are having issues too

Copper Contributor

I believe this issue is related to this one that was reported:
microsoft remote desktop macos graphic issue - Microsoft Community Hub

We're having many users reporting that they're seeing screen artifacts, lines, and blurry fonts in their Windows applications. The issue appeared to have started recently, around the June 4, 2024. It seems to coincide with the latest update pushed by Microsoft, Remote Desktop Services SxS Network Stack:

fwuC_0-1718034827890.png

 

This issue is occurring on Windows 10 and Windows 11 Azure Virtual Desktop machines and Windows 365 (Cloud PC), running Windows 10 and Windows 11 as well.

 

Users are also running Microsoft Remote Desktop version 10.9.7. Issue also occurred on users that were still running version 10.9.6.

Copper Contributor

I have users reporting this as well on Windows 10 Azure virtuals. This is only on Mac clients.

Copper Contributor

I have tested this occurs on the Remote desktop app on MacOS 10.9.7.

 

Working fine on

 

Windows Machine (msi installed client)

Web (safari and non safari)

 

Copper Contributor

Also wanted to say this is occurring for us, same version. Utilizing the Remote Desktop client beta from June 5th has significantly improved the visual quality, but there are still a few lines that appear occasionally.

Copper Contributor
Copper Contributor

Does anyone have an existing trouble ticket open with Microsoft?

Copper Contributor

This issue also has previously occurred last year:
https://techcommunity.microsoft.com/t5/azure-virtual-desktop-feedback/screen-artifacts-after-upgrade...

But that seemed to be related to Microsoft Remote Desktop version on macOS, this issue appears no matter what version of the client software is running on the macOS client side.

Copper Contributor

Our Mac users have reported similar issue, the virtical lines. The html web client on macOS works okay.

Copper Contributor

Latest from Microsoft support:

"This is a known issue and there is an IcM ticket for it."

 

"Additionally, please try the following steps on the session host..." "

This solution was suggested by a colleague who successfully resolved this issue for another customer.
  1. Go to Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Remote Session Environment.
  2. Select the policy Use hardware graphics adapters for all Remote Desktop Services sessions. Set this policy to Enabled to enable GPU rendering in the remote session.

Select the policy Configure H.264/AVC hardware encoding for Remote Desktop connections. Set this policy to Enabled to enable hardware encoding for AVC/H.264 in the remote session.

  1. Select the policy Prioritize H.264/AVC 444 Graphics mode for Remote Desktop connections. Set this policy to Enabled to force the H.264/AVC 444 codec in the remote session."


Launch gpedit.msc in order to configure the above on the host Windows instance to test:

fwuC_0-1718401028859.png

 

 

Copper Contributor

We've tested changes by pushing to affected Windows instances in Windows 365 (Cloud PC) and Azure Virtual Desktop via Group Policy Object (GPO):

 

fwuC_0-1719252676054.png

 

Results seem promising so far from feedback from users