Upgrade Azure Service Fabric Clusters* on Unsupported Versions Below 6.3.63.* By January 19, 2021

Published 01-07-2021 06:18 PM 2,049 Views

What is the  Issue? 

To improve security and availability, Azure infrastructure is making a change that may affect all Service Fabric clusters that belong to scenarios mentioned in the “Impacted Service Fabric Clusters” section.

 To avoid service disruptions, please take the recommended action to upgrade to one of the compatible supported versions listed below by January 19,2021. We have also posted an Upgrade alert on the Service Fabric supported versions page.

 

 Impact

Service Fabric clusters will not come up and will be unavailable if you have not upgraded to one of below supported versions.

 

Impacted Service Fabric Versions

Azure Service Fabric clusters which run on unsupported versions from 5.7 to 6.3.63.* 

 

Required Action

Upgrade Service Fabric clusters as soon as possible by January 19th  to versions listed below which include the necessary compatibility and will prevent downtime to clusters or loss of functionality. These versions are available in all regions.

  • Windows
    • 7.0.478
    • 7.1.503
    • 7.2.445
  • Ubuntu 16.04
    • 7.0.472
    • 7.1.455
    • 7.2.447
  • Ubuntu 18.04
    • 7.1.455
    • 7.2.447

If you have any questions or concerns, please contact us by opening a support request for Azure Service Fabric. In addition, here are your general support options for Service Fabric: Learn about Azure Service Fabric Support options - Azure Service Fabric | Microsoft Docs

 

1 Comment

Thank you for sharing this Important information with the Community!

%3CLINGO-SUB%20id%3D%22lingo-sub-2043194%22%20slang%3D%22en-US%22%3ERe%3A%20Upgrade%20Azure%20Service%20Fabric%20Clusters*%20on%20Unsupported%20Versions%20Below%206.3.63.*%20By%20January%2019%2C%202%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2043194%22%20slang%3D%22en-US%22%3E%3CP%3EThank%20you%20for%20sharing%20this%20Important%20information%20with%20the%20Community!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2041278%22%20slang%3D%22en-US%22%3EUpgrade%20Azure%20Service%20Fabric%20Clusters*%20on%20Unsupported%20Versions%20Below%206.3.63.*%20By%20January%2019%2C%202021%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2041278%22%20slang%3D%22en-US%22%3E%3CP%3E%3CFONT%20size%3D%225%22%3E%3CSTRONG%3EWhat%20is%20the%20%26nbsp%3BIssue%3F%26nbsp%3B%3C%2FSTRONG%3E%3C%2FFONT%3E%3C%2FP%3E%0A%3CP%3ETo%20improve%20security%20and%20availability%2C%20Azure%20infrastructure%20is%20making%20a%20change%20that%20may%20affect%20all%20Service%20Fabric%20clusters%20that%20belong%20to%20scenarios%20mentioned%20in%20the%20%E2%80%9C%3CSTRONG%3EImpacted%20Service%20Fabric%20Clusters%3C%2FSTRONG%3E%E2%80%9D%20section.%3C%2FP%3E%0A%3CP%3E%26nbsp%3BTo%20avoid%20service%20disruptions%2C%20please%20take%20the%20recommended%20action%20to%20upgrade%20to%20one%20of%20the%20compatible%20supported%20versions%20listed%20below%20by%20%3CSTRONG%3EJanuary%2019%2C2021%3C%2FSTRONG%3E.%20We%20have%20also%20posted%20an%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fservice-fabric%2Fservice-fabric-versions%23upgrade-alert-for-versions-between-57-and-below-6363%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3EUpgrade%20alert%3C%2FA%3E%20on%20the%20Service%20Fabric%20supported%20versions%20page.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CFONT%20size%3D%225%22%3E%26nbsp%3B%3CSTRONG%3EImpact%3C%2FSTRONG%3E%3C%2FFONT%3E%3C%2FP%3E%0A%3CP%3E%3CSTRONG%3E%3CU%3EService%20Fabric%20clusters%20will%3C%2FU%3E%3C%2FSTRONG%3E%3CSTRONG%3E%3CU%3E%20not%20come%20up%20and%20will%20be%20unavailable%20if%20you%20have%20not%20upgraded%20%3C%2FU%3E%3C%2FSTRONG%3E%3CU%3Et%3C%2FU%3Eo%20one%20of%20below%20supported%20versions.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CFONT%20size%3D%225%22%3E%3CSTRONG%3EImpacted%20Service%20Fabric%20Versions%3C%2FSTRONG%3E%3C%2FFONT%3E%3C%2FP%3E%0A%3CP%3EAzure%20Service%20Fabric%20clusters%20which%20run%20on%20%3CSTRONG%3Eunsupported%20versions%20from%205.7%20to%206.3.63.*%3C%2FSTRONG%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CFONT%20size%3D%225%22%3E%3CSTRONG%3ERequired%20Action%3C%2FSTRONG%3E%3C%2FFONT%3E%3C%2FP%3E%0A%3CP%3E%3CSTRONG%3E%3CU%3EUpgrade%20Service%26nbsp%3BFabric%26nbsp%3Bclusters%20as%20soon%20as%20possibl%3C%2FU%3E%3C%2FSTRONG%3E%3CSTRONG%3Ee%20by%20January%2019th%26nbsp%3B%3C%2FSTRONG%3E%20to%20versions%20listed%20below%20which%20include%20the%20necessary%20compatibility%20and%20will%20prevent%20downtime%20to%20clusters%20or%20loss%20of%20functionality.%20These%20versions%20are%20available%20in%20all%20regions.%3C%2FP%3E%0A%3CUL%3E%0A%3CLI%3E%3CSTRONG%3EWindows%20%3C%2FSTRONG%3E%3C%2FLI%3E%0A%3CUL%3E%0A%3CLI%3E7.0.478%3C%2FLI%3E%0A%3CLI%3E7.1.503%3C%2FLI%3E%0A%3CLI%3E7.2.445%3C%2FLI%3E%0A%3C%2FUL%3E%0A%3C%2FUL%3E%0A%3CUL%3E%0A%3CLI%3E%3CSTRONG%3EUbuntu%2016.04%20%3C%2FSTRONG%3E%3C%2FLI%3E%0A%3CUL%3E%0A%3CLI%3E7.0.472%3C%2FLI%3E%0A%3CLI%3E7.1.455%3C%2FLI%3E%0A%3CLI%3E7.2.447%3C%2FLI%3E%0A%3C%2FUL%3E%0A%3CLI%3E%3CSTRONG%3EUbuntu%2018.04%20%3C%2FSTRONG%3E%3C%2FLI%3E%0A%3CUL%3E%0A%3CLI%3E7.1.455%3C%2FLI%3E%0A%3CLI%3E7.2.447%3C%2FLI%3E%0A%3C%2FUL%3E%0A%3C%2FUL%3E%0A%3CP%3EIf%20you%20have%20any%20questions%20or%20concerns%2C%20please%E2%80%AF%3CA%20href%3D%22https%3A%2F%2Fportal.azure.com%2F%23blade%2FMicrosoft_Azure_Support%2FHelpAndSupportBlade%2Foverview%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Econtact%20us%3C%2FA%3E%E2%80%AFby%20opening%20a%20support%20request%20for%20Azure%20Service%20Fabric.%26nbsp%3BIn%20addition%2C%20here%20are%20your%20general%20support%20options%20for%20Service%20Fabric%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fazure%2Fservice-fabric%2Fservice-fabric-support%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3ELearn%20about%20Azure%20Service%20Fabric%20Support%20options%20-%20Azure%20Service%20Fabric%20%7C%20Microsoft%20Docs%3C%2FA%3E.%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-TEASER%20id%3D%22lingo-teaser-2041278%22%20slang%3D%22en-US%22%3E%3CH1%20id%3D%22toc-hId-1243085527%22%3E%3CSPAN%3EUpgrade%20Azure%20Service%20Fabric%20Clusters%20on%20Unsupported%20Versions%20below%20%3C%2FSPAN%3E%26nbsp%3B%3CSPAN%3E6.3.63.*%26nbsp%3B%20by%26nbsp%3BJanuary%2019%2C%202021%3C%2FSPAN%3E%3C%2FH1%3E%3C%2FLINGO-TEASER%3E
Version history
Last update:
‎Jan 12 2021 03:39 PM
Updated by: