SOLVED

Notebooks error while installing msticpy package

%3CLINGO-SUB%20id%3D%22lingo-sub-2097669%22%20slang%3D%22en-US%22%3ENotebooks%20error%20while%20installing%20msticpy%20package%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2097669%22%20slang%3D%22en-US%22%3E%3CP%3Ehi%2C%20I'm%20trying%20to%20get%20started%20with%20notebooks%20by%20using%20one%20of%20the%20default%20ones%20provided%20in%20Sentinel.%20But%2C%20when%20I%20was%20trying%20to%20execute%2C%20I'm%20continuously%20hitting%20with%20the%20below%20error%2C%20not%20sure%20if%20I'm%20missing%20anything%2C%20can%20anyone%20help%20me%20out%20here%3F%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CDIV%3EThe%20package%20'%3CSTRONG%3Emsticpy%3C%2FSTRONG%3E'%20is%20not%20installed%20or%20has%20an%20incorrect%20version%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3EAnd%20I'm%20trying%20to%20install%20PowerShell%20kernel%20as%20per%20the%20steps%20mentioned%20in%20this%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fazure-sentinel%2Fwhat-s-new-powershell-azure-sentinel-notebooks-to-supercharge%2Fba-p%2F1695969%22%20target%3D%22_self%22%3Earticle%3C%2FA%3E%2C%20but%20getting%20attached%20err%20in%20the%20terminal%2C%20there%20might%20be%20some%20silly%20mistake%20I'm%20doing%2C%20but%20unable%20to%20find%20what%20it%20is...%3CDIV%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%3CP%3EAny%20help%20would%20be%20appreciated.%3C%2FP%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2097886%22%20slang%3D%22en-US%22%3ERe%3A%20Notebooks%20error%20while%20installing%20msticpy%20package%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2097886%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F923986%22%20target%3D%22_blank%22%3E%40printscreen%3C%2FA%3E%26nbsp%3BHave%20you%20gone%20through%20all%20the%20steps%20outlines%20in%20the%20%22%3CSPAN%3EA%20Getting%20Started%20Guide%20For%20Azure%20Sentinel%20ML%20Notebooks%22%20notebook%3F%26nbsp%3B%20It%20has%20a%20lot%20of%20configuration%20steps%20that%2C%20if%20missed%2C%20may%20be%20causing%20an%20issue.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

hi, I'm trying to get started with notebooks by using one of the default ones provided in Sentinel. But, when I was trying to execute, I'm continuously hitting with the below error, not sure if I'm missing anything, can anyone help me out here? 

 

The package 'msticpy' is not installed or has an incorrect version
 
And I'm trying to install PowerShell kernel as per the steps mentioned in this article, but getting attached err in the terminal, there might be some silly mistake I'm doing, but unable to find what it is...
 

Any help would be appreciated.

5 Replies

@printscreen Have you gone through all the steps outlines in the "A Getting Started Guide For Azure Sentinel ML Notebooks" notebook?  It has a lot of configuration steps that, if missed, may be causing an issue.

@printscreen It seems msticpy package is missing. Please run the either of the below two commands to install msticpy library and then execute your rest commands.

pip install msticpy

 or 

pip install git+https://github.com/microsoft/msticpy

 

 

@printscreen 

Use this to install the correct version of msticpy :

 

pip install git+https://github.com/microsoft/msticpy@v0.8.0

 

@ESPANETYANN @AnuragSrivastava @Gary Bushey Thanks for your response. I was able to install msticpy.

 

DO you have any idea about using Powershell kernel in Notebooks, I'm following this article and reached up to this below step where I got stuck with the below error, if you have any idea about this, that would be appreciated.

 

printscreen_0-1612174807677.png

 

dotnet tool install -g --add-source "https://dotnet.myget.org/F/dotnet-try/api/v3/index.json" Microsoft.dotnet-interactive

 

 

Best Response confirmed by printscreen (Contributor)
Solution

@printscreen You are getting the error because the feed ("https://dotnet.myget.org/F/dotnet-try/api/v3/index.json") doesn't exist.

 

Please try installing with the below command:

dotnet tool install --global Microsoft.dotnet-interactive --version 1.0.155302