how do you cope without the Azure Sentinel Agant MMA available for Centos 8.0?

%3CLINGO-SUB%20id%3D%22lingo-sub-1538615%22%20slang%3D%22en-US%22%3Ehow%20do%20you%20cope%20without%20the%20Azure%20Sentinel%20Agant%20MMA%20available%20for%20Centos%208.0%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1538615%22%20slang%3D%22en-US%22%3E%3CP%3EHow%20do%20you%20work%20around%20or%20cope%20with%20the%20fact%20that%20the%20Microsoft%20Management%20Agent%20is%20NOT%20available%20for%20CentOS%208.0%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnd%20of%20course%2C%20the%20other%20question%2C%20does%20anybody%20have%20a%20crystal%20ball%20as%20to%20when%20the%20Agent%20might%20become%20available%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnd%20how%20is%20this%20MMA%20agent%20requirement%20of%20having%20to%20have%20a%20python%20ver.%202.x%20system%20or%20os%20default%20python%20version%20playing%20out%20on%20other%20Linux%20distro%3F%20Surely%20no%20recent%20distro%20still%20has%20a%20python%20ver%202.x%20os%20or%20system%20python%20version%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfterall%20Python%202.x%20has%20now%20been%20EOL%20for%20several%20months%20and%20everybody%20had%20plenty%20of%20warning%20to%20prepare%20for%20this.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1538953%22%20slang%3D%22en-US%22%3ERe%3A%20how%20do%20you%20cope%20without%20the%20Azure%20Sentinel%20Agant%20MMA%20available%20for%20Centos%208.0%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1538953%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F464287%22%20target%3D%22_blank%22%3E%40TheBigBear%3C%2FA%3E%26nbsp%3B%20Not%20sure%20if%20this%20will%20fix%20your%20issue%20but%20y%3C%2FP%3E%3CP%3Eou%20can%20use%20python%203%20for%20the%20MMA%20agent.%26nbsp%3B%20You%20would%20need%20to%20run%3A%3C%2FP%3E%3CPRE%3Esudo%20alternatives%20--set%20python%20%2Fusr%2Fbin%2Fpython3%3C%2FPRE%3E%3CP%3Eto%20map%20Python%203%20as%20the%20default%20python%20version.%26nbsp%3B%20You%20can%20then%20run%20the%20wget%20command%20that%20you%20get%20from%20Azure%20Sentinel%20to%20install%20the%20MMA.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1539500%22%20slang%3D%22en-US%22%3ERe%3A%20how%20do%20you%20cope%20without%20the%20Azure%20Sentinel%20Agant%20MMA%20available%20for%20Centos%208.0%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1539500%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F46875%22%20target%3D%22_blank%22%3E%40Gary%20Bushey%3C%2FA%3E%26nbsp%3BHi%2C%20Thanks%2C%20but%20I%20had%20already%20tried%20that%20-%20as%20it%20is%20the%20default%20on%20centos%208.0%20but%20the%20MMA%20installer%20caught%20that%20and%20said%20it%20actually%20required%20the%20os%20system%20python%20to%20be%20python%20ver%202.x%20and%20asked%20me%20to%20run%20the%20alternatives%20setting%20the%20centos%208%20system%20python%20to%20version%20%222%22%2C%20which%20of%20course%20is%20untenable.%20They%20have%20a%20note%20on%20the%20MMA%20agent%20download%20page%20that%20says%20same%20thing%20that%20you%20absolutely.%20do%20need%20python%202.x%20as%20main%20system%20and%20os%20python.%20Even%20reached%20out%20to%20MS%20and%20was%20told%20yes%2C%20we%20know%20centos%208%20is%20not%20a%20supported%20system%20...%20%3B-(%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1547266%22%20slang%3D%22en-US%22%3ERe%3A%20how%20do%20you%20cope%20without%20the%20Azure%20Sentinel%20Agant%20MMA%20available%20for%20Centos%208.0%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1547266%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F464287%22%20target%3D%22_blank%22%3E%40TheBigBear%3C%2FA%3E%26nbsp%3B%3A%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fazure-monitor%2Fplatform%2Flog-analytics-agent%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ethis%3C%2FA%3E%20page%20suggests%20that%20you%20can%20install%20Python%202%20on%20a%20system%20that%20does%20not%20include%20Python%202%20by%20default%20and%20also%20how%20to%20symlink%20it%20to%20Python%20using%20alternatives.%20Did%20you%20try%20it%3F%20It%20is%20very%20uncommon%20that%20something%20that%20runs%20on%20a%20RHEL%20version%20does%20not%20run%20on%20a%20correspnding%20CentOS%20version%20(and%20RHEL%20also%20does%20not%20have%20version-less%20%22python%22%20by%20default%20and%20recommend%20using%20alternatives).%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1547338%22%20slang%3D%22en-US%22%3ERe%3A%20how%20do%20you%20cope%20without%20the%20Azure%20Sentinel%20Agant%20MMA%20available%20for%20Centos%208.0%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1547338%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F293879%22%20target%3D%22_blank%22%3E%40Ofer_Shezaf%3C%2FA%3E%26nbsp%3Bthanks%20for%20your%20reply%2C%20but%20it%20would%20seem%20you%20only%20know%20Linux%20%22in%20theory%22%2C%20sorry%20for%20saying%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYes%2C%20I%20know%20Python%202.x%20can%20be%20installed%20BUT%20that%20is%20simply%20not%20acceptable%20as%20the%20main%20os%20python%20since%20python%202.x%20is%20now%20EOL.%20The%20main%20os%20Python%20now%20needs%20to%20be%203.x.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20point%20of%20such%20an%20'alternative'%20system%20in%20Linux%20is%20to%20point%20the%20'os'%20to%20one%20-%20the%20main%20-%20selected%20system%20(%20one%20alternative%20out%20of%20a%20few%20for%20a%20task%20)%2C%20and%20NOT%20to%20introduce%20yet%20another%20alternative%20-%20word%20has%20more%20than%20one%20meaning%20and%20therefore%20leads%20to%20more%20than%20one%20interpretation.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20point%20was%20and%20still%20is.%20That%20python%202.x%20is%20now%20EOL%20and%20python%20is%20used%20by%20some%20parts%20of%20a%20Linux%20os%20install%20and%20as%20such%20an%20up%20to%20date%20installation%20that%20is%20PCI%20DSS%20compliant%20and%20compatible%20to%20current%20company%20policies%2C%20now%20clearly%20mandates%20and%20requires%20the%20os%20python%20version%20(%20the%20one%20pointed%20to%20by%20the%20alternatives%20system%20)%20to%20be%20the%20current%20python%203.x.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20that%20is%20what%20I%20find%20hard%20to%20take%20in%20that%20MS%20still%20uses%20an%20MMA%20that%20depends%20on%20python%202.x%20%2C%20but%20only%20calls%20it%20as%20'python'%20thereby%20necessitating%20the%20main%20os%20python%20to%20be%20python%202.x%2C%20when%20it%20could%20nearly%20as%20easily%20have%20chosen%20to%20simply%20call%20python2%20instead%20of%20the%20only%20python%2C%20and%20magically%20it%20would%20call%20up%20python%202.x%20.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMost%20(all%3F)%20Linux%20distributions%20support%20having%20multiple%20parallel%20versions%20of%20python%20installed%20and%20the%20calling%20app%20simply%20calls%20python%20(%20pointing%20to%20python%203.x%20these%20days%20)%20or%20python3%20or%20python2.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1549606%22%20slang%3D%22en-US%22%3ERe%3A%20how%20do%20you%20cope%20without%20the%20Azure%20Sentinel%20Agant%20MMA%20available%20for%20Centos%208.0%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1549606%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F464287%22%20target%3D%22_blank%22%3E%40TheBigBear%3C%2FA%3E%2C%26nbsp%3BSo%2C%20to%20summarize%2C%20the%20challenge%20is%20not%20CentOS%208%20support%20by%20itself.%20RHEL%208%2C%20which%20is%20officially%20supported%2C%20would%20still%20be%20an%20issue%20because%20running%20the%20agent%20requires%20making%20Python%202%20the%20default.%20In%20other%20words%2C%20just%20certifying%20CentOS%208%2C%20without%20moving%20to%20Python%203%2C%20would%20not%20help%20here.%20Correct%3F%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1549615%22%20slang%3D%22en-US%22%3ERe%3A%20how%20do%20you%20cope%20without%20the%20Azure%20Sentinel%20Agant%20MMA%20available%20for%20Centos%208.0%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1549615%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F464287%22%20target%3D%22_blank%22%3E%40TheBigBear%3C%2FA%3E%26nbsp%3B%3A%20one%20more%20thought%3A%20would%20keeping%20to%20Python%202%20for%20now%20but%20ensruring%20the%20agent%20runs%20without%20requiring%20python%202%20to%20be%20the%20system%20default%20be%20a%20reasonable%20interim%20solution%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1549622%22%20slang%3D%22en-US%22%3ERe%3A%20how%20do%20you%20cope%20without%20the%20Azure%20Sentinel%20Agant%20MMA%20available%20for%20Centos%208.0%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1549622%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F293879%22%20target%3D%22_blank%22%3E%40Ofer_Shezaf%3C%2FA%3E%2C%20yes%2C%20well%20summarised.%3C%2FP%3E%3CP%3EOr%20alternatively%2C%20as%20a%20time-limited%20workaround%2C%20until%20the%20MMA%20code%20is%20upgraded%20to%20python%203.x%20'simply'%20change%20the%20MS%20MMA%20to%20be%20more%20specific%20and%20actually%20use%20python2%20and%20not%20just%20python.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThat%20way%20the%20Linux%20os%20can%20do%20the%20right%20thing.%20And%20all%20Linux%20distros%20I%20know%20off%20do%20support%20having%20more%20than%20one%20version%20of%20python%20installed%20in%20parallel%2C%20but%20in%20order%20to%20get%20to%20an%20older%20version%20one%20simply%20has%20to%20be%20more%20precise%20and%20call%20on%20it%20by%20issuing%20'python2'%20and%20not%20just%20'python'%3C%2FP%3E%3CP%3EBut%20medium%20and%20longer-term%20the%20MS%20MMA%20should%20be%20based%20on%20python%203%20and%20not%20on%20python%202%20which%20is%20EOL%20now.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1549626%22%20slang%3D%22en-US%22%3ERe%3A%20how%20do%20you%20cope%20without%20the%20Azure%20Sentinel%20Agant%20MMA%20available%20for%20Centos%208.0%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1549626%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F293879%22%20target%3D%22_blank%22%3E%40Ofer_Shezaf%3C%2FA%3E%26nbsp%3Byes%2C%20that%20is%20a%20more%20succinct%20way%20of%20saying%20what%20I%20just%20replied%2C%20Messages%20crossed%20over.%20In%20mine%2C%20I%20just%20also%20spelled%20out%20one%20way%20I%20think%20this%20should%20work%20'easily'%20...%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1552497%22%20slang%3D%22en-US%22%3ERe%3A%20how%20do%20you%20cope%20without%20the%20Azure%20Sentinel%20Agant%20MMA%20available%20for%20Centos%208.0%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1552497%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F464287%22%20target%3D%22_blank%22%3E%40TheBigBear%3C%2FA%3E%20%3A%20I%20had%20a%20chat%20with%20the%20agent%20PM%20and%20he%20told%20me%20that%20supporing%20systems%20with%20Python%203%20is%20being%20worked%20on%20as%20we%20speak.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

How do you work around or cope with the fact that the Microsoft Management Agent is NOT available for CentOS 8.0?

 

And of course, the other question, does anybody have a crystal ball as to when the Agent might become available?

 

And how is this MMA agent requirement of having to have a python ver. 2.x system or os default python version playing out on other Linux distro? Surely no recent distro still has a python ver 2.x os or system python version?

 

Afterall Python 2.x has now been EOL for several months and everybody had plenty of warning to prepare for this. 

 

 

9 Replies
Highlighted

@TheBigBear  Not sure if this will fix your issue but y

ou can use python 3 for the MMA agent.  You would need to run:

sudo alternatives --set python /usr/bin/python3

to map Python 3 as the default python version.  You can then run the wget command that you get from Azure Sentinel to install the MMA.

 

Highlighted

@Gary Bushey Hi, Thanks, but I had already tried that - as it is the default on centos 8.0 but the MMA installer caught that and said it actually required the os system python to be python ver 2.x and asked me to run the alternatives setting the centos 8 system python to version "2", which of course is untenable. They have a note on the MMA agent download page that says same thing that you absolutely. do need python 2.x as main system and os python. Even reached out to MS and was told yes, we know centos 8 is not a supported system ... ;-(

Highlighted

@TheBigBear : this page suggests that you can install Python 2 on a system that does not include Python 2 by default and also how to symlink it to Python using alternatives. Did you try it? It is very uncommon that something that runs on a RHEL version does not run on a correspnding CentOS version (and RHEL also does not have version-less "python" by default and recommend using alternatives). 

Highlighted

@Ofer_Shezaf thanks for your reply, but it would seem you only know Linux "in theory", sorry for saying?

 

Yes, I know Python 2.x can be installed BUT that is simply not acceptable as the main os python since python 2.x is now EOL. The main os Python now needs to be 3.x. 

 

The point of such an 'alternative' system in Linux is to point the 'os' to one - the main - selected system ( one alternative out of a few for a task ), and NOT to introduce yet another alternative - word has more than one meaning and therefore leads to more than one interpretation. 

 

My point was and still is. That python 2.x is now EOL and python is used by some parts of a Linux os install and as such an up to date installation that is PCI DSS compliant and compatible to current company policies, now clearly mandates and requires the os python version ( the one pointed to by the alternatives system ) to be the current python 3.x. 

 

So that is what I find hard to take in that MS still uses an MMA that depends on python 2.x , but only calls it as 'python' thereby necessitating the main os python to be python 2.x, when it could nearly as easily have chosen to simply call python2 instead of the only python, and magically it would call up python 2.x . 

 

Most (all?) Linux distributions support having multiple parallel versions of python installed and the calling app simply calls python ( pointing to python 3.x these days ) or python3 or python2. 

 

 

 

Highlighted

@TheBigBear, So, to summarize, the challenge is not CentOS 8 support by itself. RHEL 8, which is officially supported, would still be an issue because running the agent requires making Python 2 the default. In other words, just certifying CentOS 8, without moving to Python 3, would not help here. Correct?  

Highlighted

@TheBigBear : one more thought: would keeping to Python 2 for now but ensruring the agent runs without requiring python 2 to be the system default be a reasonable interim solution? 

Highlighted

Hi @Ofer_Shezaf, yes, well summarised.

Or alternatively, as a time-limited workaround, until the MMA code is upgraded to python 3.x 'simply' change the MS MMA to be more specific and actually use python2 and not just python. 

 

That way the Linux os can do the right thing. And all Linux distros I know off do support having more than one version of python installed in parallel, but in order to get to an older version one simply has to be more precise and call on it by issuing 'python2' and not just 'python'

But medium and longer-term the MS MMA should be based on python 3 and not on python 2 which is EOL now. 

Highlighted

@Ofer_Shezaf yes, that is a more succinct way of saying what I just replied, Messages crossed over. In mine, I just also spelled out one way I think this should work 'easily' ... 

Highlighted

@TheBigBear : I had a chat with the agent PM and he told me that supporing systems with Python 3 is being worked on as we speak.