SOLVED

Failed To Fetch Playbook

%3CLINGO-SUB%20id%3D%22lingo-sub-1370011%22%20slang%3D%22en-US%22%3EFailed%20To%20Fetch%20Playbook%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1370011%22%20slang%3D%22en-US%22%3E%3CP%3EHello!%3C%2FP%3E%3CP%3EI'm%20trying%20to%20create%20a%20simple%20playbook%20that%20sends%20me%20an%20email%20when%20an%20alert%20happens.%20But%20I%20receive%20the%20%22%26nbsp%3B%3CA%20target%3D%22_blank%22%3E%3CSPAN%20class%3D%22fxs-blade-status-text%22%3EFailed%20to%20fetch%20playbooks%20in%20one%20or%20more%20selected%20subscriptions%22%26nbsp%3B%3C%2FSPAN%3E%3C%2FA%3E%2C%20every%20time%20I%20go%20to%20the%20Playbooks%20section%20under%20Configuration.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20playbook%20was%20created%20under%20the%20same%20subscription%20and%20I'm%20the%20admin%20for%20the%20account.%20What%20would%20cause%20this%20issue%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20image-alt%3D%22failed.PNG%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F189804iE7761FA6639E7E2D%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22failed.PNG%22%20alt%3D%22Error%20in%20Sentinel%22%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-caption%22%20onclick%3D%22event.preventDefault()%3B%22%3EError%20in%20Sentinel%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1371403%22%20slang%3D%22en-US%22%3ERe%3A%20Failed%20To%20Fetch%20Playbook%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1371403%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F47533%22%20target%3D%22_blank%22%3E%40Brendon%20Brooks%3C%2FA%3E%26nbsp%3BWhy%20does%20your%20Trigger%20Kind%20say%20%22Other%22%3F%26nbsp%3B%20If%20its%20a%20Playbook%20designed%20for%20Azure%20Sentinel%2C%20the%20Trigger%20type%20needs%20to%20be%20the%20Azure%20Sentinel%20Logic%20App%20connector.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1371776%22%20slang%3D%22en-US%22%3ERe%3A%20Failed%20To%20Fetch%20Playbook%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1371776%22%20slang%3D%22en-US%22%3E%3CP%3EI%20deleted%20the%20previous%20app%20and%20used%20the%20correct%20connector.%20The%20error%20still%20appears%2C%20but%20I%20can%20wait%20a%20day%20for%20it%20to%20clear.%20Thanks%20for%20pointing%20that%20out.%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F324945%22%20target%3D%22_blank%22%3E%40rodtrent%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1377104%22%20slang%3D%22en-US%22%3ERe%3A%20Failed%20To%20Fetch%20Playbook%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1377104%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F47533%22%20target%3D%22_blank%22%3E%40Brendon%20Brooks%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDo%20you%20have%20correct%20permissions%20in%20IAM%3F%20you%20may%20be%20getting%20this%20error%20due%20to%20permissions.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1377141%22%20slang%3D%22en-US%22%3ERe%3A%20Failed%20To%20Fetch%20Playbook%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1377141%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F570807%22%20target%3D%22_blank%22%3E%40arshad80%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20should.%20I'm%20the%20admin%20for%20our%20tenant.%20Is%20there%20somewhere%20in%20Azure%20where%20this%20needs%20to%20implicitly%20specified%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1377412%22%20slang%3D%22en-US%22%3ERe%3A%20Failed%20To%20Fetch%20Playbook%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1377412%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F47533%22%20target%3D%22_blank%22%3E%40Brendon%20Brooks%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3Etry%20adding%20yourself%20owner%20on%20the%20resource%20group%20where%20you%20have%20Sentinel%20instance.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2020973%22%20slang%3D%22en-US%22%3ERe%3A%20Failed%20To%20Fetch%20Playbook%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2020973%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F570807%22%20target%3D%22_blank%22%3E%40arshad80%3C%2FA%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F47533%22%20target%3D%22_blank%22%3E%40Brendon%20Brooks%3C%2FA%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDid%20that%20work%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hello!

I'm trying to create a simple playbook that sends me an email when an alert happens. But I receive the " Failed to fetch playbooks in one or more selected subscriptions" , every time I go to the Playbooks section under Configuration. 

 

My playbook was created under the same subscription and I'm the admin for the account. What would cause this issue?

 

Error in SentinelError in Sentinel

 

6 Replies
Best Response confirmed by Brendon Brooks (New Contributor)
Solution

@Brendon Brooks Why does your Trigger Kind say "Other"?  If its a Playbook designed for Azure Sentinel, the Trigger type needs to be the Azure Sentinel Logic App connector.

I deleted the previous app and used the correct connector. The error still appears, but I can wait a day for it to clear. Thanks for pointing that out. @rodtrent 

@Brendon Brooks 

Do you have correct permissions in IAM? you may be getting this error due to permissions.

 

@arshad80

 

I should. I'm the admin for our tenant. Is there somewhere in Azure where this needs to implicitly specified?

@Brendon Brooks 

try adding yourself owner on the resource group where you have Sentinel instance.

@arshad80 @Brendon Brooks 

 

Did that work?