Data Lineage Not Visible for ADF Pipelines & Datasets

%3CLINGO-SUB%20id%3D%22lingo-sub-2003620%22%20slang%3D%22en-US%22%3EData%20Lineage%20Not%20Visible%20for%20ADF%20Pipelines%20%26amp%3B%20Datasets%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2003620%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20everyone!%3C%2FP%3E%3CP%3EAfter%20creating%20an%20ADF%20connection%20in%20the%20Management%20Center%20(img_adf_connection)%2C%20I%20re-trigger%20all%20my%20ADF%20pipelines%2C%20after%20which%20ADF%20starts%20showing%20up%20in%20View%20Insights%20section%20(img_assets).%20All%20the%20ADF%20pipelines%20are%20visible%20as%20well.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%2C%20the%20lineage%20isn't%20available%20for%20any%20of%20the%20ADF%20pipelines%20(for%20instance%2C%20refer%20to%20img_adf_lineage).%20Furthermore%2C%20the%20data%20lineage%20for%20any%20of%20my%20scanned%20datasets%20isn't%20available%20too%20(for%20instance%2C%20refer%20to%20img_sqldb_lineage).%20I've%20tried%20re-triggering%20the%20pipelines%20as%20well%20as%20re-scanning%20the%20sources%20(Storage%20accounts%20and%20SQL%20Databases)%20multiple%20times%2C%20but%20lineage%20is%20still%20not%20available.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20else%20faced%20a%20similar%20issue%3F%20Any%20help%20would%20be%20appreciated!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20in%20advance!%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22img_adf_connection.png%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F241850iF6A4A79C1A61BC82%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22img_adf_connection.png%22%20alt%3D%22img_adf_connection%22%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-caption%22%20onclick%3D%22event.preventDefault()%3B%22%3Eimg_adf_connection%3C%2FSPAN%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22img_assets.png%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F241852iB8DA7B0EF27C0FCF%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22img_assets.png%22%20alt%3D%22img_assets%22%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-caption%22%20onclick%3D%22event.preventDefault()%3B%22%3Eimg_assets%3C%2FSPAN%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22img_adf_lineage.png%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F241854i587464567A47FD46%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22img_adf_lineage.png%22%20alt%3D%22img_adf_lineage%22%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-caption%22%20onclick%3D%22event.preventDefault()%3B%22%3Eimg_adf_lineage%3C%2FSPAN%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22img_sqldb_lineage.png%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F241855iF2E4ECD6B5ECDBA9%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22img_sqldb_lineage.png%22%20alt%3D%22img_sqldb_lineage%22%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-caption%22%20onclick%3D%22event.preventDefault()%3B%22%3Eimg_sqldb_lineage%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hello everyone!

After creating an ADF connection in the Management Center (img_adf_connection), I re-trigger all my ADF pipelines, after which ADF starts showing up in View Insights section (img_assets). All the ADF pipelines are visible as well.

 

However, the lineage isn't available for any of the ADF pipelines (for instance, refer to img_adf_lineage). Furthermore, the data lineage for any of my scanned datasets isn't available too (for instance, refer to img_sqldb_lineage). I've tried re-triggering the pipelines as well as re-scanning the sources (Storage accounts and SQL Databases) multiple times, but lineage is still not available.

 

Has anyone else faced a similar issue? Any help would be appreciated!

 

Thanks in advance!

img_adf_connectionimg_adf_connectionimg_assetsimg_assetsimg_adf_lineageimg_adf_lineageimg_sqldb_lineageimg_sqldb_lineage

0 Replies