After change log analytics workspace VM shows "Enabling - Waiting for data" for hours

Regular Contributor


after changing the Log Analytics Worspace, the Azure Monitor shows "Enabling - Waiting for data" for my VMs This display has been up for several hours.

The VMs are also not monitored in the display.

As soon as I request values via the query, they are displayed correctly.

What can I do to see the display in Azure Monitor correctly again?





15 Replies

@Stefan Kießig 

Can you please respond to vminsights at microsoft dot com with details about your workspace ?

After 24hours everting was fine and the problem solved.

@Stefan Kießig the same problem started with us. It has been waiting for 2 days. I couldn't find what to do.

Adding @Xema Pathak, @Scott Kinghorn Hi, Are you able to query the data in Log Analytics ? InsightsMetrics | where Origin == "" | where Namespace == "Processor" and Name == "UtilizationPercentage" | summarize avg(Val) by bin(TimeGenerated, 15m), Computer, _ResourceId

@Ketan GhelaniI activate insight from the VM. When I look at the Monitor, I see the screenshot I shared.

@ilker93 Any update on this?  I have the same issue.

@gaboh89 Continues. We opened a case but did not move forward.


Adding @XemaPathak and @Anitha Bagyam 

Can you please send a note to vminsights at microsoft dot com with case number ?



Can you please send a note to vminsights at microsoft dot com with workspace id ?  Also would appreciate if you open a case as well for tracking purposes.



@Stefan Kießig I have the same issue, but we have 8 other similar VMs where it worked and had no issues. 

Similar Issue, logged ticket. Struggling to come to a solution. 

two days ago VM's moved from 'Not Monitored' to 'Monitored' and required update on the monitoring agents. Ran the updates and completed successfully, but VM's stuck on 'upgrade available' state.



Can you please open up a support ticket then the team can investigate it further ?