SOLVED

Syntax Error in Logic App log query

%3CLINGO-SUB%20id%3D%22lingo-sub-962480%22%20slang%3D%22en-US%22%3ESyntax%20Error%20in%20Logic%20App%20log%20query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-962480%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20getting%20syntax%20error%20when%20I%20run%20a%20query%20in%20a%20Logic%20app%20logs.%20But%20this%20error%20happens%20just%20with%20some%20Logic%20app%20resources%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F151722iBB2CDDE696F37577%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_1.png%22%20title%3D%22clipboard_image_1.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20know%20why%20is%20this%20happening%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-962480%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%20Log%20Analytics%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EQuery%20Language%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-970433%22%20slang%3D%22en-US%22%3ERe%3A%20Syntax%20Error%20in%20Logic%20App%20log%20query%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-970433%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F434995%22%20target%3D%22_blank%22%3E%40esxJoaoIgor%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThe%20above%20error%20means%20that%20AzureMetrics%20table%20does%20not%20exists%20on%20the%20Log%20Analytics%20workspace.%20Some%20tables%20are%20created%20only%20when%20you%20start%20sending%20data%20to%20them.%20Basically%20in%20the%20case%20of%20AzureMetrics%20you%20need%20to%20send%20metrics%20from%20Azure%20resource%20via%20diagnostic%20settings%20configured.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Frequent Visitor

Hi

 

I'm getting syntax error when I run a query in a Logic app logs. But this error happens just with some Logic app resources

 

clipboard_image_1.png

 

Does anyone know why is this happening

 

1 Reply
best response confirmed by Stanislav Zhelyazkov (MVP)
Solution

Hi@esxJoaoIgor 

The above error means that AzureMetrics table does not exists on the Log Analytics workspace. Some tables are created only when you start sending data to them. Basically in the case of AzureMetrics you need to send metrics from Azure resource via diagnostic settings configured.