Azure Monitor "Upgrade available" doesn't go away

%3CLINGO-SUB%20id%3D%22lingo-sub-2324900%22%20slang%3D%22en-US%22%3EAzure%20Monitor%20%22Upgrade%20available%22%20doesn't%20go%20away%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2324900%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3C%2FP%3E%3CP%3EAll%20my%20VM%3As%20have%20status%20%22Upgrade%20Available%22%20and%20though%20I%20select%20a%20VM%20and%20click%20upgrade%20and%20upgrade%20is%20reported%20as%20successful%20the%20status%20doesn't%20go%20away.%3C%2FP%3E%3CP%3EWaited%20a%20couple%20of%20days%20but%20status%20is%20still%20%22Upgrade%20available%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20else%20seen%20this%20issue%20%3F%20This%20upgrade%20appeared%20sometime%20last%20week%20I%20believe.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2326393%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20Monitor%20%22Upgrade%20available%22%20doesn't%20go%20away%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2326393%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20same%20situation%20in%20my%20current%20subscription.%20Make%20sure%20you%20have%20all%20the%20selected%20resources%20upgraded%20and%20also%20ensure%20the%20Log%20Workspace%20-%26gt%3B%20VM%20-%26gt%3B%20connection%20status%20is%20healthy.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Seshadrr_0-1620221867234.png%22%20style%3D%22width%3A%20718px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F278435i1CB3D3C27781000B%2Fimage-dimensions%2F718x58%3Fv%3Dv2%22%20width%3D%22718%22%20height%3D%2258%22%20role%3D%22button%22%20title%3D%22Seshadrr_0-1620221867234.png%22%20alt%3D%22Seshadrr_0-1620221867234.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EWhen%20a%20Log%20Analytics%20workspace%20is%20upgraded%20to%20the%20latest%20version%20of%20Azure%20Monitor%20to%20VMs%2C%20it%20will%20upgrade%20the%20dependency%20agent%20on%20each%20of%20the%20VMs%20attached%20to%20that%20workspace.%20Each%20VM%20requiring%20upgrade%20will%20be%20identified%20in%20the%26nbsp%3B%3C%2FSPAN%3E%3CSTRONG%3EGet%20Started%3C%2FSTRONG%3E%3CSPAN%3E%26nbsp%3Btab%20in%20VM%20insights%20in%20the%20Azure%20portal.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUse%20powershell%20to%20update%20the%20insight%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESet-AzOperationalInsightsIntelligencePack%20-ResourceGroupName%20%3CRESOURCE-GROUP-NAME%3E%20-WorkspaceName%20%3CWORKSPACE-NAME%3E%20-IntelligencePackName%20%22VMInsights%22%20-Enabled%20%24True%3C%2FWORKSPACE-NAME%3E%3C%2FRESOURCE-GROUP-NAME%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENote%3A%20If%20any%20of%20the%20VM%20which%20has%20customized%20image%20%2C%20template%20provision%20based%20appliance%20(for%20eg%3A%20Zscaler%20appliance)%20might%20not%20enabled%20the%20extension%20of%20VM%20Insight%20that%20could%20be%20one%20of%20the%20reason%20the%20machine%20state%20%22Not%20connected%22%20and%20upgrade%20option%20shows%20as%20%22Upgrade%20available%22%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2329948%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20Monitor%20%22Upgrade%20available%22%20doesn't%20go%20away%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2329948%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F307733%22%20target%3D%22_blank%22%3E%40Seshadrr%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan't%20see%20that%20the%20dependency%20agent%20gets%20upgraded.%20Folder%20says%20version%26nbsp%3B9.10.8.14350%20wich%20is%20same%20on%20servers%20I%20haven't%20tried%20to%20upgrade.%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20see%20that%20the%20Microsoft.Azure.Diagnostics.IaaSDiagnostics%20is%20getting%20installed%20when%20triggering%20upgrade%20though%3A%3CBR%20%2F%3EBeginning%20a%20Windows%20Installer%20transaction%3A%20C%3A%5CPackages%5CPlugins%5CMicrosoft.Azure.Diagnostics.IaaSDiagnostics%5C1.18.0.5%5CInstrumentationEngine%5CInstrumentationEngine.Installer.msi%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20I%20check%20with%26nbsp%3BGet-AzOperationalInsightsIntelligencePack%20I%20can%20see%20that%20the%26nbsp%3BVMInsights%20already%20is%20enabled.%3CBR%20%2F%3ERan%20the%20Set%20command%20anyway%2C%20nothing%20happened.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Hi

All my VM:s have status "Upgrade Available" and though I select a VM and click upgrade and upgrade is reported as successful the status doesn't go away.

Waited a couple of days but status is still "Upgrade available"

 

Anyone else seen this issue ? This upgrade appeared sometime last week I believe.

3 Replies

I have same situation in my current subscription. Make sure you have all the selected resources upgraded and also ensure the Log Workspace -> VM -> connection status is healthy.

 

Seshadrr_0-1620221867234.png

 

When a Log Analytics workspace is upgraded to the latest version of Azure Monitor to VMs, it will upgrade the dependency agent on each of the VMs attached to that workspace. Each VM requiring upgrade will be identified in the Get Started tab in VM insights in the Azure portal.

 

Use powershell to update the insight

 

Set-AzOperationalInsightsIntelligencePack -ResourceGroupName <resource-group-name> -WorkspaceName <workspace-name> -IntelligencePackName "VMInsights" -Enabled $True

 

Note: If any of the VM which has customized image , template provision based appliance (for eg: Zscaler appliance) might not enabled the extension of VM Insight that could be one of the reason the machine state "Not connected" and upgrade option shows as "Upgrade available" 

@Seshadrr 

Can't see that the dependency agent gets upgraded. Folder says version 9.10.8.14350 wich is same on servers I haven't tried to upgrade.

 

Can see that the Microsoft.Azure.Diagnostics.IaaSDiagnostics is getting installed when triggering upgrade though:
Beginning a Windows Installer transaction: C:\Packages\Plugins\Microsoft.Azure.Diagnostics.IaaSDiagnostics\1.18.0.5\InstrumentationEngine\InstrumentationEngine.Installer.msi

 

If I check with Get-AzOperationalInsightsIntelligencePack I can see that the VMInsights already is enabled.
Ran the Set command anyway, nothing happened.

Someone must have done something in the background because today all upgrade notifications are gone. Regardless if I tried to upgrade a VM or not, they are all fine as of 06:00 UTC today.