SOLVED

Agent is not getting right Counter

%3CLINGO-SUB%20id%3D%22lingo-sub-891288%22%20slang%3D%22en-US%22%3EAgent%20is%20not%20getting%20right%20Counter%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-891288%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Team%20and%20Experts%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EToday%20i%20have%20seen%20a%20weird%20issue%20in%20Log%20Analytics.%3C%2FP%3E%3CP%3EWhen%20I%20am%20checking%20Free%20Space%20on%20Server%20using%20PowerShell%20or%20by%20logging%20into%20then%20getting%20its%2097.98%25%20free.%3C%2FP%3E%3CP%3EBut%20when%20i%20am%20checking%20the%20same%20using%20KQL%20in%20my%20Log%20Analytics%20the%20it%20is%20reflecting%2077.322%2C%20Why%20this%20is%20happening.%3C%2FP%3E%3CP%3EBecause%20of%20this%20I%20am%20geeing%20false%20alert%2C%20Is%20it%20a%20bug%20or%20what%3F%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-left%22%20style%3D%22width%3A%20988px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F135287iB553E364F6CD42C9%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22KQL_ALA_1.JPG%22%20title%3D%22KQL_ALA_1.JPG%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-left%22%20style%3D%22width%3A%20330px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F135288iE106AE35337ED3DE%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22KQL_ALA_2.JPG%22%20title%3D%22KQL_ALA_2.JPG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CDIV%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-891288%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAgents%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EAzure%20Log%20Analytics%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EQuery%20Language%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-891372%22%20slang%3D%22en-US%22%3ERe%3A%20Agent%20is%20not%20getting%20right%20Counter%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-891372%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F184511%22%20target%3D%22_blank%22%3E%40Gourav%20Kumar%3C%2FA%3E%20%2C%3C%2FP%3E%0A%3CP%3EYou%20are%20looking%20at%20two%20different%20counters.%20One%20is%20percentage%2C%20the%20other%20is%20GBs.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-891387%22%20slang%3D%22en-US%22%3ERe%3A%20Agent%20is%20not%20getting%20right%20Counter%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-891387%22%20slang%3D%22en-US%22%3E%3CP%3EOpps%20!%20Yes%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F9172%22%20target%3D%22_blank%22%3E%40Stanislav%20Zhelyazkov%3C%2FA%3E%26nbsp%3BI%20just%20missed%20it.%3C%2FP%3E%3CP%3EIts%20a%20long%20day%20with%20bundle%20of%20stuff.%26nbsp%3B%20my%20bad%20%3Ap%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Hi Team and Experts,

 

Today i have seen a weird issue in Log Analytics.

When I am checking Free Space on Server using PowerShell or by logging into then getting its 97.98% free.

But when i am checking the same using KQL in my Log Analytics the it is reflecting 77.322, Why this is happening.

Because of this I am geeing false alert, Is it a bug or what?

KQL_ALA_1.JPGKQL_ALA_2.JPG

 

 
2 Replies
best response confirmed by Stanislav Zhelyazkov (MVP)
Solution

Hi@Gourav Kumar ,

You are looking at two different counters. One is percentage, the other is GBs.

Opps ! Yes @Stanislav Zhelyazkov I just missed it.

Its a long day with bundle of stuff.  my bad :p